Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-19-04, 11:42 AM   #85
bulat
Registered User
 
Join Date: Nov 2004
Posts: 3
Default Re: Black screen with nvidia 6629 driver

When will be the next driver release?
bulat is offline   Reply With Quote
Old 12-22-04, 03:27 AM   #86
pmrussell892
Registered User
 
Join Date: Dec 2004
Posts: 1
Default Re: Black screen with nvidia 6629 driver

where do I pick up 6111. I go to your site nvidia.com/object/linuc.html and all I see is the 6229
pmrussell892 is offline   Reply With Quote
Old 12-22-04, 05:27 AM   #87
dmantamp
Registered User
 
Join Date: Dec 2004
Posts: 2
Default Re: Black screen with nvidia 6629 driver

You can find in acrhive section....

http://www.nvidia.com/object/linux_display_archive.html
dmantamp is offline   Reply With Quote
Old 12-22-04, 05:12 PM   #88
antonyhilliard
Registered User
 
Join Date: Dec 2004
Posts: 1
Default Re: Black screen with nvidia 6629 driver

kernel 2.6.9, Debian sid, Intel PII mobo (BX440?), NVidia TNT2 on AGP, same problem. Awaiting updates...
antonyhilliard is offline   Reply With Quote
Old 12-26-04, 03:59 AM   #89
GermanHulkster
Registered User
 
Join Date: Dec 2004
Posts: 6
Default Re: Black screen with nvidia 6629 driver

Same problem here kernel 2.6.10 or 2.6.7. Using Xorg, but the problem also occurs with XFree.

The card is a GF MX 4000 connected to a 19"TFT via DVI.

6111 works just fine.

Ny Chipset is a NFORCE2

So from reading all the answers it can't be chipset specific, it cannot be xserver specific nor kernel specific, but it rather looks like a bug related to cards < MX 4000
GermanHulkster is offline   Reply With Quote
Old 01-04-05, 02:05 PM   #90
rjenkins
Registered User
 
Join Date: Jan 2005
Posts: 1
Default Re: Black screen with nvidia 6629 driver

Same here, nvidia logo with, after a while, a line at the top left of the screen.

- I'm trying to get get 3d acceleration working for the first time (on Linux). Spent two days searching for possible solutions before finding this topic...
Using a geforce 4 MX 440 AGP card, Gigabyte K7VT600 (VIA) M/B.

I had the problem from the first install of the driver, assumed it was due to an old kernel (2.4.21) so updated the kernel first to 2.4.28 & now 2.6.10

Since reading the other comments in this topic, I've tried uninstalling the new driver & using the 6111 version, but that will not build on my system (possibly the kernel is now too new??).

The 6629 one builds and installs fine.

I can get a desktop with nvagp at 0 - 2, but it corrupts rapidly with opening & closing menus etc. and is not useable. With nvagp commented out or set to 3, it fails.
.../agp/status is only given as enabled with the settings that fail, so this looks to be somehow connected.
rjenkins is offline   Reply With Quote
Old 01-04-05, 11:50 PM   #91
welly_nv
-geek-
 
Join Date: Apr 2004
Posts: 5
Cool Re: Black screen with nvidia 6629 driver

I'm currently using debian unstable (sid) with 2.6.9 smp kernel, NVIDIA GeForce4 MX 440, and NVIDIA driver 6629.
It worked well before I rebooted my box yesterday, and X just failed with no significant report in log.
Trying to reinstalling the driver again but didn't work ( by executing nvidia-installer after extracting the pkg.run )
Then I tried the last solution read from the README file with executing make install within extracted pkg.run directory.
Works fine now.......cheers.....

-
__________________
________________________________________________


ms linuz

________________________________________________
welly_nv is offline   Reply With Quote
Old 01-08-05, 01:59 PM   #92
maxresch
Geforce FX 5600 XT
 
Join Date: Oct 2003
Location: Krems, Austria
Posts: 17
Send a message via ICQ to maxresch
Default Re: Black screen with nvidia 6629 driver

Now I've got a Geforce fx 5600 XT and the X Server runs quite nice.

The problem really seems to be releated to the older NVidia cards (before i bought the Geforce FXi had a Geforce 440 MX)
maxresch is offline   Reply With Quote

Old 01-14-05, 12:59 PM   #93
efka
Registered User
 
Join Date: Jan 2005
Posts: 1
Default Re: Black screen with nvidia 6629 driver

I've got the same problem, black screen and a single line of pixels on the top left corner. But I found out some funny things:

If I start X with startx from the console, this black screen appears. If I open another console then and give the command

xterm -display :0.0 -geometry -0-0

the xterm is invisual but it is definitely there at the bottom right corner. If I move the mouse to the xterm position, I can enter commands. First I tried a simple

echo hello > /tmp/hello

and the file /tmp/hello is created. Even if I enter a

glxinfo > /tmp/test

The file /tmp/test contains the correct output of glxinfo including the direct rendering yes line. After that I tried to change the background color using

xsetroot -solid red

and the small line at the top of the screen turns red. So this line seems to be the representation of the root window.

Maybe this helps to figure out the problem.
efka is offline   Reply With Quote
Old 01-29-05, 08:02 PM   #94
toman
Registered User
 
Join Date: Jan 2005
Posts: 3
Default Re: Black screen with nvidia 6629 driver

Sorry if I'm off limits here, but after reading this thread, I can say I have the exact same problems with the 6111 driver. I also have huge problems in Windows XP where I constantly get a "infinite loop" error in nv_disp.dll.

When there isn't a black screen in linux or a blue screen in Windows, the symptoms are just plain image freeze. I can ssh into linux and see X taking 99.9% of the CPU, but on the box itself I'm unable to use the keyboard or mouse. This freeze seems to be triggered by anything that has to do with graphics moving: menus appearing, video played, games, anything.

If I disable agp (option "nvagp" "0") in linux everything seems to run smoothly.

No errors are produced in neither Windows XP nor Suse 9.2, and any configuration other that mentioned make up the same result.

(I am not yet able to start X with the 6629 driver)

Config:
MB: Asus a7v8x-x
Memory: 2x256MB Geil Value PC3200
GFX: Asus/Nvidia MX 4000 (128MB)
Monitor: Samsung Syncmaster 753dfx
toman is offline   Reply With Quote
Old 01-31-05, 04:42 PM   #95
mistermachine
Registered User
 
Join Date: Nov 2004
Posts: 40
Default Re: Black screen with nvidia 6629 driver

same problem here:

fedora core 2 with low-latency patched 2.6.10 kernel, geforce mx 440, asus a7n8x-x, amd athlon 2400 (underclocked to 1800) blah blah blah - i'm sure *another* list of specs is hardly going to help ...

this is really getting beyond a joke ... why the hell are we, the users, being left to develop nvidia's drivers for them? i'm only pretty new to linux, so i'm not really satisfied with the "just revert to 6111" "solution", as this entails screwing up my hard-won audio workstation ... i'm not really in the mood to do a billion bug reports that require installing/reinstalling drivers, setting up debugging etc - unless nvidia *fully* open source their drivers, or start paying their forum users for doing the testing that the driver developers obvioulsy never did!

this problem has been *known* for almost 3 months now - that's a lifetime in open source ...

i really feel i wasted my money on an nvidia agp card - in the 8 months i've had it, i've been able to use the 3d acceleration for maybe a few weeks.

RELEASE SOME NEW DRIVERS!!!!!!!!!!!!!!!
mistermachine is offline   Reply With Quote
Old 02-01-05, 05:10 AM   #96
linkin
Registered User
 
Join Date: Jan 2005
Posts: 15
Default Re: Black screen with nvidia 6629 driver

I've the same problem, (not the only one here :P)... But I've got a newer Card... the GeForce 6600GT (AGP)... the screen gets black, and returned to console... I will test, to upgrade my Bios (I use the nForce2 chipset...)

What ever... PLEASE FIX THE PROBLEMS!!!!!!

(@mistermachine: I think like you... but, i'm happy, that nvidia builds some drivers for there cards...)
linkin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM

All times are GMT -5. The time now is 09:37 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.