Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-29-02, 04:19 PM   #1
icemanjer
Registered User
 
Join Date: Oct 2002
Posts: 5
Default redhat 8 - no nvnet on nForce

Alright, I got the integrated video to work with my RedHat 8, now the next step is to get the integrated ethernet and sound to work. Using the source Tarballs, I compiled the nvnet.o and nvaudio.o modules, and went an tried to insmod them.

For the nvnet.o, it says the module is compiled with gcc version 2.0 while the kernel is compiled with gcc version 3.0. I know I have gcc 3.2, so I went to dig a bit deeper. I went in to do a 'make clean' and see if I can compile the modules manually, and it turns out the culprit (as it seems) is "nvnetlib.o" which came as part of the tarball without the source code.

Since the associated RPM are for RedHat 7.3, is it possible that "nvnetlib.o" was compiled with gcc version 2.0, and therefore when I link that into the "nvnet.o" module and try to do a "insmod", RedHat complained?

And where can I get the source for "nvnetlib.o" so I can compile that with my gcc 3.2 so I can use it on my system?

Thanks!
icemanjer is offline   Reply With Quote
Old 10-29-02, 05:33 PM   #2
icemanjer
Registered User
 
Join Date: Oct 2002
Posts: 5
Default

well.. after a few searches on Google, turns out other people are having this issue too, that nvnetlib.o was compiled with gcc 2.x while the RH 8.0 kernel is compiled with the updated gcc 3.x.

*sigh*... maybe nVidia will release a recompiled version of the nvnet driver....
icemanjer is offline   Reply With Quote
Old 11-01-02, 07:26 PM   #3
borgzilla
Linux Assimilator
 
Join Date: Aug 2002
Location: Scottsdale, AZ
Posts: 72
Default

You can try GCC 2.95-3 (still the best )
http://gcc.gnu.org/gcc-2.95/

Here's how to install alternative GCC without removing default version.

http://gcc.gnu.org/faq.html#multiple
borgzilla is offline   Reply With Quote
Old 11-02-02, 01:21 AM   #4
icemanjer
Registered User
 
Join Date: Oct 2002
Posts: 5
Default

no need now!
installed the RPM just released, works beautifully
icemanjer is offline   Reply With Quote
Old 11-12-02, 11:29 PM   #5
nacrotek
Registered User
 
Join Date: Nov 2002
Posts: 3
Default

How'd you get the integrated video to work? I havent been able to get an X session started that didnt immediately crash with the integrated video.

I am using RH 8 on the Asus A7N266-VM
nacrotek is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 03:20 AM
nforce on RedHat 8.0 shaun680 NVIDIA Linux 8 10-17-02 01:36 PM
redhat 8 nforce network success cd21 NVIDIA Linux 2 10-07-02 09:48 PM
nforce & redhat 8.0 incin NVIDIA Linux 3 10-03-02 02:10 PM
Newby question about nforce.... superconti NVIDIA Linux 2 09-08-02 12:46 AM

All times are GMT -5. The time now is 09:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.