Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-11-04, 07:41 AM   #1
hildeb
Registered User
 
hildeb's Avatar
 
Join Date: Nov 2004
Posts: 11
Default 1.0.6629 drivers unusable with WXGA laptop

My XF86Config-4 that used to work fine with the previous nvidia drivers now gives me this on my laptop:



It looks like an interlaced picture, with each half drawn above the other.

The same XF86Config does work with the "nv" driver from XFree.

lspci -v output:
============

0000:01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 420 Go 32M] (rev a3) (prog-if 00 [VGA])
Subsystem: Hewlett-Packard Company: Unknown device 006d
Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 11
Memory at ea000000 (32-bit, non-prefetchable) [size=16M]
Memory at f8000000 (32-bit, prefetchable) [size=64M]
Memory at fc000000 (32-bit, prefetchable) [size=512K]
Capabilities: [60] Power Management version 2
Capabilities: [44] AGP version 2.0

/proc/cpuinfo:
===========

processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 4
model name : AMD Athlon(tm) XP Processor 3000+
stepping : 8
cpu MHz : 1596.030
cache size : 256 KB

Output from /proc/driver/nvidia/card/0:
=============================

Model: GeForce4 420 Go 32M
IRQ: 11
Video BIOS: ??.??.??.??.??
Card Type: AGP

Please note that the VideoBIOS version is not being displayed. The XFree logfile has it, though (see attachment)

The machine:
==========

This is a hp pavilion zv5000 laptop with a WXGA 1280x800 resolution TFT screen. But "normal" resolutions don't work either - I always get totally garbled output.

I tried 2.6.9, 2.6.9-ac6 through ac8.
Attached Files
File Type: txt XF86Config-4.nvidia.txt (4.0 KB, 362 views)
File Type: txt XFree86.0.log.txt (32.9 KB, 296 views)

Last edited by hildeb; 11-11-04 at 03:22 PM. Reason: added lots of info
hildeb is offline   Reply With Quote
Old 11-11-04, 02:09 PM   #2
rhodes187
Registered User
 
Join Date: Jun 2004
Posts: 14
Default Re: Unusable output with the new 1.0.6629 drivers

I get VERY similar results with my Dell laptop, except I have colored bars going down the right hand side of my screen as well. Seems like these new drivers don't handle laptops well.
rhodes187 is offline   Reply With Quote
Old 11-11-04, 03:00 PM   #3
hildeb
Registered User
 
hildeb's Avatar
 
Join Date: Nov 2004
Posts: 11
Default Re: Unusable output with the new 1.0.6629 drivers

Quote:
Originally Posted by rhodes187
I get VERY similar results with my Dell laptop, except I have colored bars going down the right hand side of my screen as well. Seems like these new drivers don't handle laptops well.
Well, at least you do have some output.
hildeb is offline   Reply With Quote
Old 11-13-04, 06:08 PM   #4
hildeb
Registered User
 
hildeb's Avatar
 
Join Date: Nov 2004
Posts: 11
Default Re: Unusable output with the new 1.0.6629 drivers

Quote:
Originally Posted by hildeb
Well, at least you do have some output.
I just reverted back to 6111 and everything's well again.
hildeb is offline   Reply With Quote
Old 12-24-04, 01:03 PM   #5
Dooglio
Registered User
 
Join Date: Nov 2004
Posts: 2
Default Re: Unusable output with the new 1.0.6629 drivers

I, too, have an HP Pavilion zv5000 with XGA same as you, and I have a really screwed up display with 6628. But, if I revert back to 6111, it goes back to working properly.
__________________
Dooglio
Dooglio is offline   Reply With Quote
Old 12-24-04, 05:52 PM   #6
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Unusable output with the new 1.0.6629 drivers

There've been reports of a similar problem with other GeForce4 4x0 Go notebooks, with which this workaround seems to help: http://www.nvnews.net/vbulletin/show...&postcount=211. It might be worth a try.
zander is offline   Reply With Quote
Old 12-25-04, 06:43 AM   #7
hildeb
Registered User
 
hildeb's Avatar
 
Join Date: Nov 2004
Posts: 11
Default Re: Unusable output with the new 1.0.6629 drivers

Yes. So the bug is sort of confirmed. Unfortunately this doesn't help us
hildeb is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
Creative drivers ? SparrowHawk General Hardware 39 11-18-02 08:03 AM
3123 drivers and inspiron 8100 not working w3a5e1 NVIDIA Linux 10 10-14-02 08:22 PM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM

All times are GMT -5. The time now is 09:51 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.