Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-13-04, 08:51 AM   #1
pucko
Registered User
 
Join Date: Nov 2004
Location: Haninge, Sweden
Posts: 6
Default Fedora Core 3 and nVidia drivers - Solution

So I just installed Fedora Core 3 plus the nVidia drivers on my Amd64, and the result was a system that hang on "Configuring kernel parameters.

Here what I did to fix it:

1) Interrupt Grub from booting, edit the bootparameters with "e"-key, and remove the "rhgb"-parameter from the boot parameters. The continue booting normally. (This will skip the graphical boot in Fedora.)

2) Fedora complains about not being able to start GDM, ignore it and cancel all questions to get to the login prompt.

3) Login as root, enter "init 3" to go to single-user mode. Enter "modprobe nvidia" to load the nvidia-module.

4) Finally, enter "cp -a /dev/nvidia* /etc/udev/devices/" to fix the boot problem.

5) Now just enter "init 5" and you're back in business.

This solved my problem and now it boots fine. Maybe my experience will help others too?

Fedora Core 3 Amd64 (final release)
Geforce 2MX400
nVidia Amd64 drivers (NVIDIA-Linux-x86_64-1.0-6629)
pucko is offline   Reply With Quote
Old 11-13-04, 10:03 AM   #2
Spyke
Foxie
 
Spyke's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 618
Send a message via AIM to Spyke Send a message via MSN to Spyke Send a message via Yahoo to Spyke
Default Re: Fedora Core 3 and nVidia drivers - Solution

This post relates to any FC3 install, so somebody should sticky this thread so others can see it. Many people have posted about this problem.
__________________
Gaming:
Intel i7 980X @ 4GHz | ASUS Rampage III Extreme | GTX 480 3Way SLI @ 900Mhz | Koolance VID-NX480 | Corsair Obsidian 700D
Corsair H70 CPU Cooler | EK-FB RE3 | Corsair AX1200 | Black Ice SR1 360 | 240GB OCZ Revodrive X2 SSD | Windows 7 Ultimate
12GB Corsair Dominator GT @ 8-8-8-24-1T DDR3-1600 | Onkyo TX SR-707 | 70" Sharp Aquos LCD | KEF Audio 5.1 C3/C6LCR/C7
Workstation:
Intel i7 920 D0 @ 4GHz | ASUS Rampage II Extreme | GTX 480 @ 800Mhz | Koolance VID-NX480 | Lian-Li V1200B | Corsair HX1000
EK NB ASUS HP | Watercool HeatKiller 3.0 | Feser Extreme X-360 | 2x160GB Intel X25-M SSD RAID0 | 4x2TB WD20EARS RAID10
12GB Corsair Dominator @ 8-8-8-24-1T DDR3-1600 | Creative X-Fi Titanium | Pioneer DVR-212D | Gentoo Linux
Dell 3008WFP | JohnBlue JB3 | CityPulse DA2.03e II DAC | KingRex T20U w/ Modded Auricaps & PSU | Glow Audio Sub One
Server:
Quad Socket Opteron 8356 (16 cores) @ 2.3GHz | Supermicro H8QMi-2 | Supermicro 2U Chassis | Redundant 1200W PSU
32GB 2GBx16 DDR2-667 ECC | 4x 300GB Cheetah SAS RAID10 | Adaptec 5805 512MB w/BBU | Colocated | Gentoo Linux
Spyke is offline   Reply With Quote
Old 11-13-04, 10:45 AM   #3
morr
Registered User
 
Join Date: Nov 2004
Location: Virginia
Posts: 4
Default Re: Fedora Core 3 and nVidia drivers - Solution

Quote:
3) Login as root, enter "init 3" to go to single-user mode. Enter "modprobe nvidia" to load the nvidia-module.

4) Finally, enter "cp -a /dev/nvidia* /etc/udev/devices/" to fix the boot problem.

5) Now just enter "init 5" and you're back in business.

This solved my problem and now it boots fine. Maybe my experience will help others too?
A couple of points. init 3 isn't single user mode. It's standard multi-user mode, non-graphical log in. You could achive the same result by either changing the default runlevel in /etc/inittab, or adding a '3' to the end of the boot parameters at boot time interactively or thru editing /boot/grub.conf.

Secondly, I have a similar config, though 32 bit. I would be curious to see if you could logout and back in several times after doing the above. I can get the system to work (mostly) the first time I start X with 6629 drivers, but subsequent startups cause the system to hang hard. I am reasonably sure it's related to the 2.6 kernel, but it would be interesting to know if the same behaviour occurred on a 64 bit system.
morr is offline   Reply With Quote
Old 11-13-04, 11:33 AM   #4
pucko
Registered User
 
Join Date: Nov 2004
Location: Haninge, Sweden
Posts: 6
Default Re: Fedora Core 3 and nVidia drivers - Solution

No problem here. I've rebooted several times, and it just works.
I did however ran an up2date to update everything to current before installing the nv-drivers.
pucko is offline   Reply With Quote
Old 11-13-04, 02:15 PM   #5
Seve
Registered User
 
Join Date: Oct 2004
Posts: 10
Default Re: Fedora Core 3 and nVidia drivers - Solution

Pucko:

Just wanted to pass on a note ot thanks

Your solution seems to work.

Seve
Seve is offline   Reply With Quote
Old 11-13-04, 09:24 PM   #6
Spyke
Foxie
 
Spyke's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 618
Send a message via AIM to Spyke Send a message via MSN to Spyke Send a message via Yahoo to Spyke
Default Re: Fedora Core 3 and nVidia drivers - Solution

Can somebody sticky this???????
Or are we going to have the same situation like last time with the million threads of 2.6.9 not working due to a VMALLOC symbol?
__________________
Gaming:
Intel i7 980X @ 4GHz | ASUS Rampage III Extreme | GTX 480 3Way SLI @ 900Mhz | Koolance VID-NX480 | Corsair Obsidian 700D
Corsair H70 CPU Cooler | EK-FB RE3 | Corsair AX1200 | Black Ice SR1 360 | 240GB OCZ Revodrive X2 SSD | Windows 7 Ultimate
12GB Corsair Dominator GT @ 8-8-8-24-1T DDR3-1600 | Onkyo TX SR-707 | 70" Sharp Aquos LCD | KEF Audio 5.1 C3/C6LCR/C7
Workstation:
Intel i7 920 D0 @ 4GHz | ASUS Rampage II Extreme | GTX 480 @ 800Mhz | Koolance VID-NX480 | Lian-Li V1200B | Corsair HX1000
EK NB ASUS HP | Watercool HeatKiller 3.0 | Feser Extreme X-360 | 2x160GB Intel X25-M SSD RAID0 | 4x2TB WD20EARS RAID10
12GB Corsair Dominator @ 8-8-8-24-1T DDR3-1600 | Creative X-Fi Titanium | Pioneer DVR-212D | Gentoo Linux
Dell 3008WFP | JohnBlue JB3 | CityPulse DA2.03e II DAC | KingRex T20U w/ Modded Auricaps & PSU | Glow Audio Sub One
Server:
Quad Socket Opteron 8356 (16 cores) @ 2.3GHz | Supermicro H8QMi-2 | Supermicro 2U Chassis | Redundant 1200W PSU
32GB 2GBx16 DDR2-667 ECC | 4x 300GB Cheetah SAS RAID10 | Adaptec 5805 512MB w/BBU | Colocated | Gentoo Linux
Spyke is offline   Reply With Quote
Old 11-15-04, 12:09 AM   #7
ExileInParadise
Registered User
 
Join Date: Dec 2003
Location: Pasadena, TX
Posts: 5
Default Re: Fedora Core 3 and nVidia drivers - Solution

Pucko,
Thanks very much for figuring out the udev updates needed to make the NVidia driver work through RHGB and persistent reboots.

Without the step to copy the /dev/nvidia* to /etc/udev/devices the NVidia driver would work, then "disappear" on the next reboot.

I have a Fedora Core 3, i686 box and your steps worked for me.

Thanks again!
ExileInParadise is offline   Reply With Quote
Old 11-15-04, 12:28 AM   #8
molten2
Registered User
 
Join Date: May 2004
Posts: 1
Default Re: Fedora Core 3 and nVidia drivers - Solution

same for me thx
molten2 is offline   Reply With Quote

Old 11-15-04, 08:30 AM   #9
ciper
Registered User
 
Join Date: Nov 2004
Posts: 1
Default Re: Fedora Core 3 and nVidia drivers - Solution

What about the problems with the TNT2 users? Has anyone got the latest drivers to work with this? Any patch available?
__________________
Machine specs :
Intel Pentium 4@2.66Mhz - 512Mb
RIVA TNT2 Model 64/Model 64 Pro
ciper is offline   Reply With Quote
Old 11-15-04, 09:01 AM   #10
stanmc
Registered User
 
Join Date: Oct 2004
Posts: 15
Default Re: Fedora Core 3 and nVidia drivers - Solution

Quote:
Originally Posted by pucko
Here what I did to fix it:

1) Interrupt Grub from booting, edit the bootparameters with "e"-key, and remove the "rhgb"-parameter from the boot parameters. The continue booting normally. (This will skip the graphical boot in Fedora.)
I haven't the foggiest idea of how to interrupt Grub, <newbie at this level> and I don't know about the "e"-key. Are you referring to the option of entering I for interactive? Could I just remove "rhgb" from the grub.conf file and achieve the same result?
stanmc is offline   Reply With Quote
Old 11-15-04, 09:21 AM   #11
jpmcc
Registered User
 
Join Date: Nov 2004
Posts: 3
Default Re: Fedora Core 3 and nVidia drivers - Solution

Quote:
Originally Posted by stanmc
I haven't the foggiest idea of how to interrupt Grub, <newbie at this level> and I don't know about the "e"-key. Are you referring to the option of entering I for interactive? Could I just remove "rhgb" from the grub.conf file and achieve the same result?
When you get to the grub screen where you can choose the OS, move the selection to another OS (if you have one configured). This stops the 'will boot in 5 secs' timer.

Move the selection back onto the Linux install that you are interested in and press 'e'. you are then presented with the contents of the grub.conf file for that entry. Select the line to edit, then press 'e' again and you are taken into the grub 'shell' where you can edit the line. I think, pressing enter takes you back, then pressing 'b' resumes the boot process.

I hope that is correct as I'm doing this from memory cos I'm not infront of a linux box at the moment, and I only discovered how to do that the other night, however there are prompts (I think).
jpmcc is offline   Reply With Quote
Old 11-15-04, 09:25 AM   #12
Groovel76
Registered User
 
Join Date: Nov 2004
Posts: 4
Default Re: Fedora Core 3 and nVidia drivers - Solution

Quote:
Originally Posted by stanmc
I haven't the foggiest idea of how to interrupt Grub, <newbie at this level> and I don't know about the "e"-key. Are you referring to the option of entering I for interactive? Could I just remove "rhgb" from the grub.conf file and achieve the same result?
At the menu where you choose what OS you want to boot just press E on your keyboard. Unless you have FC3 in which a splash screen was added so you don't see your choices unless you press ESC winthin 5 seconds or something. I can't remember, I removed that splash screen line from grub.conf after my first boot.

But yes you can edit grub.conf.
Groovel76 is offline   Reply With Quote
Old 11-15-04, 09:48 AM   #13
Groovel76
Registered User
 
Join Date: Nov 2004
Posts: 4
Default Fix doesn't stick through a reboot (semi-n00b)

I did some of the above fixes and they helped --X doesn't crash-- but nothing OpenGL works. I ran a screensaver from the command-line and I got this message:

Error: Could not open /dev/nvidiactl because the permissions
are too restrictive. Please see the FREQUENTLY ASKED QUESTIONS
section of /usr/share/doc/NVIDIA_GLX-1.0/README for steps
to correct.
Segmentation Fault

I read through the README and it describes this message and how to fix it which is:

It is likely that a security module for the PAM system may be
changing the permissions on the NVIDIA device files. In most cases
this security system works, but it can get confused. To correct this
problem it is recommended that you disable this security feature.
Different Linux distributions have different files to control this;
please consult with your distributor for the correct method of
disabling this security feature. As an example, if your system has
the file
/etc/security/console.perms
then you should edit the file and remove the line that starts with
"<dri>" (we have also received reports that additional references to
<dri> in console.perms must be removed, but this has not been verified
by NVIDIA). <<<< I had to remove one other <dri> line. root was the only user I could log in with. my username just flashed a quick CRITICAL message. commenting out the line fixed this problem<<<<

If instead your system has the file
/etc/logindevperms
then you should edit the file and remove the line that lists
/dev/nvidiactl. The above steps will prevent the PAM security system
from modifying the permissions on the NVIDIA device files. Next,
you will need to reset the permissions on the device files back
to their original permissions and owner. You can do that with the
following commands:
chmod 0666 /dev/nvidia* chown root /dev/nvidia*

Now I did the chmod and chown and OpenGL works fine after that but after a reboot I just get the error message again. I'll run

chmod 0666 /dev/nvidia* chown root /dev/nvidia*

again and everything works but if I reboot......I think you get the picture.

What can I do to make those privilege/ownership changes permanent?

Any help is greatly appreciated.
Groovel76 is offline   Reply With Quote
Old 11-15-04, 10:05 AM   #14
stanmc
Registered User
 
Join Date: Oct 2004
Posts: 15
Unhappy Re: Fedora Core 3 and nVidia drivers - Solution

Quote:
Originally Posted by Groovel76
At the menu where you choose what OS you want to boot just press E on your keyboard. Unless you have FC3 in which a splash screen was added so you don't see your choices unless you press ESC winthin 5 seconds or something. I can't remember, I removed that splash screen line from grub.conf after my first boot.

But yes you can edit grub.conf.
Thanks jpmcc and Groovel76. I'm learning Linux slowly, but I hope surely. Your reference to OS is I think a referernce to choose which Kernel, i.e. 2.6.9-1.667. Groovel76, you mentioned that you removed the splash screen line from grub.conf. Can you elaborate on which line that was. I am going to make a backup of my grub.conf and just remove the four letters rhgb and see if I get a correct boot.


I had 6111 running under FC2 and was playing doom3-demo. FC3 doesn't have the source code readily available and so I have to try 6629, unless I want to go through the hell of installing the source code. Driver 6629 freezes at the NVIDIA splash screen in FC3 and FC2 on my machine.
AMD 1700+ Palomino/Soyo K7VTAPro/512MB Ram/Leadtek MX4000

--update--
I removed the rhgb and installed 6629 with appropriate changes to xorg.conf and copied the files to etc/udev/devices as well as doing an rpm -e on Mesa-libGL modules. It still hangs on the NVIDIA splash screen after startx. Just going to let this rest for a week. If,by then, no updates from NVIDIA, I'll remove the files no longer needed and stay at regular x session without NVIDIA drivers or the possibility of completing doom3-demo.

Last edited by stanmc; 11-15-04 at 12:57 PM. Reason: Still won't get past the NVIDIA splash screen.
stanmc is offline   Reply With Quote
Old 11-15-04, 10:31 AM   #15
Groovel76
Registered User
 
Join Date: Nov 2004
Posts: 4
Default Splash Screen Oops

Hey yeah sorry I called it the wrong name. It's called hiddenmenu. I just commented it out. Rather worthless feature if you ask me.
Groovel76 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 12:52 PM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
nvidia drivers in a motherboard with AGP 1.0 (motherboard MVP3+) knocker NVIDIA Linux 1 08-19-02 01:57 AM
NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 XASCompuGuy NVIDIA Linux 6 08-02-02 11:53 AM

All times are GMT -5. The time now is 10:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.