Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-20-04, 05:36 PM   #1
tabmow
Registered User
 
Join Date: Nov 2004
Posts: 3
Exclamation FreeBSD 5.3-Release & Nvidia 6113

I installed the nvidia-driver port with complete success and went on to change Driver "nvidia" and commented out Load "dri" in my xorg.conf - I find that i had no problems in the xorg log no errors but when i run glxinfo or glxgears i get errors saying that it can't find a rgb buffered visual, i also get messages about agp.ko so i recompiled a new kernel without device agp and i still get the same problem. I had this very same problem when trying to install the nvidia driver's on mandrake 10.1 official as well. Does anyone know why this is happening? I followed the document to the point to no prevail. The card is a GF4 ti4600. Any help will be hugely appreciated.

Thankyou.
tabmow is offline   Reply With Quote
Old 11-20-04, 06:42 PM   #2
erek
 
erek's Avatar
 
Join Date: Jan 2004
Location: USA
Posts: 220
Send a message via ICQ to erek Send a message via AIM to erek
Default Re: FreeBSD 5.3-Release & Nvidia 6113

Quote:
Originally Posted by tabmow
I installed the nvidia-driver port with complete success and went on to change Driver "nvidia" and commented out Load "dri" in my xorg.conf - I find that i had no problems in the xorg log no errors but when i run glxinfo or glxgears i get errors saying that it can't find a rgb buffered visual, i also get messages about agp.ko so i recompiled a new kernel without device agp and i still get the same problem. I had this very same problem when trying to install the nvidia driver's on mandrake 10.1 official as well. Does anyone know why this is happening? I followed the document to the point to no prevail. The card is a GF4 ti4600. Any help will be hugely appreciated.

Thankyou.
make sure you have
Quote:
Load "glx"
you don't need GLcore...
in your video card device section try adding

Quote:
Option "NvAgp" "1"
erek is offline   Reply With Quote
Old 11-21-04, 06:05 AM   #3
tabmow
Registered User
 
Join Date: Nov 2004
Posts: 3
Default Re: FreeBSD 5.3-Release & Nvidia 6113

I tried what you said and i still have no luck. I get this message coming up to the console: NVRM: Detecting agp.ko - aborting Nvidia AGP Setup!

I am going to include my xorg.conf and log for troubleshooting, i don't know what else to do though.

Thanks in advance ;oP
Attached Files
File Type: txt Xorg.0.log.txt (25.4 KB, 172 views)
File Type: txt xorg.conf.txt (2.5 KB, 210 views)
tabmow is offline   Reply With Quote
Old 11-21-04, 06:17 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: FreeBSD 5.3-Release & Nvidia 6113

You're seeing two different problems, both of which are easily solvable. The first is that you're requesting the use of NvAGP, with FreeBSD's AGPGART driver present; the easiest fix for this is to add hint.agp.0.disabled="1" to /boot/device.hints (make sure you reboot). The second problem is that you're running X at depth 8; to address this, add DefaultDepth 24 to the Screen section of your Xorg configuration file.
zander is offline   Reply With Quote
Old 11-21-04, 06:36 AM   #5
tabmow
Registered User
 
Join Date: Nov 2004
Posts: 3
Default Re: FreeBSD 5.3-Release & Nvidia 6113

Thanks heaps mate.
Your a legend!

24038 frames in 5.0 seconds = 4807.600 FPS

Woohoo!
tabmow is offline   Reply With Quote
Old 12-01-04, 05:11 AM   #6
JJ test
Registered User
 
Join Date: Dec 2004
Posts: 2
Default Re: FreeBSD 5.3-Release & Nvidia 6113

Zander's fix for adding the line to device.hints didn't work for me. I rebooted but I still get the same error. This nVidia driver installer DOESN'T WORK for my expensive video card. I can't do my work! I want to disable agp.ko by default from the installer please!

How can I do this? Please help.
JJ test is offline   Reply With Quote
Old 12-01-04, 06:19 AM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: FreeBSD 5.3-Release & Nvidia 6113

The device.hints approach to disabling agp.ko only works with recent (past FreeBSD 5.2.1, e.g. FreeBSD 5.3) kernels; on systems using earlier kernels, the kernel needs to be rebuilt w/o agp.ko support (this is beyond the Makefile's capabilities).
zander is offline   Reply With Quote
Old 12-01-04, 07:06 AM   #8
JJ test
Registered User
 
Join Date: Dec 2004
Posts: 2
Default Re: FreeBSD 5.3-Release & Nvidia 6113

Thanks Zander. Yes I'm using FreeBSD 4.10. I'll look into rebuilding it without agp.ko support.

Again thanks very much for your quick and kind response.
JJ test is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA, please release updated 290.xx drivers for new kernels and X.org versions artem NVIDIA Linux 19 08-25-12 09:02 AM
FreeBSD 9 Release with Nvidia 550 Ti configuration issues goga NVIDIA FreeBSD 0 05-23-12 08:34 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Will NVIDIA always be behind? (in release dates) Philibob Rumor Mill 14 08-16-02 12:48 AM

All times are GMT -5. The time now is 09:41 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.