Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-04-02, 09:26 AM   #1
dmw400
Guest
 
Posts: n/a
Default RH7.3 and nForce - can't find the module

I've torn my hair out over this one - I've followed the nVidia instructions (using the tarball) to the letter, and when I start X (either with startx or xinit) I get:

(I have K7N420 Pro motherboard, with the nForce chipset)

... previous bits snipped ...

(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "v4l"
(II) Loading /usr/X11R6/lib/modules/drivers/linux/v4l_drv.o
(II) Module v4l: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.0.1
ABI class: XFree86 Video Driver, version 0.5
(II) LoadModule: "nvidia"
(WW) Warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.3
(II) v4l driver for Video4Linux
(II) Primary Device is: PCI 02:00:0
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.

I've tried aliasing it in modules.conf, tried using "NVdriver" as the module string (as that is what the actual binary is named) and no luck.

What am I missing?

Thanks in advance for any insight - it is greatly appreciated!
  Reply With Quote
Old 08-04-02, 10:49 AM   #2
etr
Registered User
 
Join Date: Aug 2002
Location: NC, US
Posts: 55
Default

OK, let's back up and go over things point by point.

The nForce drivers for Linux only include drivers for the network and sound--they do not cover the video. To run X, you will need to download the nVidia video drivers for Linux. It sounds like you have done this, but it never hurts to check.

There are two components that must be installed for X to work. The first is a kernel module named NVdriver, and the second is the X driver (which needs the kernel module to work).

Once you have compiled and installed the appropriate drivers, you need to modify some configuration files.

Again, it sounds like you've done this. As a next step, I would recommend doing an /sbin/lsmod before starting X. If "NVdriver" does not show up, load it manually using "modprobe NVdriver".

If manually loading NVdriver does not help, the problem is probably in your XFree86 configuration. You will want to make sure you are loading XGL and are not loading DRI. Also, the driver name used should be "nvidia" instead of "nv".

If manually loading the NVdriver module helps, your problem is likely with /etc/modules.conf. This file should contain the following line:

alias char-major-195 NVdriver
etr is offline   Reply With Quote
Old 08-04-02, 07:02 PM   #3
dmw400
Guest
 
Posts: n/a
Default

Thanks, etr - I went over it all twice and just could not figure out what I had missed. So, since I didn't have anything vital on the machine, I started over from scratch. I've installed the RPMs, (base RH7.3 on an athlon) and now startx is met with the following (warning - lots of output spam )

[root@tiamat root]# startx


XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-8) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.17-0.13smp i686 [ELF]
Build Host: daffy.perf.redhat.com

Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Aug 5 08:05:41 2002
(==) Using config file: "/etc/X11/XF86Config-4"
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

-=-
Running startx again with --verbose 5 and --logverbose 5 yields the following for an XFree86.0.log (running "X" instead gets a segmentation fault):

XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-8) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.17-0.13smp i686 [ELF]
Build Host: daffy.perf.redhat.com

Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Aug 5 08:01:38 2002
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "XFree86 Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "ViewSonic P810"
(**) | |-->Device "NVIDIA GeForce 2 MX (generic)"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "unix/:7100"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.5
XFree86 XInput driver : 0.3
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.3
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5

... lots of resource settings - too long to post ...

[20] -1 0x00005020 - 0x0000502f (0x10) IX[b]
[21] -1 0x00005030 - 0x0000503f (0x10) IX[b]
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.2960
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "v4l"
(II) Loading /usr/X11R6/lib/modules/drivers/linux/v4l_drv.o
(II) Module v4l: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.0.1
ABI class: XFree86 Video Driver, version 0.5
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.2960
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.3
(II) v4l driver for Video4Linux
(II) NVIDIA XFree86 Driver 1.0-2960 Tue May 14 07:45:20 PDT 2002
(II) NVIDIA: NVIDIA driver for: RIVA TNT, RIVA TNT2, Vanta,
RIVA TNT2 Ultra, RIVA TNT2 Model 64, Aladdin TNT2, GeForce 256,
GeForce DDR, Quadro, GeForce2 MX/MX 400, GeForce2 MX 100/200,
Quadro2 MXR/EX/Go, GeForce2 Integrated GPU, GeForce2 GTS,
GeForce2 Ti, GeForce2 Ultra, Quadro2 Pro, GeForce4 MX 460,
GeForce4 MX 440, GeForce4 MX 420, Quadro4 500/550 XGL,
Quadro4 200/400 NVS, GeForce3, GeForce3 Ti 200, GeForce3 Ti 500,
Quadro DCC, GeForce4 Ti 4600, GeForce4 Ti 4400, GeForce4 Ti 4200,
Quadro4 900 XGL, Quadro4 750 XGL, Quadro4 700 XGL, GeForce2 Go,
GeForce4 440 Go, GeForce4 420 Go, GeForce4 420 Go 32M,
GeForce4 440 Go 64M, Quadro4 500 GoGL
(II) Primary Device is: PCI 02:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset GeForce2 Integrated GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0xee081000 - 0xee081fff (0x1000) MX[b]
[6] -1 0xee000000 - 0xee07ffff (0x80000) MX[b]
[7] -1 0xee083000 - 0xee0833ff (0x400) MX[b]
[8] -1 0xee082000 - 0xee082fff (0x1000) MX[b]
[9] -1 0xee080000 - 0xee080fff (0x1000) MX[b]
[10] -1 0xe8000000 - 0xebffffff (0x4000000) MX[b]
[11] -1 0xe0000000 - 0xe7ffffff (0x8000000) MX[b](B)
[12] -1 0xec000000 - 0xecffffff (0x1000000) MX[b](B)
[13] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[14] -1 0x00000000 - 0x000000ff (0x100) IX[b]
[15] -1 0x0000e800 - 0x0000e80f (0x10) IX[b]
[16] -1 0x0000e400 - 0x0000e47f (0x80) IX[b]
[17] -1 0x0000e000 - 0x0000e0ff (0x100) IX[b]
[18] -1 0x0000dc00 - 0x0000dc07 (0x8) IX[b]
[19] -1 0x00005000 - 0x0000501f (0x20) IX[b]
[20] -1 0x00005020 - 0x0000502f (0x10) IX[b]
[21] -1 0x00005030 - 0x0000503f (0x10) IX[b]
(II) resource ranges after probing:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0xee081000 - 0xee081fff (0x1000) MX[b]
[6] -1 0xee000000 - 0xee07ffff (0x80000) MX[b]
[7] -1 0xee083000 - 0xee0833ff (0x400) MX[b]
[8] -1 0xee082000 - 0xee082fff (0x1000) MX[b]
[9] -1 0xee080000 - 0xee080fff (0x1000) MX[b]
[10] -1 0xe8000000 - 0xebffffff (0x4000000) MX[b]
[11] -1 0xe0000000 - 0xe7ffffff (0x8000000) MX[b](B)
[12] -1 0xec000000 - 0xecffffff (0x1000000) MX[b](B)
[13] 0 0x000a0000 - 0x000affff (0x10000) MS[b]
[14] 0 0x000b0000 - 0x000b7fff (0x8000) MS[b]
[15] 0 0x000b8000 - 0x000bffff (0x8000) MS[b]
[16] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[17] -1 0x00000000 - 0x000000ff (0x100) IX[b]
[18] -1 0x0000e800 - 0x0000e80f (0x10) IX[b]
[19] -1 0x0000e400 - 0x0000e47f (0x80) IX[b]
[20] -1 0x0000e000 - 0x0000e0ff (0x100) IX[b]
[21] -1 0x0000dc00 - 0x0000dc07 (0x8) IX[b]
[22] -1 0x00005000 - 0x0000501f (0x20) IX[b]
[23] -1 0x00005020 - 0x0000502f (0x10) IX[b]
[24] -1 0x00005030 - 0x0000503f (0x10) IX[b]
[25] 0 0x000003b0 - 0x000003bb (0xc) IS[b]
[26] 0 0x000003c0 - 0x000003df (0x20) IS[b]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(**) NVIDIA(0): Depth 8, (--) framebuffer bpp 8
(==) NVIDIA(0): Default visual is PseudoColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xE0000000
(--) NVIDIA(0): MMIO registers at 0xEC000000


And then, nothing: segfault? Blah! Any insight would be greatly appreciated....
  Reply With Quote
Old 08-04-02, 09:58 PM   #4
etr
Registered User
 
Join Date: Aug 2002
Location: NC, US
Posts: 55
Default

Yeah, there's not much to go on there. If I were in your shoes, I think my next step would be to try to get things working with the standard XFree86 driver. This would verify that X is in decent shape before taking another swing at the nVidia driver.

Just for reference, what verbosity level did you set to get that much output?
etr is offline   Reply With Quote
Old 08-05-02, 12:14 PM   #5
dmw400
Guest
 
Posts: n/a
Default

The standard X driver hangs the system

It looks to be an issue with the mobo itself. The MSI forums have several "so you want to install linux on this, eh?" style posts, all of which indicate that you need to set the BIOS a certain way before you install the OS at all. So I guess I'll be going down that path now; hope it works.

In either case, to get all that output:

# startx -- -verbose 5 -logverbose 5

That's all you need to do. Thanks again for your help.
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nforce AGP & unreal 2003 nichos NVIDIA Linux 1 10-18-02 05:21 PM
redhat 8 nforce network success cd21 NVIDIA Linux 2 10-07-02 08:48 PM
Keep K7S5A or Upgrade To Nforce MB? Grechie CPUs, Motherboards And Memory 5 10-06-02 02:28 PM
RH7.3 + nForce 420-D + startx = FROZEN ctaggart NVIDIA Linux 7 10-04-02 01:48 AM
Rh7.3 & Nforce k0fcc NVIDIA Linux 10 08-11-02 06:10 PM

All times are GMT -5. The time now is 02:43 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.