Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-05-04, 04:52 PM   #1
ifaxsoln
Registered User
 
Join Date: Nov 2004
Posts: 21
Default Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

Folks,

I have a Quadro NVS 400 PCI card in one of the PCI-X slots of my Tyan Thunder K8W motherboard (S2885) running under Fedora Core 3 (FC3) and, thanks to a pointer from Zander to a kernel-2.6 patch for the 6629 drivers, I'm seeing very acceptable 2D performance and about 720 FPS from glxgears.

Unfortunately, I'm only able to get 50% of this card to work ... one of the GPUs doesn't seem to get setup by either linux or my motherboard (not sure who's to blame), and the driver's not able to use it at all.

Here's the verbose lspci output for the two devices that get created by this single PCI card:

04:00.0 VGA compatible controller: nVidia Corporation NV17GL [Quadro4 200/400 NVS] (rev a3) (prog-if 00 [VGA])
Subsystem: nVidia Corporation: Unknown device 014c
Flags: 66Mhz, medium devsel, IRQ 185
Memory at <ignored> (32-bit, non-prefetchable) [disabled]
Memory at <ignored> (32-bit, prefetchable) [disabled]
Memory at <ignored> (32-bit, prefetchable) [disabled]
Expansion ROM at <ignored> [disabled]
Capabilities: [60] Power Management version 2

04:04.0 VGA compatible controller: nVidia Corporation NV17GL [Quadro4 200/400 NVS] (rev a3) (prog-if 00 [VGA])
Subsystem: nVidia Corporation: Unknown device 014c
Flags: bus master, 66Mhz, medium devsel, latency 248, IRQ 185
Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (32-bit, prefetchable) [size=128M]
Memory at da280000 (32-bit, prefetchable) [size=512K]
Expansion ROM at fe7e0000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2


As a consequence, I'm not able to activate anything on the 'card' at 04:00.0.

I've tried updating to the latest beta Bios from Tyan, going from 2.02 to 2.02w, but that had no effect.

Is there anything I can do to help coax this second device to life? It is possible the card is just defective, or should I be hassling Tyan about this?

Thanks for any advice/assistance!

-Darren
ifaxsoln is offline   Reply With Quote
Old 12-06-04, 05:59 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

I think you'll need to contact Tyan about this problem.
zander is offline   Reply With Quote
Old 12-19-04, 09:44 PM   #3
ifaxsoln
Registered User
 
Join Date: Nov 2004
Posts: 21
Default Re: Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

I've been discussing this same issue at:

http://www.nvnews.net/vbulletin/showthread.php?t=41382

but it seems most appropriate to update this thread instead, since it's much more specific.

-Darren
ifaxsoln is offline   Reply With Quote
Old 12-19-04, 09:49 PM   #4
ifaxsoln
Registered User
 
Join Date: Nov 2004
Posts: 21
Default Re: Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

Quote:
Originally Posted by zander
I think you'll need to contact Tyan about this problem.
As I mentioned in the other thread, the helpful people from PNY/Nvidia have send a Tyan support engineer a Quadro NVS and he got it to work on a S2885 mainboard under Windows XP - displaying all 4 screen without problems.

I've also confirmed my card is not defective by putting it into a DELL and also getting 4 screens running under XP. Oddly, the screens on graphics port 1 showed the VGA boot messages in the DELL setup - on my Tyan/Opteron box the boot messages were on graphics port 2 (the second GPU).

Tyan is claiming this must be a linux issue, not a problem with their motherboard, since it works find under Windows.

-Darren
ifaxsoln is offline   Reply With Quote
Old 12-20-04, 02:40 AM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

I don't consider running Windows XP a sufficient analysis of this problem; in any case, this isn't a NVIDIA Linux driver bug, there's nothing it can do if the graphics devices aren't setup correctly by the time its probe routine is called for them by the kernel.
zander is offline   Reply With Quote
Old 01-28-05, 08:57 AM   #6
ifaxsoln
Registered User
 
Join Date: Nov 2004
Posts: 21
Default Re: Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

Thanks for your reply Zander.

Tyan says this is not a problem with their BIOS, ... at least if it is they don't understand what the problem is. There's two engineers there who are willing to listen, and escalate the issue within Tyan, but I can't get anyone from Nvidia to help me move this forward. I've submitted multiple issue reports to linux-bugs@nvidia.com with no reply. I have a PNY engineer trying to get Nvidia's attention, and still no luck.

Do you have any suggestions as to what BIOS code/routines is failing, or what they're lacking? Any information at all I can send to Tyan to make them take this seriously?

-Darren
ifaxsoln is offline   Reply With Quote
Old 01-28-05, 09:20 AM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

Has the PNY engineer reproduced the problem? Has the Tyan engineer tried to reproduce the problem on a Linux system?
zander is offline   Reply With Quote
Old 01-28-05, 12:15 PM   #8
ifaxsoln
Registered User
 
Join Date: Nov 2004
Posts: 21
Default Re: Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

Quote:
Originally Posted by zander
Has the PNY engineer reproduced the problem? Has the Tyan engineer tried to reproduce the problem on a Linux system?
The PNY Engineers sent a Quadro NVS 400 to the Tyan engineer, and he put it in a S2885 mainboard. They installed Windows XP, and the windows drivers, and had 4 screens display properly.

Next, they installed SuSE Linux (one of the kernel-26 distributions I think) with x86_64 support, and they confirmed that they could not get both GPUs to work. They do not think this is a BIOS problem, but I've told them you say it is, and so they have asked me and Nvidia for help in understanding how it might be. They're not Linux experts, but they're very interested in hearing from Nvidia as to what might be missing/broken in their BIOS routines to cause the second GPU not to be setup properly. If you're saying it's a BIOS problem, what can you tell me about what the BIOS should be doing? If I can tell Tyan somthing like "you're not intializing the kerfuddle widget of the fuddle array pointer" then this is something they can take seriously and escalate.

Tyan wants to help, but I can't find anyone from Nvidia willing to contribute to this troubleshooting, or willing to say anything more than 'get tyan to fix their bios'. They WANT to, if it really is their problem, they just don't understand the problem! It doesn't help much that the nvidia driver somehow works just fine with the same motherboard under windows XP ... it makes them _THINK_ that the BIOS must be fine.

-Darren
ifaxsoln is offline   Reply With Quote

Old 01-28-05, 02:14 PM   #9
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

In your case, the PCI BAR's 0, 1 and 2 aren't programmed on PCI device PCI:04:00.0. Though both PCI:04:00.0 and PCI:04:04.0 are ordinary PCI devices, the Quadro 400 NVS is special in the sense that it has an on-board PCI bridge that sits in front of the two graphics devices; the problem might be related to this configuration. Do you have another mainboard to test the card in?
zander is offline   Reply With Quote
Old 01-29-05, 10:35 AM   #10
ifaxsoln
Registered User
 
Join Date: Nov 2004
Posts: 21
Default Re: Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

Quote:
Originally Posted by zander
In your case, the PCI BAR's 0, 1 and 2 aren't programmed on PCI device PCI:04:00.0. Though both PCI:04:00.0 and PCI:04:04.0 are ordinary PCI devices, the Quadro 400 NVS is special in the sense that it has an on-board PCI bridge that sits in front of the two graphics devices; the problem might be related to this configuration. Do you have another mainboard to test the card in?

Thanks Zander, that's the type of information I can pass on to Tyan.

I tried the card in a Gigabyte GA-6BXDS, on an old RedHat-7.2 machine (Dual PIII 333 MHz) and this is what I see in lspci:

02:00.0 VGA compatible controller: nVidia Corporation: Unknown device 017a (rev a3) (prog-if 00 [VGA])
Subsystem: nVidia Corporation: Unknown device 014c
Flags: bus master, 66Mhz, medium devsel, latency 64
Memory at e8000000 (32-bit, non-prefetchable) [size=16M]
Memory at c8000000 (32-bit, prefetchable) [size=128M]
Memory at d8000000 (32-bit, prefetchable) [size=512K]
Expansion ROM at e9000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2

02:04.0 VGA compatible controller: nVidia Corporation: Unknown device 017a (rev a3) (prog-if 00 [VGA])
Subsystem: nVidia Corporation: Unknown device 014c
Flags: 66Mhz, medium devsel
Memory at ea000000 (32-bit, non-prefetchable) [disabled] [size=16M]
Memory at d0000000 (32-bit, prefetchable) [disabled] [size=128M]
Memory at d8080000 (32-bit, prefetchable) [disabled] [size=512K]
Expansion ROM at eb000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2

This seems much more healthy?

-Darren
ifaxsoln is offline   Reply With Quote
Old 01-29-05, 10:42 AM   #11
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

That looks better with respect to the BAR's, but no IRQ's appear to have been assigned (possibly due to a BIOS setting ("Assign IRQ to VGA")).
zander is offline   Reply With Quote
Old 01-29-05, 12:09 PM   #12
ifaxsoln
Registered User
 
Join Date: Nov 2004
Posts: 21
Default Re: Quadro NVS 400 / Tyan S2885 - only one GPU recognized?

Quote:
Originally Posted by zander
That looks better with respect to the BAR's, but no IRQ's appear to have been assigned (possibly due to a BIOS setting ("Assign IRQ to VGA")).
Good catch Zander, the workstation with the GA-6BXDS mainboard had an AGP graphics card in it previously, and no IRQ had been assigned to VGA. I corrected that, and now I see:

02:00.0 VGA compatible controller: nVidia Corporation: Unknown device 017a (rev a3) (prog-if 00 [VGA])
Subsystem: nVidia Corporation: Unknown device 014c
Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 10
Memory at e8000000 (32-bit, non-prefetchable) [size=16M]
Memory at c8000000 (32-bit, prefetchable) [size=128M]
Memory at d8000000 (32-bit, prefetchable) [size=512K]
Expansion ROM at e9000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2

02:04.0 VGA compatible controller: nVidia Corporation: Unknown device 017a (rev a3) (prog-if 00 [VGA])
Subsystem: nVidia Corporation: Unknown device 014c
Flags: 66Mhz, medium devsel, IRQ 10
Memory at ea000000 (32-bit, non-prefetchable) [disabled] [size=16M]
Memory at d0000000 (32-bit, prefetchable) [disabled] [size=128M]
Memory at d8080000 (32-bit, prefetchable) [disabled] [size=512K]
Expansion ROM at eb000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2


If I understand what you're saying correctly, this is a healthy initialization of the board by the BIOS? The fact that the Tyan S2885 (Thunder K8W) cannot set the card up this way is the heart of the problem, and something I need to escalate to Tyan (if I can get them to listen)?

-Darren
ifaxsoln is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GPU memory consumption, back buffer, Quadro tdsussman NVIDIA Linux 5 08-14-12 09:14 PM
Choosing The Right GPU To Take Adobe Workflows To The Max News Archived News Items 0 05-29-12 05:40 PM

All times are GMT -5. The time now is 01:48 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.