Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-07-04, 03:07 AM   #1
e-gore
Registered User
 
Join Date: Sep 2004
Posts: 5
Default MDK10 - Asus 6800 Ultra - 6629 drivers - no games work

I have been running Mandrake 10 with a GF 4 Ti 4600 for years with no probs ever.

Then I installed an ASUS 6800 V9999 Ultra Deluxe . . . Bad move . . .

OS:
------
Linux io 2.6.3-7mdk #1 Wed Mar 17 15:56:42 CET 2004 i686 unknown unknown GNU/Linux

Machine spec:
----------------------
P4 2.4Ghz
1 Gb DDR RAM
1x Nvidia 6800 Ultra
Benq 19" flat panel
19" CRT
1x GF 2 PCI
15" CRT

X works fine with all three heads.

If I try running Doom3 - It is brilliant . . . for no more than 5 minutes until it freezes and the sound sort of gets stuck - but I can still ssh in and kill it

If I run ArmyOps 2.1 - it works first time but with sound a bit stuttering. If I exit and run it again - black screen of death - machine completely dead - hardware re-boot

If I then rm -rf ~/.armyops210 - it works again still with stuttering sound - once only - must rm -rf ~/.armyops210 directory again to run it again.

If I run UT2004 - same as ArmyOps
havn't tried latest version of UT2004 yet though - (seems little point)

I have tried:
- The two previous versions of the NV drivers - same problem
- latest patches for armyops and doom3
- Looking for firmware updates on ASUS site - none available
- Upgraded mobo from a AGP4x to AGP8x - no difference
- Upgrading PS to 500w - no difference
- Complete OS re-install - no difference
- Bitching to my friends - no friends left

See attachments for:
- XF86Config-4 (a bit messy - has evolved over many years - but it does work)
- X boot log
- Army ops log of crash
- glxinfo output

I have seen lots of posts with similar probs with the 6800 cards, maybe they are just duds. Lucky I didn't trade my GF4.

Any ideas would be greatly appreciated

Will try latest patch for UT2004 and post result back here

e-gore
Attached Files
File Type: txt XF86Config-4.txt (7.5 KB, 200 views)
File Type: txt glxinfo.txt (18.7 KB, 177 views)
File Type: txt ArmyOpsLog.txt (36.0 KB, 176 views)
File Type: txt XFree86.0.log.txt (49.0 KB, 159 views)
e-gore is offline   Reply With Quote
Old 12-07-04, 08:19 AM   #2
chrismortimore
Registered User
 
Join Date: Jul 2004
Posts: 131
Default Re: MDK10 - Asus 6800 Ultra - 6629 drivers - no games work

try recompiling your nvidia module. i get the impression (i might be wrong) it makes it for whatever card is installed at the time.
__________________
[ www.guff.tk ]
chrismortimore is offline   Reply With Quote
Old 12-16-04, 03:02 AM   #3
e-gore
Registered User
 
Join Date: Sep 2004
Posts: 5
Default Re: MDK10 - Asus 6800 Ultra - 6629 drivers - no games work

Thanks for the input chrismortimore !

From what I gather, the installer recognizes the card because it has a "pre-compiled interface" it uses. I have no idea how to force it to compile one. Does anybody else ?

Update:

Have installed the new ArmyOps-2.2.1
I no longer get a black screen of death the second time I run it, but I still get random freezing. (machine completly locks up)

Sometimes when I run it, the video is all shagged (but recognizable) and I have to re-start X

UT2004 update - I played two maps with no probs the other night, but when I went to exit, I got a screen full of crap. I could still shell in and reboot though, so the machine hadn't frozen.

I am slowly getting there. I am hoping that by the first anniversary of buying the card it may actually work. It will of course be obsolete by then.

This little black duck will definitely never be buy cutting edge hardware again (at least not off Nvidia)

The GF4-Ti4600 in my other machine is still solid as a rock and never had a problem.
e-gore is offline   Reply With Quote
Old 12-16-04, 09:19 PM   #4
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default Re: MDK10 - Asus 6800 Ultra - 6629 drivers - no games work

Quote:
Originally Posted by e-gore
Thanks for the input chrismortimore !

From what I gather, the installer recognizes the card because it has a "pre-compiled interface" it uses. I have no idea how to force it to compile one. Does anybody else ?

Update:

Have installed the new ArmyOps-2.2.1
I no longer get a black screen of death the second time I run it, but I still get random freezing. (machine completly locks up)

Sometimes when I run it, the video is all shagged (but recognizable) and I have to re-start X

UT2004 update - I played two maps with no probs the other night, but when I went to exit, I got a screen full of crap. I could still shell in and reboot though, so the machine hadn't frozen.

I am slowly getting there. I am hoping that by the first anniversary of buying the card it may actually work. It will of course be obsolete by then.

This little black duck will definitely never be buy cutting edge hardware again (at least not off Nvidia)

The GF4-Ti4600 in my other machine is still solid as a rock and never had a problem.
Well, that could be due to the fact that it's a Geforce 6800 Ultra. I was unable to get one here in Australia, and the reason was, that they were sent back to Nvidia, due to chipset problems. I ended up, going out and getting the 6800GT and it runs flawlessly.. (But I really wanted the Ultra)

Wolf
Wolfman [TWP] is offline   Reply With Quote
Old 01-01-05, 01:24 AM   #5
Chailen
Registered User
 
Join Date: Nov 2004
Posts: 1
Default Re: MDK10 - Asus 6800 Ultra - 6629 drivers - no games work

I'm a gal with the same problems, but here's my solution:

I just got my Asus v9999 6800 Ultra Deluxe December 29.
-It freezes (froze) during Doom3's transition from the load screen to the game.
-There are (were) colored scanlines visible for certain 2D overlay water textures in Prince of Persia: WW.
-I downloaded rivatuner, changed the 2D clockspeed to match the 3D clock speed.

This worked for me without needing to flash my Bios.

I'm running the card on a 2-year-old machine.
Only a P4 2.4 and 512 Mb of ram.
I did upgrade the power supply to 500W

My last card was a Geforce 4 MX - it was like shock therapy switching to the 6800 Ultra. I am still speechless...
Chailen is offline   Reply With Quote
Old 01-04-05, 06:11 AM   #6
bms20
Registered User
 
Join Date: Mar 2003
Posts: 46
Default Re: MDK10 - Asus 6800 Ultra - 6629 drivers - no games work

Check the bios version of your 6800. Esp. if it is a 6800 Ultra.

I had to go through three bios revision before everything worked fine. Now that it does I'm very happy, and the graphics performance is stunning - both for work and for games.

I run doom3 on a 6800 Ultra (Mandrake 10.0) - just fine. I had pausing problems, lockups and hangs until the bios was updated. I'm running what the "Nvidia Bios forum" calls the revision 3 bios.

Also, be sure that your card is not overclocked - it should be set to 400MHz for 2d and 400MHz for 3D (if its an ultra). Several suppliers tried to overclock their cards - at anything above 408MHz I notice subtle drawing problems.
bms20 is offline   Reply With Quote
Old 04-07-05, 09:33 PM   #7
Hannibal1632
Registered User
 
Join Date: Apr 2005
Posts: 1
Default Re: MDK10 - Asus 6800 Ultra - 6629 drivers - no games work

Hi everyone!

Hey, guess what; I am having the same problem quite often while I am playing games. My screen freezes and the sound stutters, but this only lasts for about 5-10 seconds and then everything goes back to normal. I have tried so many different possible fixes, but nothing has worked for me yet. However, I haven't tried flashing my video card's BIOS yet...

Chailen, I have a stupid question to ask..............how can I view/change my 2D and 3D clock speeds with RivaTuner??? I can't seem to figure out how to do so. Maybe that will correct my problem.

Also, I welcome any other tips, suggestions, or advice that any of you might have. Thanks.


My Basic System Specs:
AMD Athlon 64 3200+
ASUS K8N-E Deluxe mobo
BFG GeForce 6800GT OC
1 Gig Corsair RAM
Maxtor 120GB 7200RPM SATA HD
Hannibal1632 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM

All times are GMT -5. The time now is 06:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.