Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-10-04, 07:07 AM   #1
ibm2080
Registered User
 
Join Date: May 2004
Location: Paris, FRANCE
Posts: 16
Red face [Debian /w nForce3 250Gb] nvsound: /dev/dsp locked

Hi all,

I am using Debian SID (unstable) with kernel 2.6.9 (custom compilation) and installed the latest nVidia nForce drivers. I had to use modconf to load the modules into the kernel. Now, at each reboot, they are loaded at startup. The nvnet driver works great. But the nvsound is giving me problems. I tried to search the web for answers, but nothing. I also tried to see about aRts (the sound server for Debian; each time it starts it reports that the resource is temporarly unavailable) but nothing there either. I then tried different mailing lists, but the only thing I found out is that a Gentoo user had to make sure that nvsound is loaded at startup before a similar issue (resources locked) was resolved. So I looked at the log file /var/log/dmesg and Nvsound figuers in there. So I guess it is loaded. However, I just now (for the first time) ran dmesg and here is what I get:
<snip>
Nvsound: Nvidia Audio Init Module, 12:58:04 Nov 11 2004 version 1.0-1
PCI: Setting latency timer of device 0000:00:06.0 to 64
Nvsound: NVIDIA CK8S Audio found at IO 0xe400 and 0xe800, IRQ 7
Nvsound: Aci_device c1567c00 Apu_device 00000000
Nvsound: DEV MIXER 0 DEV AUDIO 3
<snip>
Nvsound: Unable to change the Record SampleRate, set back to 48000

The last message is repeated 56 times. And I guess this is connected to the problem I am having. But I don't know how to interpret it

Is there a log for nvsound to pin down the problem? I only see the installation log in /var/log/.

Thx,
ib

Last edited by ibm2080; 12-10-04 at 12:38 PM.
ibm2080 is offline   Reply With Quote
Old 12-10-04, 10:26 AM   #2
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: [Debian /w nForce3 250Gb] nvsound: /dev/dsp locked

If I were you I would use the in-kernel alsa based driver for the sound. OSS is more or less deprecated.
Lithorus is offline   Reply With Quote
Old 12-10-04, 12:37 PM   #3
ibm2080
Registered User
 
Join Date: May 2004
Location: Paris, FRANCE
Posts: 16
Default Re: [Debian /w nForce3 250Gb] nvsound: /dev/dsp locked [SOLVED]

Thx a lot,

I just recompiled my kernel and removed all OSS stuff and added both ALSA intel/nForce drivers (didn't know which one will actually work ). Now I got sound, woooooohoooooooo.

Next thing on my list: figure out how to change the level of base compared to the treble as its a little too high. Tried AlsaMixerGui, but those controls are not there. I am searching the web as I write this. Actually, I stopped searching just to write this, hehe.

Getting back to my google page ...

Thx again,
ib
ibm2080 is offline   Reply With Quote
Old 12-15-04, 05:11 AM   #4
ibm2080
Registered User
 
Join Date: May 2004
Location: Paris, FRANCE
Posts: 16
Default Re: [Debian /w nForce3 250Gb] nvsound: /dev/dsp locked

It turns out that only aRts has a problem with the OSS driver module nvsound. After a few tests I found that both OSS and ALSA work fine. Tested that with XMMS.
ibm2080 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.