Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-13-04, 09:24 PM   #1
eyeyam
Registered User
 
Join Date: Dec 2004
Posts: 2
Default 6629 doesn't recognize LCD panel where 6111 at least kinda worked

The 1.0-6629 driver recognizes my monitor as a "Nvidia default Flat Panel" and therefore refuses to produce 1280x800 resolution on my 15.4 wxga flat planel. I have a compaq presario R3310CA. The logfiles attached are produced using kernel 2.4.28. Unfortunately only the 6629 driver works with kernel 2.6 so I've been fighting with it to try to get it to recognize my display. The 6111 nvidia driver reports my display as a "QDS" Manufactured in the year 2049 (gotta love time travel) -- but at least it gave me my 1280x800 See attached for my xorg.conf and verbose logs both produced with the same xorg.conf, same kernel version, but different nvidia driver versions. Also, just for fun, is the output of the nvidia 6629 on kernel 2.6.10-rc3.

If I set ignore EDID then I end up with two squashed images of the screen, one above the other, if that's meaningful in any way.

Any takers on how to make the 6629 driver work with this setup?
Attached Files
File Type: txt xorg.conf.txt (2.4 KB, 211 views)
File Type: txt Xorg.0.nvidia6111.krnl2.4.28..log.txt (32.6 KB, 118 views)
File Type: txt Xorg.0.nvidia6629.krnl2.4.28..log.txt (32.8 KB, 107 views)
File Type: txt Xorg.0.nvidia6629.krnl2.6.10rc3..log.txt (32.8 KB, 164 views)

Last edited by eyeyam; 12-13-04 at 09:27 PM. Reason: fixing "invalid file types" in attachments.
eyeyam is offline   Reply With Quote
Old 12-14-04, 03:49 PM   #2
kdgassiot
Registered User
 
Join Date: Nov 2002
Posts: 13
Default Re: 6629 doesn't recognize LCD panel where 6111 at least kinda worked

I think the problem is that you specify a horizontal sync value of 50.66, which is outside the value that the panel is returning when the nvidia driver queries it.

When the driver loads, it queries the panel, and gets the ranges :

(II) NVIDIA(0): Ranges: V min: 0 V max: 60 Hz, H min: 29 H max: 49 kHz, PixClock max 70 MHz

The driver reports that it is using the EDID reported Horizontal max of 29-49, instead of the 50.66 that you specified :

(WW) NVIDIA(0): The user specified HorizSync "50.660" has been adjusted to ""
(WW) NVIDIA(0): (the intersection with EDID-specified HorizSync
(WW) NVIDIA(0): "29.000-49.000")
(EE) NVIDIA(0): no HorizSync values remaining
(II) NVIDIA(0): Monitor0: Using default hsync range of 29.00-49.00 kHz
(II) NVIDIA(0): Monitor0: Using default vrefresh range of 0.00-60.00 Hz

you either need to remove the Horizontal sync line in your Monitor definition, or add the `Option "IgnoreEDID" "on"` line to the driver section. You need to be sure that you know what you are doing if you tell it to ignore the EDID reported by the device. It looks like if you remove the horizontal sync line from your Monitor definition, it will use the 1024x768 reported by your panel as it's maximum resolution :

However, you have set your default depth to 24, and the only modes requested for the depth of 24 are "1280x768" and "1280x800". Adding the "1024x768" option like all of the other depths might let your display work as it is...

personally, I would try removing the Horizontal sync line from your Monitor definition, and adding the `Option "UseEdidFreqs" "on"` line to your Device section, and adding the "1024x768" option to the Depth 24 Modes line...

Option "UseEdidFreqs" "boolean"
This option causes the X server to use the HorizSync
and VertRefresh ranges given in a display device's EDID,
if any. EDID provided range information will override
the HorizSync and VertRefresh ranges specified in the
Monitor section. If a display device does not provide an
EDID, or the EDID does not specify an hsync or vrefresh
range, then the X server will default to the HorizSync
and VertRefresh ranges specified in the Monitor section.

Option "IgnoreEDID" "boolean"
Disable probing of EDID (Extended Display Identification
Data) from your monitor. Requested modes are compared
against values gotten from your monitor EDIDs (if any)
during mode validation. Some monitors are known to lie
about their own capabilities. Ignoring the values that
the monitor gives may help get a certain mode validated.
On the other hand, this may be dangerous if you do not
know what you are doing. Default: Use EDIDs.
kdgassiot is offline   Reply With Quote
Old 12-14-04, 07:46 PM   #3
eyeyam
Registered User
 
Join Date: Dec 2004
Posts: 2
Default Re: 6629 doesn't recognize LCD panel where 6111 at least kinda worked

Found the solution:
http://www.nvnews.net/vbulletin/show...214#post482214

It was here all along
eyeyam is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:39 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.