Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-14-04, 10:46 AM   #1
iExcel
Registered User
 
Join Date: Dec 2004
Location: Oakville, ON
Posts: 1
Red face My machine freezes at the first boot

I'm experiencing a stange problem that when my machine boots up for the very first time, it will freeze when it attempts to load X.

I have GeForce4 MX 440 w/ 64M. If I configure the system to boot into console, it works fine for the very first time. However, if I attempt to startx, the same problem occurs.

When the problem occurs, I have to reset the machine to give it a cold reboot. After the reboot, everything will be fine, no matter how I launch X, either thru startx or xdm.

I'm using driver v1.0.6629 and the /etc/X11/xorg.conf reads
Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   RgbPath      "/usr/X11R6/lib/X11/rgb"
   ModulePath   "/usr/X11R6/lib/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/CID/"
   FontPath     "/usr/share/fonts/75dpi/"
   FontPath     "/usr/share/fonts/100dpi/"
EndSection

Section "Module"
   Load  "extmod"
   #Load  "dri"
   Load  "dbe"
   Load  "record"
   Load  "xtrap"
   Load  "glx"
   Load  "type1"
   Load  "freetype"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option        "Buttons" "5"
   Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
   #DisplaySize     330   270   # mm
   Identifier   "Monitor0"
   VendorName   "IQT"
   ModelName    "L70S"
   HorizSync    31-80
   VertRefresh  56-75
   Option       "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "HWcursor"              # [<bool>]
        #Option     "NoAccel"               # [<bool>]
        #Option     "ShadowFB"              # [<bool>]
        #Option     "UseFBDev"              # [<bool>]
        #Option     "Rotate"                # [<str>]
        #Option     "VideoKey"              # <i>
        #Option     "FlatPanel"             # [<bool>]
        #Option     "FPDither"              # [<bool>]
        #Option     "CrtcNumber"            # <i>
   # The following driver options are supported by the NVIDIA XFree86 driver:

   Option "NvAGP" "3"
   # Configure AGP support. Integer argument can be one of:
   #   0 : disable agp
   #   1 : use NVIDIA's internal AGP support, if possible
   #   2 : use AGPGART, if possible
   #   3 : use any agp support (try AGPGART, then NVIDIA's AGP)
   #       Please note that NVIDIA's internal AGP support cannot
   #       work if AGPGART is either statically compiled into your
   #       kernel or is built as a module, but loaded into your
   #       kernel (some distributions load AGPGART into the kernel
   #       at boot up).  Default: 3 (the default was 1 until after
   #       1.0-1251).

   # Option "NoLogo" "boolean"
   #         Disable drawing of the NVIDIA logo splash screen at
   #         X startup.  Default: the logo is drawn.
   Option "NoLogo" "1"
   Option "RenderAccel" "1"
   Identifier  "Card0"
   Driver      "nvidia"
   #Driver       "nv"
   VideoRam    65536
   VendorName  "nVidia Corporation"
   BoardName   "NV17 [GeForce4 MX 440]"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24

   Subsection "Display"
           Depth       8
           Modes        "1280x1024" "1024x768" "800x600" "640x480"
           ViewPort    0 0
   EndSubsection
       Subsection "Display"
           Depth       16
           Modes        "1280x1024" "1024x768" "800x600" "640x480"
           ViewPort    0 0
       EndSubsection
       Subsection "Display"
           Depth       24
           Modes       "1280x1024" "1024x768" "800x600" "640x480"
           ViewPort    0 0
       EndSubsection
EndSection
Any ideas?
iExcel is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia driver stopped working after X restart and Kernel taint msgs during boot mikejuni NVIDIA Linux 10 05-21-12 08:30 PM
unable to boot machine with tesla card wcochran NVIDIA Linux 3 05-03-12 07:26 PM
Favorite OS of all-time. PCarr78 Microsoft Windows XP And Vista 86 02-19-08 11:51 AM
Install MDK9.0 on Asus a7n266-vm succeds but won't boot fierywizard NVIDIA Linux 2 10-06-02 05:53 PM
crashes and freezes Lethal Weapon NVIDIA Linux 9 09-27-02 08:23 PM

All times are GMT -5. The time now is 02:20 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.