Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-14-04, 11:10 AM   #1
cpradio
Registered User
 
Join Date: Dec 2004
Posts: 11
Default driver "nv" versus driver "nvidia" v. 1.0-6629

I am in a somewhat odd situation as I am unable to use driver "nvidia" as my GeForce2 MX/MX 400 card's driver.

Anytime I change it to driver "nvidia", X never starts. I have tried countless things to get it to work, but each site I have been sent to, hasn't solved it yet.

I just simply want to run TwinView, which I successfully did when running Debian: Woody 2.4.21 but now I am running Debian: Sarge 2.6.8 and I can't figure out where things are going wrong.

Any help will be much appreciated.
Thanks.
Attached Files
File Type: txt XF86Config-4.log.txt (3.2 KB, 149 views)
File Type: txt XFree86.0.log.txt (39.4 KB, 186 views)
cpradio is offline   Reply With Quote
Old 12-14-04, 02:10 PM   #2
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: driver "nv" versus driver "nvidia" v. 1.0-6629

First of all, you attached the log file from when you had "nv" in there and not "nvidia". Second, your X seems to load just about every driver you have in your modules/drivers path. Third, I've heard of some of the modules you are loading, like "pex5" and "xtrap".
But start with attaching the log from when X is failing to start, so we can actually figure out what the problem might be.
Lithorus is offline   Reply With Quote
Old 12-14-04, 02:27 PM   #3
cpradio
Registered User
 
Join Date: Dec 2004
Posts: 11
Default Re: driver "nv" versus driver "nvidia" v. 1.0-6629

Sorry, I thought I had attached the correct one, here is the one that fails.
Attached Files
File Type: txt XF86Config-4.log.txt (3.2 KB, 194 views)
File Type: txt XFree86.0.log.txt (17.9 KB, 191 views)
cpradio is offline   Reply With Quote
Old 12-14-04, 02:50 PM   #4
cpradio
Registered User
 
Join Date: Dec 2004
Posts: 11
Default Re: driver "nv" versus driver "nvidia" v. 1.0-6629

So you know, when I choose "nv" as the driver, all I get is a single monitor display, not TwinView...which I find weird as well..
cpradio is offline   Reply With Quote
Old 12-15-04, 10:20 AM   #5
cpradio
Registered User
 
Join Date: Dec 2004
Posts: 11
Default Re: driver "nv" versus driver "nvidia" v. 1.0-6629

I also tried going back a driver and that didn't help either... I am running out of ideas.
cpradio is offline   Reply With Quote
Old 12-15-04, 11:05 AM   #6
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: driver "nv" versus driver "nvidia" v. 1.0-6629

Try and uncomment the pex5 line and change the input section into this :
Code:
Section "InputDevice"
   Identifier      "Configured Mouse"
   Driver          "mouse"
(You missed a newline, not sure it does anything, but it's nice to rule these things out when debugging).

Btw. how do you start X? It seems more like it's trying to probe for hardware than really start the X server.

Also try and delete the lines :
Code:
        VendorName ""
        BoardName ""
And try with "DefaultDepth 24" instead of "DefaultColorDepth 24"

Last but not least, check if the nvidia_drv.o is in /usr/X11R6/lib/modules/drivers/

Last edited by Lithorus; 12-15-04 at 11:20 AM.
Lithorus is offline   Reply With Quote
Old 12-15-04, 12:24 PM   #7
cpradio
Registered User
 
Join Date: Dec 2004
Posts: 11
Default Re: driver "nv" versus driver "nvidia" v. 1.0-6629

Quote:
Originally Posted by Lithorus
Try and uncomment the pex5 line and change the input section into this :
Code:
Section "InputDevice"
   Identifier      "Configured Mouse"
   Driver          "mouse"
(You missed a newline, not sure it does anything, but it's nice to rule these things out when debugging).

Btw. how do you start X? It seems more like it's trying to probe for hardware than really start the X server.

Also try and delete the lines :
Code:
        VendorName ""
        BoardName ""
And try with "DefaultDepth 24" instead of "DefaultColorDepth 24"

Last but not least, check if the nvidia_drv.o is in /usr/X11R6/lib/modules/drivers/
Okay, I made the changes.

The nvidia_drv.o is listed, I am starting X by logging in through console and running startx.

Also attached are the new files.
Attached Files
File Type: txt XF86Config-4.txt (3.8 KB, 124 views)
File Type: txt XFree86.0.log.txt (39.9 KB, 158 views)
cpradio is offline   Reply With Quote
Old 12-15-04, 03:54 PM   #8
tiangha
Registered User
 
Join Date: Jul 2004
Posts: 25
Default Re: driver "nv" versus driver "nvidia" v. 1.0-6629

I think that this problem may be related to the issue with the TNT cards where X doesn't start correctly (although in the GeForce2 case, X doesn't start at all). I'm in the same boat as you are (GeForce2 Go) in the exact same situation (starting X through a console) and it appears that when X starts, power is cut to the monitor and the whole system freezes (can't even SSH in to run the nvidia bug report or to shutdown gracefully).

Hopefully, if they can manage to fix the TNT bug, it'll fix the problems we're having too.
tiangha is offline   Reply With Quote

Old 12-15-04, 04:05 PM   #9
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: driver "nv" versus driver "nvidia" v. 1.0-6629

What puzzles me that X tries and load every single builtin drivers which it's not supposed to do. It even tries so when the nv driver is specified. It must have been setup somewhere that it's supposed to probe for videocards.
This is from my own X config which is also from a debian installation. Try and load only these, it should be more than enough to load X
Code:
Section "Module"
    Load        "dbe"   # Double buffer extension
    Load        "type1"
    SubSection  "extmod"
#      Option    "omit xfree86-dga"
    EndSubSection
    Load        "freetype"
    Load        "glx"   # libglx.a
EndSection
Check also in aptitude which xserver packages you have installed. They should be called xserver-common and xserver-xfree86.

Edit:
Hmm.. try and comment out this line (and ofcourse put back in "nvidia"):
Code:
BusID           "AGP:01:00:0"

Last edited by Lithorus; 12-15-04 at 04:19 PM.
Lithorus is offline   Reply With Quote
Old 12-15-04, 09:13 PM   #10
cpradio
Registered User
 
Join Date: Dec 2004
Posts: 11
Default Re: driver "nv" versus driver "nvidia" v. 1.0-6629

Okay, well I am in Houston, TX right now so I will have to check this in a week when I am back home. I appreciate your help.

Matt
cpradio is offline   Reply With Quote
Old 12-16-04, 07:25 AM   #11
cpradio
Registered User
 
Join Date: Dec 2004
Posts: 11
Default Re: driver "nv" versus driver "nvidia" v. 1.0-6629

Quote:
Originally Posted by Lithorus
Check also in aptitude which xserver packages you have installed. They should be called xserver-common and xserver-xfree86.
I have the following installed:
xfree86-common
xserver-common
xserver-xfree86
xserver-xfree86-dbg

Unfortunately, I cannot visually see my computer right now, so seeing if the changes you suggested earlier worked is a little hard to do. If you know a way around this, I am willing to try it.

Matt
cpradio is offline   Reply With Quote
Old 12-16-04, 10:33 AM   #12
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: driver "nv" versus driver "nvidia" v. 1.0-6629

Try and remove the xserver-xfree86-dbg package since it's only for debugging. Actually I'm quite sure this is the problem. From the package description :
Quote:
This package is a variant of the xserver-xfree86 package which includes a monolithic XFree86 X server binary (as opposed to using loadable server modules on the architectures where they are supported) and which retains debugging symbols for execution tracing and core dump analysis.
which probably means it ONLY have support for the already built-in drivers and would explain the behaviour of the X server.
Actually you can see this from remote by starting your display manager(eg. gdm) and look in the X logfile.

Edit:
Ok, now I'm DEFINATELY sure. I just tried to install the xserver-xfree86-dbg package and it asked me which server to use as default. I selected the -dbg which was selected by default and tried starting X. And now X won't start and the log looks just like yours. Alternatively you can do a "dpkg-reconfigure xserver-xfree86" and select the non-dbg one.

Last edited by Lithorus; 12-16-04 at 10:56 AM.
Lithorus is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.