Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-20-04, 03:23 AM   #1
timtaylor
Registered User
 
Join Date: Aug 2004
Posts: 4
Post New nForce Drivers 1.0-0283 released

On Aug 13 nvidia released new Drivers for the nvidia chipset (NIC and Audio). New features are ie SoundStorm Support with long awaited Hardware Mixing. I have Asus A7N8X Deluxe (rev. 2.0) Debian stable 3.0r2 (woody). I downloaded and run
Code:
NFORCE-Linux-x86-1.0-0283-pkg1.run
The installer has to compile a kernel interface layer for both NIC and Audio modules because I have a self compiled vanilla kernel 2.6.6. The guided installation process first installs and starts the nforce NIC driver successfully. Afterwards, the audiodriver nvsound is installed. The good: A7N8X-typical Staticy-Sound stops. The bad: The driver hangs Linux. YES, no [Ctrl-Alt-Del], no [Ctrl-C] no Numlock response, no Console switching etc. The Following is printed on my screen:
Code:
nvsound: module license 'unspecified' taints kernel.
Nvsound: Nvidia Audio Init Module, 23:08:28 Aug 19 2004 2004 version 1.0-0
Nvsound:   NVIDIA nForce2 Controller found at IO Mem 0xe0000000 and IRQ c1
Nvsound: NVIDIA nForce2 Audio found at IO 0xd800 and 0xd400, IRQ c9
Nvsound: Aci_device dff3ec00 Apu_device dff3f000
Before installation I removed my previous ForcedEth, 3c98x and audio modules (snd-intel8x0) except soundcore module.
Has anybody experiences with this new driver (released only 7 days ago)?
If more information about the static noise of Asus A7N8X Mainboards is needed, I will post it here soon!
Thank you for your help!

Michael (timtaylor)
timtaylor is offline   Reply With Quote
Old 08-20-04, 05:16 PM   #2
Catmandu
Registered User
 
Join Date: Jul 2004
Posts: 6
Default Re: New nForce Drivers 1.0-0283 released

Might want to look at the several other threads that talk about this release of the 283 release. Lots of sound problems.
Catmandu is offline   Reply With Quote
Old 08-21-04, 07:25 AM   #3
timtaylor
Registered User
 
Join Date: Aug 2004
Posts: 4
Question Re: New nForce Drivers 1.0-0283 released

Every Asus A7N8X Deluxe Rev 2.0 Board has a problem with a weird "whining" "whirring" or "buzzing" "static" noise coming out of the speakers AND out of the motherboard itself.

The reason why I post this issue in the nForce Drivers 1.0-0283 thread:
Only the new nVidia drivers 1.0-0283 made the noise stop but - like described above - linux doesnt respond any more.

There are many posts out there, but all with conflicting arguments and solutions:
Detailed description of the problem here

I have located the source of the noise in the two transformator coils below the big capacitors unter the CPU.


If you have a silent PC this noise can even be heard with closed computer chassis WITHOUT speakers connected! When speakers are connected and the volume is turned up to normal levels, the noise is very loud, approx 20% of the signal and it drives you mad.


This is referred to as "grounding problem" or "ground loop" here but I know it is rather a driver problem. It occurs, when drivers for the APU (SoundStorm), ACI (Realtec ALC650), 3Com NIC or nVidia NIC are not loaded or one of them is not loaded. In WindowsXP, this noise occurs only at startup and then it is deactivated by the proper win-drivers, but in Linux I wasnt successful yet. (nearly except nForce drivers 1.0-0283)

Please send ANY comments, even if you have the same board and you dont have this problem.

THANK YOU,
timtaylor
Attached Images
File Type: jpg staticnoise.jpg (6.9 KB, 1085 views)
File Type: jpg mainboard.jpg (14.4 KB, 1079 views)

Last edited by timtaylor; 08-21-04 at 07:37 AM.
timtaylor is offline   Reply With Quote
Old 08-25-04, 02:27 AM   #4
timtaylor
Registered User
 
Join Date: Aug 2004
Posts: 4
Default Re: New nForce Drivers 1.0-0283 released

Problem solved after some research and help from nvidia:

APIC timing (Advanced Programmable Interrupt Controller) on nforce2 chipsets is broken and causes hardware lockups under some conditions. This has someting to do with the C1 disconnect HLT command of the CPU. APIC is enabled over ACPI (Advanced Configuration and Power Interface), so I built a new 2.6.6 kernel without ACPI support and the driver runs properly. I have only Stereo Sound now (sound quality is excellent), but I had not time to enable 5.1 Surround. The lost Power Managenent features of APCI can be replaced by the older standard APM. Only insert apm module.

For some information about this problem see the extensive and sophisticated discussion
here

The noise (described above) is emitted by electrostriction of two transformator coils near the CPU. But the reasons for this are still not clear, although there are reports about it in the link above.

Thank you Nvidia for this excellent driver!
timtaylor is offline   Reply With Quote
Old 12-25-04, 08:32 PM   #5
misnagid
Registered User
 
Join Date: Dec 2004
Posts: 2
Default Re: New nForce Drivers 1.0-0283 released

Dear Tim,

I'd like to confirm something. I use the Asus A7N8X-E Deluxe. I am using Fedora FC3. I have the on-board sound controller disabled. I have installed a Creative Labs Audigy 2 with ALSA driver EMU10K1. I am experiencing a buzzing sound only when a sound is supposed to be generated from an installed application. Is the problem that you've described in this column thus quite different from mine? Should I be able to eliminate my buzzing sound with normal debugging techniques? Your buzzing sound only exists when using the mainboard's nvidia sound controller, is that correct? Please advise as soon as possible with complete explanation so as to ensure my complete understanding of this issue without any possibility of confusion.

Thanks,
Jerry
misnagid is offline   Reply With Quote
Old 12-26-04, 08:03 AM   #6
misnagid
Registered User
 
Join Date: Dec 2004
Posts: 2
Default Re: New nForce Drivers 1.0-0283 released

Hi Tim,

More news. The buzz is apparently a lot worse than I thought. Seems to buzz a lot more than just when I'm expecting a sound from some software. Damn, it sure buzzes a lot and for long periods of time.

Yours,
Jerry
misnagid is offline   Reply With Quote
Old 12-27-04, 11:10 PM   #7
Krieger
Registered User
 
Join Date: Dec 2004
Posts: 1
Default Re: New nForce Drivers 1.0-0283 released

Re: buzzing noise, nvidia sound
I cannot speak for all distributions (and I'm a Linux noob), but for gentoo users:

From NeddySeagoon:
Quote:
Thats a feature of that motherboard. I have one too. Its caused by the CPU entering and exiting the halt state, which puts pulses on the power supply being shared by the CPU and sound chip. You are hearing these pluses.

Either run a distrubuted copmuting project like seti@home or add
Code:
no-hlt
to your kernel command line in grub.conf,
Both have the same effect, they prevent the CPU entering the halt state by keeping it busy.
-hth-
Krieger is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Installing nForce drivers on Debian 3.0 Doink NVIDIA Linux 4 09-14-02 08:34 PM
Detonator Drivers (40.xx) and nForce. Philibob NVIDIA Windows Graphics Drivers 1 09-07-02 12:49 PM
nvidia drivers in a motherboard with AGP 1.0 (motherboard MVP3+) knocker NVIDIA Linux 1 08-19-02 01:57 AM

All times are GMT -5. The time now is 09:06 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.