Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-28-04, 11:21 AM   #1
Wernu
Registered User
 
Join Date: Nov 2004
Posts: 4
Unhappy mandrakelinux 10.0 nForce and USB

Hi, this is a long list for a long story i woul'd like to solve
before 2010 !


Hardware is as follows :

CPU AMD Athlon XP 2600+ nVidia nForce2 Chipset Based K7N2G Series
MSI MS-6570 (V1.X) ATX Mainboard

Printer : HP PSC1210 series (USB interface)
Modem : Sweex 56KUSBV.92

Problem :

MANDRAKE LINUX 10.0 CAN'T DETECT USB PRINTER NOR USB MODEM !!

______________________________________________

both devices are working properly with Windows XP !!!!!!
______________________________________________


The configuration menu (system - configure - hardware ) leads to :

USB controllers 1.0 / 1.0 / 2.0

Vendor : nVidia Corporation
Bus : PCI
Bus identification : 10de:68:1462:5700
Location : 0:2:0 / 0:2:1 / 0:2:2
Description : nForce2 USB 1.0 OHCI Controller
1.0 OHCI Controller
2.0 Enhanced Controller
Module : usb-ohci
usb-ohci
ehci-hcd
Media class : Serial_USB

as well as :

Host Controllers

Vendor : Linux 2.6.3-7mdk ohci-hcd (ohci-hcd, ehci-hcd respectively)
Bus / Bus-ID : none
Location : none
Description : OHCI Host Controller
OHCI Host Controller
EHCI Host Controller (respectively)

Output for the commands

lspci

00:02.0 USB Controller : nVidia Corporation nForce2 USB Controller ( rev. a4 )
00:02.1 USB Controller : nVidia Corporation nForce2 USB Controller ( rev. a4 )
00:02.2 USB Controller : nVidia Corporation nForce2 USB Controller ( rev. a4 )

lsusb

BUS 003 Device 001: ID 0000:0000
BUS 002 Device 001: ID 0000:0000
BUS 001 Device 001: ID 0000:0000

NOTE :

MANDRAKELINUX 10.0 USAGE NOTES ABOUT SOME VIA CHIPSETS HAVING PROBLEMS
WITH USB DIDN'T HELP !

Some problem related messages given by mdk :

File /var/log/boot.log

...localhost usb: Initializing USB controller (usb-ohci): succeeded
...localhost usb: Initializing USB controller (usb-ehci-hcd): succeeded
...localhost usb: Mount USB filesystem succeeded
...localhost modprobe: cupsd: no process killed
...localhost usb: Loading USB printer succeeded


File /var/log/kernel/errors

...localhost kernel: hub 3-0:1.0: Cannot enable port 1. Maybe the USB cable is bad ?
...localhost kernel: hub 3-0:1.0: over-current change on port 1

the same messages for ports 2 to 6
BUT not for hub 2-0 or hub 1-0

File /root/drakx/install.log1

NVIDIA_kernel-2.6.3.7mdk-5336-6mdk.i586.rpm
NVIDIA_kernel-2.4.25.2mdk-5336-6mdk.i586.rpm
NVIDIA_GLX-5336-6mdk.i586.rpm
cups-1.1.20-5mdk.i586.rpm
cups-drivers-1.1-133mdk.i586.rpm

File /root/drakx/stage1.log

* PCI: device 10de 0067 ffff ffff is "", driver is usb-ohci
* have to insmod ohci-hcd
* needs usbcore
* needs ohci-hcd
* succeeded ohci-hcd
* PCI: device 10de 0067 ffff ffff is "", driver is usb-ohci
* PCI: device 10de 0068 ffff ffff is "", driver is ehci-hcd
* have to insmod ehci-hcd
* needs ehci-hcd
* succeeded ehci-hcd
* have to insmod usbkbd
* needs usbkbd
* succeeded usbkbd


File /var/log/dmesg (as well as in /var/log/kernel/info)

drivers/usb/core/usb.c: registered new driver usbfs
drivers/usb/core/usb.c: registered new driver hub
ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ohci_hcd: block sizes: ed 64 td 64
ohci_hcd 0000:00:02.0: OHCI Host Controller
PCI: Setting latency timer of device 0000:00:02.0 to 64
ohci_hcd 0000:00:02.0: irq 10, pci mem df826000
ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 3 ports detected
ohci_hcd 0000:00:02.1: OHCI Host Controller
PCI: Setting latency timer of device 0000:00:02.1 to 64
ohci_hcd 0000:00:02.1: irq 5, pci mem df926000
ohci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
ehci_hcd 0000:00:02.2: EHCI Host Controller
PCI: Setting latency timer of device 0000:00:02.2 to 64
ehci_hcd 0000:00:02.2: irq 10, pci mem df928000
ehci_hcd 0000:00:02.2: new USB bus registered, assigned bus number 3
PCI: cache line size of 64 is not supported by device 0000:00:02.2
ehci_hcd 0000:00:02.2: USB 2.0 enabled, EHCI 1.00, driver 2003-Dec-29
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 6 ports detected
drivers/usb/core/usb.c: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
...
0: nvidia: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-5336
___Wed Jan 14 18:29:26 PST 2004
hub 3-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?
hub 3-0:1.0: over-current change on port 1

! same as in /var/log/kernel/errors !

NOTE : the IRQ settings in Windows XP

IRQ10 NVIDIA nForce PCI System Management
IRQ10 Universal Serial Bus (USB) Controller
IRQ21 Standard OpenHCD USB Host Controller
IRQ22 Standard OpenHCD USB Host Controller

File /var/log/ksyms.0

Fri Nov 26 16:23:59 CET 2004
Linux localhost 2.6.3-7mdk #1 Wed Mar 17 15:56:42 CET 2004 i686
___unknown unknown GNU/Linux
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 10
model name : AMD Athlon(tm) XP 2600+
stepping : 0
cpu MHz : 1913.459
cache size : 512 KB
...
nvidia 2073216 0 - Live 0xdfd78000
usblp 12288 0 - Live 0xdf95e000
ehci-hcd 24196 0 - Live 0xdf93b000
ohci-hcd 18692 0 - Live 0xdf92d000
usbcore 99132 5 usblp,ehci-hcd,ohci-hcd, Live 0xdf944000


Thanks for having the patience to read all this stuff. So maybe
someone has an uncle who solved exactly the same problem and
reports me at least his uncles name.
Wernu is offline   Reply With Quote
Old 12-18-04, 04:04 AM   #2
stune62
Registered User
 
Join Date: Dec 2004
Posts: 1
Default Re: mandrakelinux 10.0 nForce and USB

hi !
this has been solved using mandrake 10.1 (same problems with nforce2 and mdk 10)

but not sure you will be able to use USB modem (http://linmodems.org

[quote=Wernu]
[...]
MANDRAKE LINUX 10.0 CAN'T DETECT USB PRINTER NOR USB MODEM ![...]
stune62 is offline   Reply With Quote
Old 12-21-04, 10:28 AM   #3
Wernu
Registered User
 
Join Date: Nov 2004
Posts: 4
Default Re: mandrakelinux 10.0 nForce and USB

usb / mdk 10

thanks for your hint !!

Wernu
Wernu is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.