Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-30-04, 08:30 PM   #1
loflyingplane
Registered User
 
Join Date: Dec 2004
Posts: 4
Default installer chokes on processor id

I've downloaded the driver ia32 for my computer.
I've got the gForce 440 using a pentium 3.
Anyway, when I run the installer NVIDIA-linux-x86-1.0-6111-pkg1.run.txt I get the message that I'm running an ix86 processor and this installer is for the
x86 only and the install is aborted.
Let me know if you need any more info. I'm sure it's straightforward.
loflyingplane is offline   Reply With Quote
Old 12-30-04, 09:24 PM   #2
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: installer chokes on processor id

Did you try with the latest (66.29)?
Lithorus is offline   Reply With Quote
Old 12-30-04, 10:02 PM   #3
loflyingplane
Registered User
 
Join Date: Dec 2004
Posts: 4
Default Re: installer chokes on processor id

No, I didn't. I'm assuming the 6629 was just released.
The time stamp on my downloaded file is 11/28 but maybe that date is in error. I'll give it a try.
Thanks for the heads up.
loflyingplane is offline   Reply With Quote
Old 12-31-04, 06:26 AM   #4
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: installer chokes on processor id

It got released quite some time ago actually. I would expect a new release soon actually.
Lithorus is offline   Reply With Quote
Old 12-31-04, 04:05 PM   #5
loflyingplane
Registered User
 
Join Date: Dec 2004
Posts: 4
Default Re: installer chokes on processor id

I downloaded the latest version available(6629 pkg 1) of ia32 and tried the installer.
I still get the "this .run file is intended for x86 installation. You appear to be running Linux i?86. Installation aborted.
Help. Please...
loflyingplane is offline   Reply With Quote
Old 12-31-04, 04:16 PM   #6
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: installer chokes on processor id

The error message is printed by `makeself`, which doesn't recognize i?86, as reported by `uname -m 2` on your system.
zander is offline   Reply With Quote
Old 12-31-04, 09:30 PM   #7
loflyingplane
Registered User
 
Join Date: Dec 2004
Posts: 4
Default Re: installer chokes on processor id

Yes, I can reproduce this. So... I guess I can either somehow get the machine to quit replying with the i?86 or get the installer to accept the
i?86 or other. Can someone with vast Linux experience explain where I might modify the uname response or some other fix?
loflyingplane is offline   Reply With Quote
Old 01-01-05, 06:01 AM   #8
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: installer chokes on processor id

The `uname` core utility gets the name from the kernel; the easiest workaround in your case probably is something along these lines:

# sh NVIDIA-Linux-x86-1.0-6629-pkg0.run --extract-only
# cd NVIDIA-Linux-x86-1.0-6629-pkg0
# ./nvidia-installer
zander is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:32 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.