Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-21-02, 04:39 PM   #1
hirschma
Registered User
 
hirschma's Avatar
 
Join Date: Nov 2002
Posts: 10
Default Can't get AGP enabled - help!

I'm hoping that someone can help me get AGP enabled on my Gentoo installation. This has never been an issue before with other computers.

The machine in question is a Dell Dimension 4550 with i845PE chipset. I have a Gainward dual DVI Ti4600 in the machine.

Video works fine except for the AGP issue, and everything is fine under Win2k on the same machine. Using the 3123 drivers.

Some info... from /proc...
Code:
jonathan@bigdell log $ cat /proc/driver/nvidia/agp/card
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       4x 2x 1x
Registers:       0x1f000217:0x00000000

jonathan@bigdell log $ cat /proc/driver/nvidia/agp/host-bridge
Host Bridge:     Intel (unknown)
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       4x 2x 1x
Registers:       0x1f000217:0x00000000

jonathan@bigdell log $ cat /proc/driver/nvidia/agp/status
Status:          Disabled
from lsmod:
Code:
Module                  Size  Used by    Tainted: P
smbfs                  32256   1  (autoclean)
NVdriver             1062976  10
agpgart                25580   0
rtc                     6720   0  (autoclean)
I've tried using and not using agpgart, didn't help.

from dmesg:
Code:
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 203M
agpgart: Detected Intel i845G chipset
agpgart: AGP aperture is 128M @ 0xe0000000
note that agpgart picks up a diifferent chipset.

from /etc/modules.d/nvidia:
Code:
jonathan@bigdell etc $ cat /etc/modules.d/nvidia
alias char-major-195 NVdriver
options agp_try_unsupported=1
(i've also tried without the try_unsupported, too).

My /etc/X11/XF86Config...

Code:
Section "Device"
    Identifier  "ti4600"
    Driver      "nvidia"
    #VideoRam    131072
    # Insert Clocks lines here if appropriate
    Option "ConnectedMonitor" "DFP,DFP"
#    Option "UseEdidFreqs" "true"
    Option "TwinView"
    Option "NvAgp" "3"
    Option "MetaModes" "1024x768,1024x768"
    Option "SecondMonitorHorizSync" "31.5 - 57.0"
    Option "SecondMonitorVertRefresh" "50-90"
    Option "TwinViewOrientation" "LeftOf"
    Option "NoLogo" "false"
    Option "CursorShadow" "true"
EndSection
Again, video is great (especially twinview on two digital FPDs!), just no AGP.

Lastly, two warnings from /var/log/XFree86.0.log:
Code:
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(WW) NVIDIA(0): Failed to verify AGP usage
Not sure if the APM warning is related or not.

Anyone have any ideas?

Thanks.

jonathan
hirschma is offline   Reply With Quote
Old 11-21-02, 05:33 PM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Have you tried using NVAGP? (Option "NvAgp" "1") It's recommended that you reboot when switching AGP drivers, as some chips don't appreciate being reprogrammed.

The APM message is unrelated.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 11-21-02, 06:23 PM   #3
hirschma
Registered User
 
hirschma's Avatar
 
Join Date: Nov 2002
Posts: 10
Default

Quote:
Originally posted by Andy Mecham
Have you tried using NVAGP? (Option "NvAgp" "1")


--andy
Did not work. Removed agpgart from /etc/modules.autoload, changed the option as per above, rebooted. No dice, I'm afraid.

jonathan
hirschma is offline   Reply With Quote
Old 11-21-02, 08:31 PM   #4
tspinillo
Registered User
 
Join Date: Sep 2002
Posts: 29
Default AGP

I had a similiar problem (ASUS-P533-V 845G chipset). I removed agpgart.o from /lib/modules/kernelversion etc. depmod -a.
As a sanity check, verify NvAgp is set to 1 as Andy said and check loaded modules (lsmod) to be sure that the kernel's agpgart is not loaded.

With any luck. I'll be installing a 845PE board this weekend, I will re-verify and check in if I see a problem on this end.

Good luck,

t
tspinillo is offline   Reply With Quote
Old 11-22-02, 12:27 AM   #5
hirschma
Registered User
 
hirschma's Avatar
 
Join Date: Nov 2002
Posts: 10
Unhappy Still not happening

Renamed agpgart.o and ran depmod -a. lsmod confirms that it is not loaded. NvAgp definitely set to "1". Still showing disabled...

Thanks for the idea.

jonathan
hirschma is offline   Reply With Quote
Old 06-22-03, 01:12 PM   #6
churritz
Registered User
 
Join Date: Jun 2003
Posts: 11
Default

This problem can be fixed by selecting a SINGLE the kernel agp driver for your card in kernel configuration. If you have I8* and AMD760 compiled together it may never see either of them. Just pick one and it should enable agp

Last edited by churritz; 06-22-03 at 02:13 PM.
churritz is offline   Reply With Quote
Old 06-22-03, 09:04 PM   #7
etr
Registered User
 
Join Date: Aug 2002
Location: NC, US
Posts: 55
Default

Are you using a custom compiled kernel? The driver does call some kernel code, and will fail to load if it is not available. I got a similar message and it was ultimately traced down to my having compiled MTRR (memory type range register) support into my kernel.
etr is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Detonator 40.71 frenzy A-KO NVIDIA Windows Graphics Drivers 41 10-03-02 08:25 AM
AGP not being enabled on Geforce2 mx frankjr NVIDIA Linux 1 09-22-02 02:01 PM
agp 440bx/zx tntultar32 t00bad NVIDIA Linux 1 09-11-02 02:46 PM
How much heat can a GeForce4 Ti 4600 handle? Velkator NVIDIA GeForce 7, 8, And 9 Series 4 09-03-02 04:41 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 04:56 PM

All times are GMT -5. The time now is 06:21 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.