Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-29-04, 05:51 AM   #1
imoore
Registered User
 
Join Date: Dec 2004
Posts: 6
Default GLX module fails to load on FreeBSD 5.3-p2, Xorg6.8.1

Hi,
I've been using the 1.0.6113 driver with FreeBSD 5.3-p2 & Xorg 6.7.0 without any trouble. I cvsuped my ports the other day and updated everything. Now I have Xorg 6.8.1 and the Nvidia driver 1.0.6113_2 port installed.
When I start X, the nvidia driver loads (I see the splash screen) but OpenGL apps run *very* slowly.
In the Xorg.0.log log file, it looks like glx fails to load, but 2D acceleration works:
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(**) NVIDIA(0): DPMS enabled
(EE) NVIDIA(0): Failed to load GLX

The card is a GeForce4 Ti 4200. The only change I made to my config files after the upgrade was changing the keyboard driver in xorg.conf from keyboard to kbd. I've attached the xorg.conf file & the Xorg log file.

sysctl -a hw.nvidia gives:
hw.nvidia.agp.card.rates: 8x 4x
hw.nvidia.agp.card.fw: supported
hw.nvidia.agp.card.sba: supported
hw.nvidia.agp.card.registers: 0x1f000e1b:0x1f000302
hw.nvidia.agp.status.status: enabled
hw.nvidia.agp.status.driver: nvidia
hw.nvidia.agp.status.rate: 8x
hw.nvidia.agp.status.fw: disabled
hw.nvidia.agp.status.sba: enabled
hw.nvidia.version: NVIDIA FreeBSD x86 NVIDIA Kernel Module 1.0-6113 Mon Aug 2 16:08:32 PDT 2004
hw.nvidia.registry.EnableVia4x: 0
hw.nvidia.registry.EnableALiAGP: 0
hw.nvidia.registry.NvAGP: 1
hw.nvidia.registry.EnableAGPSBA: 0
hw.nvidia.registry.EnableAGPFW: 0
hw.nvidia.registry.SoftEDIDs: 1
hw.nvidia.registry.Mobile: 4294967295
hw.nvidia.registry.ResmanDebugLevel: 4294967295
hw.nvidia.registry.FlatPanelMode: 0
hw.nvidia.cards.0.model: GeForce4 Ti 4200 with AGP8X
hw.nvidia.cards.0.irq: 11
hw.nvidia.cards.0.vbios: 04.28.20.21.00
hw.nvidia.cards.0.type: AGP

Hope someone can help.

Cheers,
Ian
Attached Files
File Type: txt Xorg.0.log.txt (26.6 KB, 188 views)
File Type: txt xorg.conf.txt (3.3 KB, 211 views)
imoore is offline   Reply With Quote
Old 12-29-04, 07:26 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: GLX module fails to load on FreeBSD 5.3-p2, Xorg6.8.1

(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="X.Org Foundation"
compiled for 6.8.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="X.Org Foundation"
compiled for 6.8.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="X.Org Foundation"
compiled for 6.8.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/freebsd/libdrm.a
(II) Module drm: vendor="X.Org Foundation"
compiled for 6.8.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension XFree86-DRI


The X server is loading its own GLX extension module; reinstalling the NVIDIA driver should fix that problem. If it doesn't, then try libglx.a out of the way.
zander is offline   Reply With Quote
Old 12-29-04, 07:50 AM   #3
imoore
Registered User
 
Join Date: Dec 2004
Posts: 6
Default Re: GLX module fails to load on FreeBSD 5.3-p2, Xorg6.8.1

Quote:
Originally Posted by zander
The X server is loading its own GLX extension module; reinstalling the NVIDIA driver should fix that problem. If it doesn't, then try libglx.a out of the way.
Thanks, reinstalling fixed the problem :-)

Cheers,
Ian
imoore is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 02:24 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 11:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM

All times are GMT -5. The time now is 04:04 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.