Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-03-05, 03:30 PM   #1
Anandh
Registered User
 
Join Date: Jan 2005
Posts: 3
Default Nvidia 5200Go on MDK 10.1 - How to get AGP 8x mode to work

Hi,

When I run UT2004 on my laptop (Dell Inspiron 5160), it seems to work well with Windows XP, and comparitively slower on MDK 10.1 Official with nvidia 1.0-6629.

glxgears reports to have an average fps of 2500.

My system config is as follows:
P4 3.06 GHz HT running on 2.6.8.1 SMP kernel on Mdk 10.1, with 1GB Pc2700 DDR, nVidia Geforce FX Go5200 running on 1.0-6629 nvidia driver.

Any suggestions on how do I go about setting up the graphics card to work under an 8X agp mode ?

Thanks.
Anandh
Anandh is offline   Reply With Quote
Old 01-03-05, 05:53 PM   #2
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Nvidia 5200Go on MDK 10.1 - How to get AGP 8x mode to work

Could you please post the content of all files in:
/proc/driver/nvidia/agp
and
/proc/driver/nvidia/cards?
chunkey is offline   Reply With Quote
Old 01-03-05, 09:18 PM   #3
Anandh
Registered User
 
Join Date: Jan 2005
Posts: 3
Default Re: Nvidia 5200Go on MDK 10.1 - How to get AGP 8x mode to work

Hi Chunkey

cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Enabled
SBA: Enabled

cat /proc/driver/nvidia/agp/card
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x1f000314

cat /proc/driver/nvidia/agp/host-bridge
Host Bridge: PCI device 8086:3580
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000314

cat /proc/driver/nvidia/cards/0
Model: GeForce FX Go5200
IRQ: 20
Video BIOS: 04.34.20.34.d2
Card Type: AGP

Thanks

Anandh
Anandh is offline   Reply With Quote
Old 01-04-05, 05:09 AM   #4
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Nvidia 5200Go on MDK 10.1 - How to get AGP 8x mode to work

Well it seems your card & agp-bridge only support up to 4x...

Also Dell says:
32 MB DDR 4X AGP NVIDIA GeForce FX Go5200
64 MB DDR 4X AGP NVIDIA GeForce FX Go5200

http://www1.us.dell.com/content/prod...&~tab=specstab



Are you sure that Windows runs in AGP 8x?
chunkey is offline   Reply With Quote
Old 01-04-05, 07:16 PM   #5
Anandh
Registered User
 
Join Date: Jan 2005
Posts: 3
Default Re: Nvidia 5200Go on MDK 10.1 - How to get AGP 8x mode to work

Chunkey,

Seems like you're right. Though the card supports AGP 8x, the slot supports only 4x transport speeds. So, that explains why I couldn't get the 8x rate.

Can you tell me how I can get the nvidia's nvagp to work instead of the agpgart ? I tried forcing the option nvagp to be used in the XF86config, it first failed to startx, on a restart it started x, but the agp status in proc, reports the agp to be disabled.

Do I need to recompile my kernel without agpgart support ? and if so, which section do I need to look for it ? And if possible also tell me how to disable the rivafb support in my kernel config.

Thanks for all the help.
Anandh
Anandh is offline   Reply With Quote
Old 01-04-05, 08:11 PM   #6
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Nvidia 5200Go on MDK 10.1 - How to get AGP 8x mode to work

Well, I don't know if nvagp really increase your performance in ut2004, some this is may "wasted" time... but anyway, if you're willing to try it... here we go...

NVagp can only be used when agpgart is not loaded in kernel.... (see nvidia's readme file.. somewehre at line 1850)...

For easiest, but dirtiest solutions you've to rename your agpgart kernel modules(something agpgart.ko or if you still use 2.4 agpgart.o), ... and reboot...
(there should be in /lib/modules/$YOUR_KERNEL_VERSION/kernel/drivers/char)
(now check what /proc/driver/nvidia/agp/status says)

you could also recompile the kernel... But for this it maybe the best to PM some guys here, which use Mandrake 10.1 and have a homemade kernel.
chunkey is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 09:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 11:34 AM

All times are GMT -5. The time now is 09:47 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.