Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-25-04, 10:45 PM   #1
sprocket87
Registered User
 
Join Date: Dec 2004
Posts: 1
Default nForce driver won't work - Libranet 2.8.1

Hey all, more or less of a noob here, I've dabbled with Linux on and off and know my way around, but I'm stuck at the moment. Just installed Libranet 2.8.1 and it autodetected all my devices fine, except the NIC. I have the A7N8X or some variation, and I downloaded the newest NFORCE-Linux0x86-1.0-0292 pkg from the site.

The first time I ran "sh NFORCE......" and got something about the kernel source not being found. I thought I had opted to include the extra source packages when I did the OS install, but just for fun I tooled around in the XAdminmenu kernel app and it recompiled or something (sorry for the lack of specifics )

Anyway, now when I run it I get the following:

"No precompiled kernel interface was found to match your kernel..."
"Installer will compile a new kernel interface" (or something)
Then a progress bar appears, gets to about 15%, and then dies with an error message:
"Unable to build"

I checked the log and I forgot to write down exactly what part it choked at, I can try again if you need to know (its just a pain cause I have to reboot into Windows to get on the Internet now )

Also, this Libranet 2.8.1 is the 2.4.21 kernel. I read that this kernel should have the forcedeth module which should support my NIC, but I can't find it when I run the config prog. I've also tried a "modprobe forcedeth", but it said "module not found" or something. Eh?

Any help out there? Thanks all!

Jesse
sprocket87 is offline   Reply With Quote
Old 01-06-05, 08:43 PM   #2
SupportLinux!
Registered User
 
Join Date: Jan 2005
Posts: 3
Default Re: nForce driver won't work - Libranet 2.8.1

Wow. A week and no answer. I guess NVidia's support people don't bother visiting these forums...

If you do a "make menuconfig" to configure your Linux kernel before you compile, you'll find the kernel's (the driver was reverse-engineered by some great Linux kernel gurus -- no NVidia support) driver under:

"Network device support --->" "Ethernet (10 or 100Mbit) --->" then check the box for "EISA, VLB, PCI and on board controllers" and you should see the option for "nForce Ethernet support (EXPERIMENTAL)".

Hope it helps.
SupportLinux! is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Cannot load nvaudio driver (NVidia nforce) thahn01 NVIDIA Linux 4 09-13-02 01:28 AM
Newby question about nforce.... superconti NVIDIA Linux 2 09-07-02 11:46 PM
new nforce driver!! 1.12!! frenchy2k1 CPUs, Motherboards And Memory 9 08-27-02 01:09 AM

All times are GMT -5. The time now is 03:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.