Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-07-05, 03:19 AM   #1
lformaggia
Registered User
 
Join Date: Jan 2005
Posts: 1
Unhappy Audio on K8NS (nforce3)

Hello,

I have recently installed Mandrake 10.1 on a Athlon 64 linux box (yet I am using the 32 bits version of the OS) based on a GA-K8NS motherboards that mounts the nForce3 250 chipset.

I have installed the latest Nvidia drivers: NFORCE-Linux-x86-1.0-0292, and all seems fine a part the audio! More precisely I am able to get some audio (very low volume) from the front jack (earphones), yet nothing happens to the rear jacks, where I have the speakers connected..

The nvmixer tool starts fine finding the hardware, the module is loaded, yet no sound is coming out. I have Linux kernel 2.6.8.

One strange thing is that when I am rebooting Win XP after having used Linux, the speakers won't work until I restart the audio system using the Realtek utility that comes with the Win XP installation. It seems that the Linux NVidia driver messes up the audio system somehow.

Has anybody any clue of what can be done? I really want to have audio properly working on Linux.

P.S. I have used also the other open source drivers that ships with Mandrake... with no success.

Thanks,

Luca
lformaggia is offline   Reply With Quote
Old 01-20-05, 04:47 PM   #2
HellSpawn
Registered User
 
Join Date: Jan 2005
Posts: 21
Default Re: Audio on K8NS (nforce3)

I have the same mobo, and had the same problem but with FC3 x86_64, I had to changed back to the FC3 audio drivers, I don't know mandrake but I give you a copy of my /etc/modprobe.conf any way:

alias eth0 forcedeth
alias scsi_hostadapter sata_nv
alias snd-card-0 snd-intel8x0
#alias snd-card-0 nvsound
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>
&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove sn
d-intel8x0
alias snd-card-1 snd-usb-audio
options snd-card-1 index=1
install snd-usb-audio /sbin/modprobe --ignore-install snd-usb-audio && /usr/sbin/alsactl restore >/dev/null
2>&1 || :
remove snd-usb-audio { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove s
nd-usb-audio
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
# I2C module options
alias char-major-89 i2c-dev
alias char-major-195* nvidia

BTW, do you have lm_sensors working properly?? It seems that I'm not geeting good voltage readings from it...
HellSpawn is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
8800 GT: audio on TV with a DVI(PC) to HDMI(TV) cable? legluondunet NVIDIA Linux 0 06-23-12 08:58 AM
Upgrade from 290.10 to 295.49 on GeForce 8300 = no hdmi audio + overscan tbubel NVIDIA Linux 2 06-15-12 04:55 AM
No HDMI audio on 302.07 fldc NVIDIA Linux 5 06-01-12 05:46 PM
nForce Audio pergamon NVIDIA Linux 6 12-26-02 12:38 AM
Bohooo HELP, new Nforce 1.13 Audio Utilities won INITIALIZE nanyangview CPUs, Motherboards And Memory 1 09-04-02 08:40 PM

All times are GMT -5. The time now is 02:42 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.