Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-12-05, 02:35 AM   #1
wildweasel
Registered User
 
Join Date: Jan 2005
Posts: 17
Default Installer problem debian

I am running debian sarge, kernel 2.6.9-9-amd64-k8.
I have an ASUS K8N motherboard - NVIDIA nforce chipset, as well as a an ASUS video card with NVIDIA 5200 as well.
I downloaded both AMD64 installers, but neither one works. The archives are verifed and the installers unpack fine.
When I run the scripts they both segfault and I get the following error messages:

# bash NFORCE-Linux-x86_64-1.0-0292-pkg1.run
Verifying archive integrity...OK
Uncompressing NVIDIA nForce drivers for Linux-x86_64 1.0-0292.............................................. ..............................
NFORCE-Linux-x86_64-1.0-0292-pkg1.run: line 615: 5312 Segmentation fault $script $scriptargs $*

# bash NVIDIA-Linux-x86_64-1.0-6629-pkg2.run
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 1.0-6629.............................................. ...........................
NVIDIA-Linux-x86_64-1.0-6629-pkg2.run: line 653: 5342 Segmentation fault $script $scriptargs $*

What I am doing wrong - are there any additional packages I need to install?
wildweasel is offline   Reply With Quote
Old 01-12-05, 03:24 AM   #2
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: Installer problem debian

Is the rest of your system 64 bit? Currently debian doesn't offer an official x86_64 distribution and so far they only offer a few libraries and some kernels compiled for x86_64 in the official package lists. This means that while your kernel may be 64-bit, the rest of the system isn't and is merely running in 32-bit. There is a way to use "beta" packages and get a completely 64-bit debian system, but until arch x86_64 is officially in their system, I would much rather recommend using a distro like Ubuntu which is based on debian but provides the x86_64 packages officially.
Lithorus is offline   Reply With Quote
Old 01-12-05, 02:58 PM   #3
wildweasel
Registered User
 
Join Date: Jan 2005
Posts: 17
Default Re: Installer problem debian

Thanks for the reply.

I didn't do anything special to the system, other than selecting the AMD64 kernel when running the install off the debian i386 sarge install disk. so I'm assuming its 32 bit.
Would that cause the installer to blow up? I'm no expert, but it doesn't seem to get very far (the two above snippets are the entire output when I try and run the twoinstallers).
I like Debian alot. Should I use the 32 bit installers? Should I try to compile from source? Or is the only real option to switch distros?
If so how close to Debian is Ubuntu? Does Knoppix have a full AMD64 system?
wildweasel is offline   Reply With Quote
Old 01-12-05, 03:11 PM   #4
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Installer problem debian

Well, what about: amd64 sid/sarge netinst isos?
http://debian-amd64.alioth.debian.org/install-images/

But then dont forget to read: (really, you should do it... )
https://alioth.debian.org/docman/vie...d64-howto.html
chunkey is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ti4200 and Linux Install Problem ultrajava NVIDIA Linux 5 09-28-02 09:13 AM
Problems with a GeForce4 MX 440 under Debian Iainuki NVIDIA Linux 1 09-24-02 10:27 PM
Riva TNT 2 - Debian (Woody) chipset problem sindra NVIDIA Linux 4 08-26-02 04:21 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 11:58 AM

All times are GMT -5. The time now is 11:53 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.