Go Back   nV News Forums > Hardware Forums > General Hardware

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-01-05, 12:44 PM   #1
Marcos
think of me not at all
 
Marcos's Avatar
 
Join Date: Oct 2004
Location: Americas
Posts: 845
Send a message via AIM to Marcos
Default got XConnect ultra 500w

:drool:



sexy, it was on sale w/ rebate @ compusa .

My only problem with it is the ATX power cable is a bitch to bend around, it feels like it could snap a mobo in 2...
it was funny to see how quiet everything is with the 4 case fans unplugged.
__________________
[64 3500+][MSI Neo2 Plat] [6800gt][Audigy 2][Hamixada is a fag]


<-- worst. smiley. ever.
Marcos is offline   Reply With Quote
Old 02-01-05, 02:17 PM   #2
crainger
 
crainger's Avatar
 
Join Date: Aug 2004
Location: Coffs Harbour, NSW, Australia
Posts: 29,559
Send a message via AIM to crainger
Default Re: got XConnect ultra 500w

How is it?? I've seen alot of reviews for the Xconnect Ultra, most raving how good it is... On this forum however alot say its a very poor supply. I've been trying to decided between one of these and an OCZ Powersupply, which is next to impossible to find in Australia. The XConnects on the other hand are popping up all over the place.
crainger is offline   Reply With Quote
Old 02-01-05, 02:55 PM   #3
Marcos
think of me not at all
 
Marcos's Avatar
 
Join Date: Oct 2004
Location: Americas
Posts: 845
Send a message via AIM to Marcos
Default Re: got XConnect ultra 500w

Its so far so good, But i have no idea how to tell how good it is haha. Everything stays stable on that MSI center thing. I had a problem with my Antec 350w cutting out on me so I had to replace it and this thing called to me like a siren.
__________________
[64 3500+][MSI Neo2 Plat] [6800gt][Audigy 2][Hamixada is a fag]


<-- worst. smiley. ever.
Marcos is offline   Reply With Quote
Old 02-01-05, 04:21 PM   #4
Yonkers
Registered User
 
Join Date: Oct 2004
Posts: 438
Default Re: got XConnect ultra 500w

I have one also and I like it. I have heard nothing but good things from it. Most here are Antec fans, with good reason but I just had to get the Ultra X.
Yonkers is offline   Reply With Quote
Old 02-01-05, 04:24 PM   #5
BrianG
aka HalcYoN - Hook Em!
 
BrianG's Avatar
 
Join Date: Jul 2002
Location: Austin, TX, USA
Posts: 1,184
Default Re: got XConnect ultra 500w

I did not like how loose the connections on the PSU side were. I was limited for space and the bend combined with the inflexible mobo line made using the X-Connect impossible as the cable kept unseating.

If i had a bigger rig, no doubt I would give it another shot.
__________________
Brian - aka HalcYoN

photobriangray
Nikon D700 and D300s | SB-600 | Tamron 28-75/2.8 | Tamron 17-50/2.8 | Nikon 70-200VR I
10.5/2.8 Fisheye | 28/1.8 AF-S | 35/1.8 AF-S | 50/1.8 | 105/F2 AF-D | Sigma 150/2.8 Macro
Nikon J1 | 10-30VR |30-100VR | 10/2.8 | 18/1.8

Last edited by BrianG; 02-01-05 at 04:25 PM. Reason: grammar
BrianG is offline   Reply With Quote
Old 02-01-05, 04:53 PM   #6
bkswaney
Mr. Extreme!
 
bkswaney's Avatar
 
Join Date: Aug 2002
Location: SC
Posts: 3,421
Send a message via Yahoo to bkswaney
Default Re: got XConnect ultra 500w

No problems here.
I've had mine for going on 3 months.
It's the most stable unit to date for me.
__________________
Notebook!
Compaq Presario CQ60-215DX
AMD 64 Athlon X2 @ 2GHz (QL62)
15.6 inch HD WideScreen
Nvidia 8200M-G 895mb
2Gig system ram
250Gig SATA 5400rpm HDrive
Vista Premium
bkswaney is offline   Reply With Quote
Old 02-01-05, 07:56 PM   #7
Marcos
think of me not at all
 
Marcos's Avatar
 
Join Date: Oct 2004
Location: Americas
Posts: 845
Send a message via AIM to Marcos
Default Re: got XConnect ultra 500w

i have no problems with connections on the psu side..
__________________
[64 3500+][MSI Neo2 Plat] [6800gt][Audigy 2][Hamixada is a fag]


<-- worst. smiley. ever.
Marcos is offline   Reply With Quote
Old 02-01-05, 08:59 PM   #8
XP_GUN
Registered User
 
XP_GUN's Avatar
 
Join Date: Jun 2003
Location: Orange CA.
Posts: 1,086
Default Re: got XConnect ultra 500w

Yeah mine works great here, its a really good powersuppy I hope your happy
__________________
Yeah I use a Mac Mini now....
XP_GUN is offline   Reply With Quote

Old 02-02-05, 12:25 AM   #9
bkswaney
Mr. Extreme!
 
bkswaney's Avatar
 
Join Date: Aug 2002
Location: SC
Posts: 3,421
Send a message via Yahoo to bkswaney
Default Re: got XConnect ultra 500w

Quote:
Originally Posted by XP_GUN
Yeah mine works great here, its a really good powersuppy I hope your happy

I've saw a few post where some have had problems.
But with any product there are going to be good
and bad parts.

But it seems for the most part everyone loves there's.
I know I do. My rig is more stable than with my old Antec Trueblue 480.
Not only does the PSU look bad@ss it's performance is great to.
__________________
Notebook!
Compaq Presario CQ60-215DX
AMD 64 Athlon X2 @ 2GHz (QL62)
15.6 inch HD WideScreen
Nvidia 8200M-G 895mb
2Gig system ram
250Gig SATA 5400rpm HDrive
Vista Premium
bkswaney is offline   Reply With Quote
Old 02-02-05, 07:46 PM   #10
crainger
 
crainger's Avatar
 
Join Date: Aug 2004
Location: Coffs Harbour, NSW, Australia
Posts: 29,559
Send a message via AIM to crainger
Default Re: got XConnect ultra 500w

Quote:
Originally Posted by Marcos
Its so far so good, But i have no idea how to tell how good it is haha. Everything stays stable on that MSI center thing. I had a problem with my Antec 350w cutting out on me so I had to replace it and this thing called to me like a siren.
Hmmm, I may look into replacing my Antec 350 with one, I wonder how the UV reactive ones look. It sucks the place with exclusive rights to the Xconnect series in the whole of Australia is over 1000km away. Postage is gonna be a smack in the mouth
crainger is offline   Reply With Quote
Old 02-03-05, 03:06 PM   #11
Yonkers
Registered User
 
Join Date: Oct 2004
Posts: 438
Default Re: got XConnect ultra 500w

Quote:
Originally Posted by crainger
Hmmm, I may look into replacing my Antec 350 with one, I wonder how the UV reactive ones look. It sucks the place with exclusive rights to the Xconnect series in the whole of Australia is over 1000km away. Postage is gonna be a smack in the mouth
Here is mine.


Yonkers is offline   Reply With Quote
Old 02-04-05, 05:16 PM   #12
crainger
 
crainger's Avatar
 
Join Date: Aug 2004
Location: Coffs Harbour, NSW, Australia
Posts: 29,559
Send a message via AIM to crainger
Default Re: got XConnect ultra 500w

Dude, that looks sweet ass sweet, that would look mad with my water cooling setup, as its tubing glows a spooky purple/blue colour.
crainger is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:42 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.