Go Back   nV News Forums > Hardware Forums > General Hardware

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-04-05, 07:06 PM   #13
Eltigre88
ASUS Lover!!!
 
Eltigre88's Avatar
 
Join Date: Aug 2004
Location: Essex Jct. Vermont
Posts: 1,061
Default Re: got XConnect ultra 500w

Awesome power supply!!
__________________
ASUS Sabertooth P67
Intel SB 2600K 4.4 GhZ
16 GB Gskill RipJaws DDR3 2133
MSI 680GTX Twin Frozr 4GD5/OC, Galaxy 680GTX 4GB GC SLI
Samsung 840 Pro 256GB
ThermalTake ToughPower 850W PSU
Windows 8 Pro 64bit
16076 3dMark11 score

Last edited by Eltigre88; 10-14-13 at 04:00 PM.
Eltigre88 is offline   Reply With Quote
Old 02-04-05, 07:52 PM   #14
BrianG
aka HalcYoN - Hook Em!
 
BrianG's Avatar
 
Join Date: Jul 2002
Location: Austin, TX, USA
Posts: 1,184
Default Re: got XConnect ultra 500w

OK, now I wnat it back, but onoly if I get a new windowed case and some watercooling. Heh.
__________________
Brian - aka HalcYoN

photobriangray
Nikon D700 and D300s | SB-600 | Tamron 28-75/2.8 | Tamron 17-50/2.8 | Nikon 70-200VR I
10.5/2.8 Fisheye | 28/1.8 AF-S | 35/1.8 AF-S | 50/1.8 | 105/F2 AF-D | Sigma 150/2.8 Macro
Nikon J1 | 10-30VR |30-100VR | 10/2.8 | 18/1.8
BrianG is offline   Reply With Quote
Old 02-04-05, 10:01 PM   #15
bkswaney
Mr. Extreme!
 
bkswaney's Avatar
 
Join Date: Aug 2002
Location: SC
Posts: 3,421
Send a message via Yahoo to bkswaney
Default Re: got XConnect ultra 500w

Quote:
Originally Posted by BrianG
OK, now I wnat it back, but onoly if I get a new windowed case and some watercooling. Heh.

hehehe "lol"
They do look mean. The cables are nice.
I'm water cooled to. I love the UV stuff.
I just got in 2 new vantech UV case fans.
__________________
Notebook!
Compaq Presario CQ60-215DX
AMD 64 Athlon X2 @ 2GHz (QL62)
15.6 inch HD WideScreen
Nvidia 8200M-G 895mb
2Gig system ram
250Gig SATA 5400rpm HDrive
Vista Premium
bkswaney is offline   Reply With Quote
Old 03-14-05, 01:00 PM   #16
TierMann
Bite my shiny, metal @ss!
 
TierMann's Avatar
 
Join Date: Jun 2004
Location: PA, USA
Posts: 1,586
Default Re: got XConnect ultra 500w

My 500w UV Blue Ultra X-connect just came. Time to put this sexy thing in the case but it looks so nice just sitting here. Should look even better lit up . I bought a couple rounded blue UV IDE cables too. I'll get some pics one day if I get a decent cam.

Update: Installed. 2 words, "Holy Crap" (in a good way).
If I can't control myself, a new litter of baby x-connects will be available on the For Sale/Trade forums in a few months.
__________________
Athlon 64 4400+ X2 (10x250= 2.5ghz) | Foxconn NF4KS8AA-8EKRS (nForce4 SLI) | 2GB OCZ DDR400 @ 416 (3-3-3-8) | eVGA 8800GTS 320mb
Red Diabolic Minotaur Case | PCP&C 610 Silencer | Samsung 19" 997DF + Acer AL1914smd-8 | G15 Keyboard | MX Revolution | 900Gb Storage
Vista Ultimate 32 + Gentoo Linux (Gnome + Beryl)
Athlon XP 3000+ | ECS KM400M2 3.0 | 512mb DDR333 | PNY 5200 Ultra
TV-Tuner | Silver Aspire X-Qpack w/Windows | WinXP MCE 2005 | 200Gb Storage
DVD Collection -- MySpace

Last edited by TierMann; 03-14-05 at 02:26 PM.
TierMann is offline   Reply With Quote
Old 03-14-05, 06:19 PM   #17
Robilar
Registered User
 
Join Date: Mar 2005
Location: Toronto, Canada
Posts: 4
Default Re: got XConnect ultra 500w

I have a Antec true power 430w in my main rig but bought and changed to the x-connect 500w titanium (based on reviews, the removable cables which in my other rig, an antec super lanboy are really handy, and its appearance). I ran it for about a week in my rig and monitored its power levels with the DFI hardware monitor. It seems fine but honestly, my rigs internal temp is about 5-6C higher with the ultra and it is quite a bit louder than the antec. I switched the two p/s between my two systems and my case temp dropped back to prior levels and was "much" quieter so its safe to say that its a good p/s from a power perspective but definitely louder and much hotter (even though it operates on a push/pull airflow)
__________________
System Specs

Intel P4 3.4 (FSB800 Prescott), DFI LanParty 875P-T Board, 1 GB OCZ Dual DDR 400, WD Raptor 36 GB 10K Sata HDD, Audigy 2, XFX 6600GT AGP 128 MB, Zalman 7700CU CPU Fan , Zalman VF700CU Video Fan, NEC FE991SB 19", Plextor 712 DVD-RW, Antec SLK3000 Case (2 120 MM Fans, 1 80mm side mount fan), Antec True Power 430W P/S, Logitech MX310 Mouse, Logitech Elite Keyboard, Creative Inspire T3000 Speakers.
Robilar is offline   Reply With Quote
Old 03-14-05, 10:35 PM   #18
TierMann
Bite my shiny, metal @ss!
 
TierMann's Avatar
 
Join Date: Jun 2004
Location: PA, USA
Posts: 1,586
Default Re: got XConnect ultra 500w

Hmm. As far as sound goes, mine makes almost no noise at all. I couldn't even hear the 2 80mm fans unless I put my ear to the back and that was with my case open (I have dog ears too. Long story involving a dog and gamma radiation But that's another post). The only thing I can hear is the dual fans on my video card. I'm not saying it's not true that yours is indeed loud, but it's just strange how some seem to be quiet and others of the same model are loud.
__________________
Athlon 64 4400+ X2 (10x250= 2.5ghz) | Foxconn NF4KS8AA-8EKRS (nForce4 SLI) | 2GB OCZ DDR400 @ 416 (3-3-3-8) | eVGA 8800GTS 320mb
Red Diabolic Minotaur Case | PCP&C 610 Silencer | Samsung 19" 997DF + Acer AL1914smd-8 | G15 Keyboard | MX Revolution | 900Gb Storage
Vista Ultimate 32 + Gentoo Linux (Gnome + Beryl)
Athlon XP 3000+ | ECS KM400M2 3.0 | 512mb DDR333 | PNY 5200 Ultra
TV-Tuner | Silver Aspire X-Qpack w/Windows | WinXP MCE 2005 | 200Gb Storage
DVD Collection -- MySpace
TierMann is offline   Reply With Quote
Old 03-16-05, 08:43 AM   #19
Robilar
Registered User
 
Join Date: Mar 2005
Location: Toronto, Canada
Posts: 4
Default Re: got XConnect ultra 500w

Tiermann, have you tried an antec truepower? Now its nowhere as slick as the ultra but quality wise its rated tops. The thing is built like a tank with about a mille of wires hanging off it. Its power scales are rock solid and it makes very little noise (but the x-connect is prettier)
__________________
System Specs

Intel P4 3.4 (FSB800 Prescott), DFI LanParty 875P-T Board, 1 GB OCZ Dual DDR 400, WD Raptor 36 GB 10K Sata HDD, Audigy 2, XFX 6600GT AGP 128 MB, Zalman 7700CU CPU Fan , Zalman VF700CU Video Fan, NEC FE991SB 19", Plextor 712 DVD-RW, Antec SLK3000 Case (2 120 MM Fans, 1 80mm side mount fan), Antec True Power 430W P/S, Logitech MX310 Mouse, Logitech Elite Keyboard, Creative Inspire T3000 Speakers.
Robilar is offline   Reply With Quote
Old 03-16-05, 12:21 PM   #20
Marcos
think of me not at all
 
Marcos's Avatar
 
Join Date: Oct 2004
Location: Americas
Posts: 845
Send a message via AIM to Marcos
Default Re: got XConnect ultra 500w

mine is silent, the only thing i hear in my case is the 100mm on the back and the 68oogt stock fan
__________________
[64 3500+][MSI Neo2 Plat] [6800gt][Audigy 2][Hamixada is a fag]


<-- worst. smiley. ever.
Marcos is offline   Reply With Quote

Old 03-16-05, 02:02 PM   #21
TierMann
Bite my shiny, metal @ss!
 
TierMann's Avatar
 
Join Date: Jun 2004
Location: PA, USA
Posts: 1,586
Default Re: got XConnect ultra 500w

Quote:
Originally Posted by Robilar
Tiermann, have you tried an antec truepower? Now its nowhere as slick as the ultra but quality wise its rated tops. The thing is built like a tank with about a mille of wires hanging off it. Its power scales are rock solid and it makes very little noise (but the x-connect is prettier)
No, I havn't tried an antec yet. That was my second choice to the ultra. If it had made any noise in my case I would have sent it back and got the antec though. My uptime right now is 2 days and counting and so far I still can't hear one of it's fans or any vibrations. I'm anal about noise too.

Next upgrade on my g/f's computer I'll check out the antec truepower though.
__________________
Athlon 64 4400+ X2 (10x250= 2.5ghz) | Foxconn NF4KS8AA-8EKRS (nForce4 SLI) | 2GB OCZ DDR400 @ 416 (3-3-3-8) | eVGA 8800GTS 320mb
Red Diabolic Minotaur Case | PCP&C 610 Silencer | Samsung 19" 997DF + Acer AL1914smd-8 | G15 Keyboard | MX Revolution | 900Gb Storage
Vista Ultimate 32 + Gentoo Linux (Gnome + Beryl)
Athlon XP 3000+ | ECS KM400M2 3.0 | 512mb DDR333 | PNY 5200 Ultra
TV-Tuner | Silver Aspire X-Qpack w/Windows | WinXP MCE 2005 | 200Gb Storage
DVD Collection -- MySpace
TierMann is offline   Reply With Quote
Old 03-16-05, 02:33 PM   #22
H-street
Registered User
 
Join Date: Nov 2003
Posts: 138
Default Re: got XConnect ultra 500w

the only thing i don't like about my Xconnect is the fact that the exhaust fans don't really exhaust much.. i can see them spinning but they don't really put out anything..

which forced me to put in a secondary exhaust fan (and thus pretty much eliminates the noice reduction of the PSU)..
H-street is offline   Reply With Quote
Old 03-17-05, 06:45 AM   #23
Marcos
think of me not at all
 
Marcos's Avatar
 
Join Date: Oct 2004
Location: Americas
Posts: 845
Send a message via AIM to Marcos
Default Re: got XConnect ultra 500w

Quote:
Originally Posted by H-street
the only thing i don't like about my Xconnect is the fact that the exhaust fans don't really exhaust much.. i can see them spinning but they don't really put out anything..

which forced me to put in a secondary exhaust fan (and thus pretty much eliminates the noice reduction of the PSU)..

that dont sound like its working correctly
__________________
[64 3500+][MSI Neo2 Plat] [6800gt][Audigy 2][Hamixada is a fag]


<-- worst. smiley. ever.
Marcos is offline   Reply With Quote
Old 03-17-05, 06:58 AM   #24
MUYA
 
Join Date: Jul 2002
Location: Hong Kong
Posts: 6,794
Send a message via MSN to MUYA
Default Re: got XConnect ultra 500w

My antec doesn't exhaust a lot either...quiet operatiosns more heat tolerance within the PSU itself..methinks
__________________
I5-2500k@4.7GHz - MSI Z77A-GD65 - 4GB X2 A-DATA DDR3 1600 - Corsair H100 - Antec Quatro 850W
Gigabyte Windforce X3 GTX 680 OC - Dell 24" IPS
Intel 320 300 GB SSD - 1 TB Hitachi HDD - 2x 250 GB WD HDD
Corsair K90 - Corsair Venegance 2000 Headset - Razer Naga Epic
Corsair 600T Case
MUYA is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:18 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.