Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-02-02, 06:53 PM   #1
mas582
Registered User
 
Join Date: Dec 2002
Posts: 9
Question DVD acceleration?

Does anyone know if the Nvidia cards support DVD acceleration?

My DVD player skips in Linux, and I've manipulated hdparm a number of ways.

I'm running a AMD-1.4GHz processor, and the DVD drive is generic, but 16x. I don't see why it would skip, cause even if it was running it though software it should be good...... I know the DVD's are not scratched.

Any suggestions? thoughts?
__________________
Slack8.1
GeForce4 Ti 4200
mas582 is offline   Reply With Quote
Old 12-02-02, 07:07 PM   #2
Chalnoth
Registered User
 
Join Date: Jul 2002
Posts: 1,293
Default

So, you've turned DMA on through hdparm?
Chalnoth is offline   Reply With Quote
Old 12-02-02, 09:33 PM   #3
mas582
Registered User
 
Join Date: Dec 2002
Posts: 9
Default

Yes, through multiple means and attempts with verification that dma was indeed activated...

bash-2.05a# /usr/sbin/hdparm -i /dev/hdd

/dev/hdd:

Model=ATAPI 12X DVDROM, FwRev=VER-0.08, SerialNo=
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=yes, tPIO={min:227,w/IORDY:120}, tDMA={min:120,rec:150}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 *udma2
AdvancedPM=no

I enabled Ultra-DMA, I thought it was a spin-down problem, so I made it's spindown time 22+ minutes.

I'm concerned it may be the drive itself....but I have no reason to believe this yet.....
__________________
Slack8.1
GeForce4 Ti 4200
mas582 is offline   Reply With Quote
Old 12-02-02, 09:51 PM   #4
Chalnoth
Registered User
 
Join Date: Jul 2002
Posts: 1,293
Default

Well, an obvious way to check if it's the DVD drive, to some degree of accuracy, would be to try it in Windows. Have you done this yet?
Chalnoth is offline   Reply With Quote
Old 12-02-02, 10:02 PM   #5
mas582
Registered User
 
Join Date: Dec 2002
Posts: 9
Default

I have, but now I don't use windows at all. I'm all Linux baby!!...anyway, it may have skipped in Windows once or twice, but I can't recall to any degree of accuracy...therfore, unless I try it in someone else's machine I have no way of knowing. But if that is the only suggestion you or anyone can come up with-----OUT WITH THE DRIVE!!!! and I'll try it.. just say the word, and I'll try it...

thanks
__________________
Slack8.1
GeForce4 Ti 4200
mas582 is offline   Reply With Quote
Old 12-03-02, 01:20 AM   #6
Chalnoth
Registered User
 
Join Date: Jul 2002
Posts: 1,293
Default

I don't know, I can't think of anything else. I'm rather new to Linux myself.
Chalnoth is offline   Reply With Quote
Old 12-03-02, 08:14 AM   #7
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Which program are you using to play the DVD's?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 12-03-02, 01:18 PM   #8
mas582
Registered User
 
Join Date: Dec 2002
Posts: 9
Default

I've tried ogle, xine, and mplayer...mplayer was the only one I had trouble with additional things....it wouldn't decode, despite my attepmts to force the decoding...I used the dvdnav plugin for xine, and I remember back in the day..ok so maybe only about a year ago I was able to play them in xine using the d4d and d5d plugins...I think that's what they're called....
__________________
Slack8.1
GeForce4 Ti 4200
mas582 is offline   Reply With Quote

Old 12-04-02, 01:19 AM   #9
kappax
Registered User
 
Join Date: Oct 2002
Posts: 56
Default

Mostlikey it is the sound card drivers/running esd/arts

turn esd/arts off.

2. your sound card might not support the timeing featerus so the move and sound get out of sync so i pauses a second

3. i have found xine and mplayer to suck bad at dvd play back. So try OGLE ogle it is, Smooth play back and is made for playing dvd's only, even supports the nav stuff
kappax is offline   Reply With Quote
Old 12-04-02, 01:19 AM   #10
Chalnoth
Registered User
 
Join Date: Jul 2002
Posts: 1,293
Default

Okay, mas582, I checked, and the hdparm -i command means nothing, when it comes to which mode is used.

Try this:

hdparm -d /dev/hdd

This should tell you if it's using DMA mode. The setting shown with the -i command appears to only be the BIOS setting, not what Linux is using. You can turn DMA on with:

hdparm -d1 /dev/hdd

As a side note, for some reason, this won't work with my DVD drive (Pioneer 10x). I haven't tested why, but neither have I really attempted to play DVD's under Linux lately.
Chalnoth is offline   Reply With Quote
Old 12-04-02, 11:42 AM   #11
mas582
Registered User
 
Join Date: Dec 2002
Posts: 9
Default

Yeah, sorry I didn't know about the hdparm -i /dev/hdd

I put the hdparm stuff in my /etc/rc.d/rc.S so it would run during boot...

here's the cmd's I have:

/sbin/hdparm -c3 -d1 -m32 -X udma6 /dev/hda
/sbin/hdparm -c3 -d1 -m16 /dev/hdb
/sbin/hdparm -c3 -d1 -m16 -X udma2 /dev/hdc
/sbin/hdparm -c3 -S200 -p66 -B255 -X udma2 -K /dev/hdd

the c3 enables 32bit transfers, S200 sets the spindown time of the drive (200seconds), p66 reprograms the IDE interface chipset for the specified PIO mode (PIO66), B255 disables Power Management on the drive, X udma2 enables UltraDMA2 mode, and K keeps the settings over reset.

This can all be found in the man page for hdparm.

When I just run the cmd in a terminal it yeilds:
#hdparm -c3 -S200 -p66 -B255 -X udma2 -K1 /dev/hdd

/dev/hdd:
attempting to set PIO mode to 66
setting 32-bit IO_support flag to 3
setting drive keep features to 1 (on)
setting xfermode to 66 (UltraDMA mode2)
Segmentation fault

(that Segmentation fault worries me...perhaps we could find info about what that means...?)

(side note, I have finals coming up, I don't know how much I'll be able to reply, but I'll do my best, thanks for all the help so far guys)
__________________
Slack8.1
GeForce4 Ti 4200
mas582 is offline   Reply With Quote
Old 12-04-02, 11:46 AM   #12
mas582
Registered User
 
Join Date: Dec 2002
Posts: 9
Default

I added the -d1 flag to the cmd so it now reads:

# hdparm -c3 -d1 -S200 -p66 -B255 -X udma2 -K1 /dev/hdd

/dev/hdd:
attempting to set PIO mode to 66
setting 32-bit IO_support flag to 3
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
setting drive keep features to 1 (on)
setting xfermode to 66 (UltraDMA mode2)
Segmentation fault
__________________
Slack8.1
GeForce4 Ti 4200
mas582 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
$59.99 - RJ Tech RJ-4200 5.1 Progressive Scan Karaoke CD G DVD Player w/Mic USB SD In News Newegg Daily Deals 0 09-10-12 09:40 AM
$22.99 - MSI 24X DVD Burner Black SATA Model DH-24AS News Archived News Items 0 09-06-12 05:50 AM
When will we see DVD based games? thcdru2k Gaming Central 34 05-31-12 08:58 PM
Multi card acceleration Andrew01 NVIDIA Linux 4 11-01-02 06:01 PM
Can I use 3-D acceleration in the framebuffer coredumped NVIDIA Linux 3 08-24-02 01:20 PM

All times are GMT -5. The time now is 11:47 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.