Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-07-05, 08:28 AM   #13
scourge
Registered User
 
Join Date: Feb 2005
Posts: 28
Default Re: 6800U PCIe Issues - Summary

Quote:
Originally Posted by ZicoTheTux
Hmm i took this Version right of the Point of View (Manuf. of my Card) Section of the Page. If you find this Version (see above) for your card or a generic BIOS (in the NVIDIA FIrmaware Section) you could try one of them.
This one?
I'm gonne try this as soon as I've recompiled my Gentoo, the last crash ate my filesystem

EDIT: .00 is rev2 while .05 is rev1. Somewhat strange.
scourge is offline   Reply With Quote
Old 03-07-05, 08:39 AM   #14
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default Re: 6800U PCIe Issues - Summary

Yeah - i'm using exactly that Version. But fisrt it's from a different Manuf. and second it's made for an AGP Card. I doubt that this would work.
ZicoTheTux is offline   Reply With Quote
Old 03-07-05, 08:43 AM   #15
scourge
Registered User
 
Join Date: Feb 2005
Posts: 28
Default Re: 6800U PCIe Issues - Summary

That is the problem after all, finding a suitable PCIe BIOS...

I'm trying this now. It's the same version as mine, but its PCIe and maybe it works...

edit: PoV PCIe BIOS is 100% identical with mine(md5sum), but I'll try anyway...
scourge is offline   Reply With Quote
Old 03-07-05, 09:34 AM   #16
scourge
Registered User
 
Join Date: Feb 2005
Posts: 28
Default Re: 6800U PCIe Issues - Summary

PoV 6800U PCIe BIOS doesnt't work well (it's the same file after all). 1st run of viewperf was ok (1280x1024), 2nd run long startup time + display corruption.

dmesg says:

NVRM: Xid: 23, L1 -> L0
NVRM: Xid: 8, Channel 00000001

Gonna try Gainward 6800U GS BIOS now
scourge is offline   Reply With Quote
Old 03-07-05, 10:20 AM   #17
scourge
Registered User
 
Join Date: Feb 2005
Posts: 28
Default Re: 6800U PCIe Issues - Summary

The GS BIOS doesn't work, too. Have been able to run a viewset 5 times in a row, but once I restarted X, the next run resulted in a crash (crash and reboot to be precise).

Maybe it's a problem with X? X.org 6.8.0 here.
scourge is offline   Reply With Quote
Old 03-07-05, 11:34 AM   #18
scourge
Registered User
 
Join Date: Feb 2005
Posts: 28
Default Re: 6800U PCIe Issues - Summary

UPDATE:
------------

None of the BIOSes I tried worked.

System:

Asus A8N-SLI
Gainward PowerPack! 2600PCX (6800 Ultra PCI-e)
AMD Athlon64 2500+
Kingston HyperX RAM
Linux 2.6.11 (happened with .9/.10 as well)
X.org 6.8.2 (happened with 6.8.0 as well)

Steps to reproduce the crash:

- start X
- run a random viewperf viewset
- kill X
- restart X
- try to run a viewset

What then happens is: I get the bare frame of the window, the mouse is moveable for a while and then hangs. I was able to log in via ssh, and notices that the CPU utilization of X was very high:

Code:
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND

root      8229 89.8  0.5  31436 11800 ?        R<L  18:16   1:49 X :0 -nolisten tcp -br -deferglyphs 16
root      8285  6.2  0.1  30080  4096 pts/0    SL+  18:17   0:07 ../viewperf/viewperf -executebatch -zb
The reboots I'm having are most likely caused by the kernel hangcheck timer.

nvidia-bug-report.log is attached

Any ideas?
Attached Files
File Type: txt nvidia-bug-report.txt (67.4 KB, 134 views)
scourge is offline   Reply With Quote
Old 03-07-05, 11:41 AM   #19
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default Re: 6800U PCIe Issues - Summary

I'm out of ideas, right now.
For me this BIOS Update worked. I know how frustrating this is.
Perhaps you could TRY to update Xorg. i use 6.8.1. And as far NO ONE does exactly knows what this XID Message means it could be everything. What kernel do you use? I use 2.6.7. You could try that, too.
And as a last tip: I had a workaround for the time before the flash:
Disable any Screensaver that uses 3D/OpenGL. Use every Desktop Resolution you want, but start you games WINDOWED. i definetly know that this will work

If you want, contact me via ICQ.
ZicoTheTux is offline   Reply With Quote
Old 03-08-05, 07:09 AM   #20
scourge
Registered User
 
Join Date: Feb 2005
Posts: 28
Default [SOLVED] 6800U PCIe Issues - Summary

Problem solved
============

Edited the BIOS via NiBiTor and set 2D and 3D clocks to the same values. Not a crash/hang/display corruption/Xid for hours.
scourge is offline   Reply With Quote

Old 03-08-05, 08:18 AM   #21
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 6800U PCIe Issues - Summary

@scourge: thanks for the update; I had suspected that this might be the case (that's why I asked if starting something like `glxgears` helped, since that bumps the card into perfomance mode), but it's hard to identify the root cause remotely. I'm not sure why this wasn't a problem on Windows, but it'd be interesting to learn if the hangs continue to reproduce with the upcoming driver release.
zander is offline   Reply With Quote
Old 03-08-05, 08:42 AM   #22
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default Re: 6800U PCIe Issues - Summary

Zander, as you know i had the same Problems. I just updated the BIOS to fix it. I didn't noticed that this changed my clock rates. So i could not help scourge (sorry for that). But how fits that all into this XID Problem? As said my speeds haven't changed (as far as i see that) but now it runs fine.

scourge, glad to hear your system runs stable now. Sorry i couldn't help to solve it faster, but now i wish you happy playing!
ZicoTheTux is offline   Reply With Quote
Old 03-08-05, 08:58 AM   #23
scourge
Registered User
 
Join Date: Feb 2005
Posts: 28
Default Re: 6800U PCIe Issues - Summary

Quote:
Originally Posted by zander
@scourge: thanks for the update; I had suspected that this might be the case (that's why I asked if starting something like `glxgears` helped, since that bumps the card into perfomance mode), but it's hard to identify the root cause remotely. I'm not sure why this wasn't a problem on Windows, but it'd be interesting to learn if the hangs continue to reproduce with the upcoming driver release.
My researches showed, that the problem is apparent among Windows users as well, but most of them fix it by adjusting their 2D speeds via CoolBits. Would it be possible to implement clock rate settings in "nvidia-settings"? The only solution to my problem (which I guess affects a lot of people) was to tamper around with a BIOS-editor.

Last edited by scourge; 03-08-05 at 09:12 AM.
scourge is offline   Reply With Quote
Old 03-08-05, 09:13 AM   #24
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 6800U PCIe Issues - Summary

@ZicoTheTux: NVRM error messages prefixed with Xid are caused by and log a variety of different problems, they often just show that a severe problem has occurred, but not if it was caused by system-level hardware/software problems or if the driver was directly/indirectly responsible. In this they are similar to the respective symptoms (such as black screens, hangs, intermediate pauses and severe corruption, ...). It's possible that the root causes of yours and scourge's problem are related, but they may not be.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:05 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.