Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-11-05, 03:37 PM   #37
smthmlk.
linux.
 
Join Date: Jan 2005
Posts: 102
Default Re: 1.0-7167 for Linux x86 released

Installed 7167's just fine in fc3 with a kernel.org 2.6.11 kernel (pre-empt + 4k_stacks + 1gb -ck patch)

The fans on my BFG 6800NU OC 128MB spin down when X starts like always, no problems there.

Performance...

Code:
                       timedemo demo1, 2nd run results

					800x600@HQ	1024x768@HQ	1280x1024@HQ	1600x1200@HQ
Linux (2.6.9,nv1.0-6111,d3 1.1.1282)	57.8		57.5		51.3		43.1
Linux (2.6.9,nv1.0-6629,d3 1.1.1282)	66.0		66.0		61.9		53.4
WinXP SP2 (nv66.81,d3 1.1.1282)		72.3		71.8		65.6		55.0
Linux (2.6.11,nv1.0-7167,d3 1.1.1286)	38.3		42.3		-		32.8
Linux (2.6.11,nv1.0-7167*,d3 1.1.1286)	65.6		65.5		-		53.3
		


			timedemo demo006 (custom), 2nd run results

					800x600@HQ	1024x768@HQ	1280x1024@HQ	1600x1200@HQ
Linux (2.6.9,nv1.0-6629,d3 1.1.1282)	112.1		107.1		86.0		67.9
WinXP SP2 (nv66.81,d3 1.0.1282)		122.5		116.1		93.5		70.9
Linux (2.6.11,nv1.0-6629,d3 1.1.1286)	-		106.5		-		67.9
Linux (2.6.11,nv1.0-7167,d3 1.1.1286)	-		63.7		-		41.1
Linux (2.6.11,nv1.0-7167*,d3 1.1.1286)	-		108.0		-		68.3

* patched w/ NVIDIA_kernel-1.0-7167-1233959.diff.txt


System specs:
amd xp2500mobile @ 11x200, 2.2ghz
asus a7n8x-e deluxe
2x512mb mushkin 2.5 pc3200
sb audigy
fortron source 400w 12cm fan

Last edited by smthmlk.; 03-11-05 at 04:22 PM.
smthmlk. is offline   Reply With Quote
Old 03-11-05, 04:00 PM   #38
holmes
Registered User
 
holmes's Avatar
 
Join Date: Aug 2004
Location: El Paso, TX
Posts: 692
Default Re: 1.0-7167 for Linux x86 released

hmm.. I was hoping for better Doom3 performance but seemed to have dropped some. I run Doom3 @1280x1024 0xAA/8xAF HQ and had ~60fps in timedemo demo1 with the 6629 drivers. Currently, with the 7167 drivers I'm getting about 55fps... There also seems to be a lot more hitching playing MP as well...
__________________

The Rig
ASRock 970 Extreme3 AM3+
AMD Athlon II x2 260
DDR3-1600 (2x2GB) Kingston HyperX
Western Digital caviar 1TB
ECS GeForce GT 220 1GB
Cooler Master Storm Scout ATX case
Corsair 750W PSU
holmes is offline   Reply With Quote
Old 03-11-05, 04:08 PM   #39
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 1.0-7167 for Linux x86 released

@smthmlk.: are you using AGPGART? If so, a problem snuck into the 1.0-7167 NVIDIA Linux graphics driver release that's likely responsible for the performance drop you're seeing. Please see http://www.nvnews.net/vbulletin/showthread.php?t=47405 for information on how to resolve it.
zander is offline   Reply With Quote
Old 03-11-05, 04:12 PM   #40
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: 1.0-7167 for Linux x86 released

hmm, it seems that both power cores in ut2004 look like **********...
EDIT: ok... Thanks zander...

On the other hand, 3 fps more in doom³ ( ~70 FPS @ 1024x768, HQ, No Tweaks)...

Last edited by chunkey; 03-11-05 at 04:27 PM.
chunkey is offline   Reply With Quote
Old 03-11-05, 04:14 PM   #41
Spyke
Foxie
 
Spyke's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 618
Send a message via AIM to Spyke Send a message via MSN to Spyke Send a message via Yahoo to Spyke
Default Re: 1.0-7167 for Linux x86 released

Quote:
Originally Posted by chunkey
hmm, it seems that both power cores in ut2004 look like **********...

On the other hand, 3 fps more in doom³ ( ~70 FPS @ 1024x768, HQ, No Tweaks)...
That problem has been around forever with no fix.
__________________
Gaming:
Intel i7 980X @ 4GHz | ASUS Rampage III Extreme | GTX 480 3Way SLI @ 900Mhz | Koolance VID-NX480 | Corsair Obsidian 700D
Corsair H70 CPU Cooler | EK-FB RE3 | Corsair AX1200 | Black Ice SR1 360 | 240GB OCZ Revodrive X2 SSD | Windows 7 Ultimate
12GB Corsair Dominator GT @ 8-8-8-24-1T DDR3-1600 | Onkyo TX SR-707 | 70" Sharp Aquos LCD | KEF Audio 5.1 C3/C6LCR/C7
Workstation:
Intel i7 920 D0 @ 4GHz | ASUS Rampage II Extreme | GTX 480 @ 800Mhz | Koolance VID-NX480 | Lian-Li V1200B | Corsair HX1000
EK NB ASUS HP | Watercool HeatKiller 3.0 | Feser Extreme X-360 | 2x160GB Intel X25-M SSD RAID0 | 4x2TB WD20EARS RAID10
12GB Corsair Dominator @ 8-8-8-24-1T DDR3-1600 | Creative X-Fi Titanium | Pioneer DVR-212D | Gentoo Linux
Dell 3008WFP | JohnBlue JB3 | CityPulse DA2.03e II DAC | KingRex T20U w/ Modded Auricaps & PSU | Glow Audio Sub One
Server:
Quad Socket Opteron 8356 (16 cores) @ 2.3GHz | Supermicro H8QMi-2 | Supermicro 2U Chassis | Redundant 1200W PSU
32GB 2GBx16 DDR2-667 ECC | 4x 300GB Cheetah SAS RAID10 | Adaptec 5805 512MB w/BBU | Colocated | Gentoo Linux
Spyke is offline   Reply With Quote
Old 03-11-05, 04:20 PM   #42
smthmlk.
linux.
 
Join Date: Jan 2005
Posts: 102
Default Re: 1.0-7167 for Linux x86 released

Quote:
Originally Posted by zander
@smthmlk.: are you using AGPGART? If so, a problem snuck into the 1.0-7167 NVIDIA Linux graphics driver release that's likely responsible for the performance drop you're seeing. Please see http://www.nvnews.net/vbulletin/showthread.php?t=47405 for information on how to resolve it.
yes i saw this right after i posted my benchmarks. I have updated the post w/ new benchmarks including the patch. thanks
smthmlk. is offline   Reply With Quote
Old 03-11-05, 04:21 PM   #43
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 1.0-7167 for Linux x86 released

@chunkey: the UT2004 rendering problem is currently considered an application problem related to the value of GL_MAX_TEXTURE_UNITS reported by the NVIDIA OpenGL library; please see http://www.nvnews.net/vbulletin/show...ghlight=ut2004 and http://developer.nvidia.com/object/General_FAQ.html#t6 for more information.
zander is offline   Reply With Quote
Old 03-11-05, 04:43 PM   #44
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: 1.0-7167 for Linux x86 released

I haven't got any Xid since I am using 7167 driver - if it remains stable for at least 3 days, I'll remove my protesting signature .

My OpenGL performance is still the same (only 30FPS, but I have a slow CPU: 2.4 GHz only and I am running AGP 4x only <- my MoBo's limit).

I haven't noticed any problems with overheating/cooling.
LubosD is offline   Reply With Quote

Old 03-11-05, 04:55 PM   #45
erek
 
erek's Avatar
 
Join Date: Jan 2004
Location: USA
Posts: 220
Send a message via ICQ to erek Send a message via AIM to erek
Default Re: 1.0-7167 for Linux x86 released

Quote:
Originally Posted by holmes
hmm.. I was hoping for better Doom3 performance but seemed to have dropped some. I run Doom3 @1280x1024 0xAA/8xAF HQ and had ~60fps in timedemo demo1 with the 6629 drivers. Currently, with the 7167 drivers I'm getting about 55fps... There also seems to be a lot more hitching playing MP as well...

yeah us guys using the Internal AGPGART seem to be losing performance :-\
__________________
[b]Linux localhost 2.6.11 #3 Sat Mar 19 14:50:03 EST 2005 i686 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux[/b][center]
[color=blue]EPoX 9NDA3+ Socket 939 nForce 3 Ultra[/color][b] * [/b][color=blue]2x 512MB Mushkin Dual Basic PC3200 (@ CAS 2.0-3-3-6 1T)[/color][b] * [/b][color=blue]"BFG" GeForce 6800 GT "OC" (@OEM 370/1000)[/color][b] * [/b][color=blue]LSI Logic Ultra 160 SCSI-3 Single Channel 64-Bit Controller[/color][b] * [/b][color=blue]Creative Labs Soundblaster Audigy[/color][b] * [/b][color=blue]Intel Pro 100 S Desktop adapter[/color][b] * [/b][color=blue]Seagate Cheetah 15k.3 18GiB 15K RPM Ultra 320[/color][b] * [/b][color=blue]Seagate Cheetah X15 36LP 18GiB 15K RPM Ultra 160[/color][b] * [/b][color=blue]Samsung Spinpoint 40GiB 5400 RPM ATA100[/color][b] * [/b][color=blue]Samsung 48X ATA33 CD-ROM.[/color][/center][indent]
[b]Kernel[/b]: Vanilla [url="http://frozenarctic.com/erek/SERENA.txt"][u]2.6.11[/u][/url].
[b]Settings[/b]: 4kB stacks, regparm, pre-emptive, deadline i/o scheduler, fast writes on, sideband addressing on.
[b]Video/Sound drivers[/b]: NVIDIA x86-1.0-7174 / ALSA 1.0.9_rc3[/indent]
erek is offline   Reply With Quote
Old 03-11-05, 05:46 PM   #46
xrotanimret
gar gar gar
 
Join Date: Oct 2004
Posts: 62
Default Re: 1.0-7167 for Linux x86 released

Bah, these drivers completely broke the COMPOSITE extension for me. I fired up xcompmgr under GNOME 2.10 and X locks instantly when I hit alt+tab.
xrotanimret is offline   Reply With Quote
Old 03-11-05, 06:06 PM   #47
kmare
Registered User
 
Join Date: Jul 2003
Location: greece
Posts: 180
Send a message via ICQ to kmare
Default Re: 1.0-7167 for Linux x86 released

for me those are the only drivers that do not lock up X with composite enabled and xcompmgr... welll X crashes as soon as I run an opengl app, but that's mostly a prob with X and the glx protocol...
kmare is offline   Reply With Quote
Old 03-11-05, 06:06 PM   #48
bradtem
Registered User
 
Join Date: Nov 2004
Posts: 18
Default Re: 1.0-7167 for Linux x86 released

Does this fix the most-complained about bug with HDTV users, the inability to do DVI at 1080i on the old drivers? Does the advanced DVI timings offer the possiblity of a fix if it is not fixed directly?
bradtem is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:24 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.