Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-12-05, 11:23 AM   #85
fallow
Registered User
 
Join Date: Mar 2005
Posts: 1
Default Re: 1.0-7167 for Linux x86 released

hello .

I have problem with composite support and nvidia drivers 7167.
I`m a XFCE4.2 user (XFWM4 cvs with composite wm support ) .
With enlightenment and composite the same situation.
The driver freezes when I moving some windows (for ex.mozilla and xfterm4)
With nvidia 6629 driver everything was been ok

I have GeForce 2 GTS card , VIA KT133 , using NVAGP
Code:
Status:          Enabled
Driver:          NVIDIA
AGP Rate:        4x
Fast Writes:     Enabled
SBA:             Enabled
somebody have the same problem ?
fallow is offline   Reply With Quote
Old 03-12-05, 11:49 AM   #86
KillerGod2000
Registered User
 
Join Date: Mar 2004
Posts: 3
Default Re: 1.0-7167 for Linux x86 released

Quote:
Originally Posted by LubosD
I use NVidia's AGP driver
I would, too but it doesn't work
KillerGod2000 is offline   Reply With Quote
Old 03-12-05, 12:03 PM   #87
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: 1.0-7167 for Linux x86 released

Quote:
Originally Posted by markroth8
Kudos to NVIDIA!

My FC3 2.6.10-1.770_FC3smp system used to freeze / spontaneously reboot about 1/3 of the time with the 6629 driver. I upgraded to 7167 and so far it hasn't happened once! Not only that, but UT2004 seems to run with less lag, especially at the start of the level.

Nice job guys!
- Mark
Oh yeah, it is much better, guys from nvidia have done a good job. But it isn't 100%, I had a Xid few monents ago (after a few hours of playing).
LubosD is offline   Reply With Quote
Old 03-12-05, 02:03 PM   #88
kristian
Registered User
 
kristian's Avatar
 
Join Date: Mar 2005
Posts: 17
Default Re: 1.0-7167 for Linux x86 released

Problems with both 6629 and the new 7167 drivers.
On my laptop I can't get it to use the whole widescreen, its around 10cm of black at the right side of the screen also there is a little 2cm border at the bottom with scrampled data.

Anyone that has a qlue on what to do?

The laptop is a HP Compaq nx9105.
Kernel: 2.6.11
Distro: Ubuntu (Hoary)
Attached Thumbnails
Click image for larger version

Name:	Bild026.jpg
Views:	348
Size:	45.6 KB
ID:	10817  
kristian is offline   Reply With Quote
Old 03-12-05, 03:17 PM   #89
mfred
Registered User
 
mfred's Avatar
 
Join Date: Nov 2002
Posts: 15
Default Re: 1.0-7167 for Linux x86 released

Quote:
Originally Posted by Paulus
I have the exact same problem.... it cant find the kernel source, and when it's installed it doenst like it, source doent match kernel was the jist of the error, do we have to wait for the debian packages to install or is there a workaround?
Quote:
Originally Posted by Hammett
Exact same problem here. Installer says it cannot find kernel source. putting --kernel-source-path to the installer does not help either.
Any solution?
Sign in for this

While 6629 does find kernel sources (which are as usual on /usr/src/linux/ )
7167 doesent. I also tried with --kernel-source-path /usr/src/linux/ to no sucess.

cat /proc/version
Linux version 2.6.8.1-24mdk

ll /usr/src/
lrwxrwxrwx 1 root root 19 Feb 27 18:49 linux -> linux-2.6.8.1-24mdk/
drwxr-xr-x 21 root root 4096 Mär 6 16:32 linux-2.6.8.1-24mdk/

So source does match kernel exactly. It must be a driverprob as older nvidia packages are still working to install.

Attached is nvidia-installer.log
maybe of interest for analysis
Attached Files
File Type: txt nvidia-installer_log.txt (12.7 KB, 200 views)
__________________
--
rgds
mfred

Using: Leadtek WinFast PX6800 TDH PCIe
mfred is offline   Reply With Quote
Old 03-12-05, 03:24 PM   #90
seandarcy
Registered User
 
Join Date: Jan 2005
Posts: 8
Default Re: 1.0-7167 for Linux x86 released

Trying to install 7167 with the cumulative patch on 2.6.11-bk4. Ran nvidia-installer without any command line options.

uname -r
2.6.11-bk4-kraxel1


nvidia-installer.log:

-> Kernel source path: '/lib/modules/2.6.11-bk4-kraxel1/source'
-> Performing CC test with CC="cc".
ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the appropriate nvidia-installer command line option.
.........................

ls /lib/modules/2.6.11-bk4-kraxel1/source
arch CREDITS Documentation fs init kernel MAINTAINERS mm README scripts sound
COPYING crypto drivers include ipc lib Makefile net REPORTING-BUGS security

6629 - patched - built on this kernel.

Any suggestions?

sean
seandarcy is offline   Reply With Quote
Old 03-12-05, 03:54 PM   #91
Alphohsu Pugh
Registered User
 
Join Date: Nov 2004
Posts: 7
Default Re: 1.0-7167 for Linux x86 released

Zander,

--- Previous (Mar. 11):
<< Linux-GNU 2.6.10 on Intel P4 3.06GHz, TNT2 M64 32M, XFree86 4.4

7167 compiles without any problems BUT when I try to bring up XFree86:

FATAL: Module nvidia already in kernel.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting *** >>

--- Zander:
Quote:
please upgrade your module-init-tools
You were right on the mark!
I changed my mit from 0.9.14 (Sep. 11, 2003) to 3.1 (Nov. 14, 2004)
(“What a Difference A Year Makes”, and “24 little hours” of upgrade).

Everything works perfectly now INCLUDING the SMP and HyperThreading.
I still cannot believe!

Many thanks to you and NVIDIA for an outstanding job.
Alphohsu Pugh is offline   Reply With Quote
Old 03-12-05, 04:04 PM   #92
Kim
Registered User
 
Join Date: Dec 2004
Posts: 3
Red face Re: 1.0-7167 for Linux x86 released

Finally RandR support.

Unfortunately it freezes my otherwise rock-stable machine if I exit the KDE session to go to KDM, or if I use Fvwm2 as a windowmanager.

It works for a while if I boot straight to KDE, but eventually it will crash.

I can't use it yet, but at least there's hope for the future.
Kim is offline   Reply With Quote

Old 03-12-05, 04:21 PM   #93
legalos
Leadtek 6800 / PNY 6600GT
 
Join Date: Jan 2005
Location: Tucson, AZ
Posts: 2
Send a message via AIM to legalos
Cool Re: 1.0-7167 for Linux x86 released

and yes I am running 7167

I switched out PSU.

I ran with bare minimal harware. It ran ut2003 for 2.5hrs straight.
I shutdown, added in my sound card card and within 10minutes. hardlock.

/var/log/messages:
Code:
Mar 12 02:41:31 jedi NVRM: Xid: 23,  L1 -> L0
Mar 12 02:41:31 jedi NVRM: Xid: 6, PE0002 180c 03be03af 002ec900 00000000 00100000
Mar 12 13:53:44 jedi NVRM: Xid: 23,  L1 -> L0
Mar 12 13:53:44 jedi NVRM: Xid: 6, PE0002 180c 0519052b 002bdb0c c4c98300 00000000
Mar 12 13:54:54 jedi NVRM: Xid: 23,  L1 -> L0
Mar 12 13:54:54 jedi NVRM: Xid: 8, Channel 00000020
Mar 12 13:54:54 jedi NVRM: Xid: 16, Head 00000000 Count 0002321d
Mar 12 13:54:54 jedi NVRM: Xid: 16, Head 00000001 Count 0002321b
Mar 12 13:55:52 jedi NVRM: Xid: 23,  L1 -> L0
Mar 12 13:55:52 jedi NVRM: Xid: 8, Channel 00000020
Mar 12 13:55:52 jedi NVRM: Xid: 16, Head 00000000 Count 0002321e
Mar 12 13:55:52 jedi NVRM: Xid: 16, Head 00000001 Count 0002321c
Mar 12 13:56:26 jedi NVRM: Xid: 23,  L1 -> L0
Mar 12 13:56:26 jedi NVRM: Xid: 8, Channel 00000020
Mar 12 13:56:26 jedi NVRM: Xid: 16, Head 00000000 Count 0002321f
Mar 12 13:56:26 jedi NVRM: Xid: 16, Head 00000001 Count 0002321d
Quote:
Originally Posted by legalos
@zander

I have tried 2 different brand 6600GTs. PNY and XFX. Both have dual DVI outputs.

After playing something 3d, but it could happen in 2d (takes a much longer time), both my screens go blank.

Screens display "No signal, check cable"
Machine in hardlocked. Cannot ssh into it, etc.

in /var/log/messages I get msgs like this:
Code:
Mar 11 19:52:53 jedi NVRM: Xid: 23,  L1 -> L0
Mar 11 19:52:53 jedi NVRM: Xid: 6, PE0002 180c 02c402c5 0030fb80 bf0e380c 00000005
Mar 11 19:53:50 jedi NVRM: Xid: 23,  L1 -> L0
Mar 11 19:53:50 jedi NVRM: Xid: 8, Channel 00000020
Mar 11 19:54:25 jedi NVRM: Xid: 23,  L1 -> L0
Mar 11 19:54:25 jedi NVRM: Xid: 8, Channel 00000020
Mar 11 19:55:06 jedi NVRM: Xid: 23,  L1 -> L0
Mar 11 19:55:06 jedi NVRM: Xid: 8, Channel 00000020
Mar 11 19:55:43 jedi NVRM: Xid: 23,  L1 -> L0
Mar 11 19:55:43 jedi NVRM: Xid: 8, Channel 00000020
Mar 11 19:56:20 jedi NVRM: Xid: 23,  L1 -> L0
Mar 11 19:56:20 jedi NVRM: Xid: 8, Channel 00000020
Mar 11 19:56:58 jedi NVRM: Xid: 23,  L1 -> L0
Mar 11 19:56:58 jedi NVRM: Xid: 8, Channel 00000020
Mar 11 19:57:31 jedi NVRM: Xid: 23,  L1 -> L0
Mar 11 19:57:31 jedi NVRM: Xid: 8, Channel 00000020
Mar 12 02:41:31 jedi NVRM: Xid: 23,  L1 -> L0
Mar 12 02:41:31 jedi NVRM: Xid: 6, PE0002 180c 03be03af 002ec900 00000000 00100000
I tried 6629 & 7167, 6600GT is supported in only those 2 versions.

I went as far as measuring my power usage with a multimeter, disconnecting all unnecessary devices and I still get the error, thinking maybe it was power related. My motherboard specs claim it has all the supporting features.

Giga-Byte: GA-7DPXDW-P motherboard

450watt PSU
dual amd 2800+
1xPNY 6600GT AGP
2xSATA WD raptor drives
2xATA/133 maxtor drives
1xSony DVD+/-RW
1xPCI/66 intel gigabit ethernet
1xPCI/66 promise SATA
1xPCI sound blaster audigy
1xPCI via usb2 card
1xPCI hauppauge tv tuner

My calculations were: 121.0 volts from wall socket * ~3.0 amps under load == 363watts, 121.0 * ~2.6 amps idle == 320watts

In the readme, there is another Gigabyte board listed with AGP problems. Not sure if mine is the same...

On a side note, I have been running with a Leadtek 6800 since august 13, 2004 with not one lockup. I wanted to switch for the dual DVI, as I now have 2 LCD displays...

According the multimeter reading, the 6800 and 6600 seem to draw about the same amount of power both idle and under load, within a few watts.

What I basically would like from someone like zander, is their thoughts whether it is hardware or software (driver) related, so I know whether or not to keep the card.

I have also tried an updated BIOS from http://www.mvktech.net, but with the updated BIOS, only one DVI port works, so i had to go back to the factory BIOS.

thanks so much. you time is appreciated.

cheers,
joe
legalos is offline   Reply With Quote
Old 03-12-05, 05:10 PM   #94
cowchaser
Registered User
 
Join Date: Nov 2002
Location: Eastern Shore of Virgina
Posts: 9
Send a message via AIM to cowchaser
Default Re: 1.0-7167 for Linux x86 released

Seems to install and work great on with my old TNT2 card and FC3 with 2.6.10 Kernel.
Much faster frame rates than with the 6111 driver I was forced to use.
Thanks Nvidia
__________________
Roger Skildum
cowchaser is offline   Reply With Quote
Old 03-12-05, 05:35 PM   #95
nbecker
Registered User
 
Join Date: Feb 2004
Posts: 13
Default Major dissapointment!

I've really been looking forward to the black death issue on
nVidia Corporation NV17 [GeForce4 440 Go 64M] (rev a3)
being fixed by the long-awaited driver update. What a dissapointment!

This is a compaq presario r3000z amd_64. I had no problem with 6111, but this driver won't work with kernels >2.6.9.

I am running Fedora3. Starting X with nvidia driver 6629 or 7167 results in a black screen. I can switch VTs, it's not dead. No useful error messages in any log file. Tried disabling AGP, no difference.

Please do something about this! The standard xorg driver isn't really usable either. I have xorg-x11-6.8.1-12.FC3.21. It works in graphics mode, but can't be switched back to text - result is a scambled screen.

If you can't figure out how to make 7167 work on 440 chip, can you please make 6111 compile on newer kernels?
nbecker is offline   Reply With Quote
Old 03-12-05, 06:19 PM   #96
cowchaser
Registered User
 
Join Date: Nov 2002
Location: Eastern Shore of Virgina
Posts: 9
Send a message via AIM to cowchaser
Default Re: Major dissapointment!

In order to compile the 6111 driver on the newer kernels you need to patch the driver. There are instructions on this forum or if you can find it the patched driver is available on the web. If you can't find it I still haver a copy of it.
__________________
Roger Skildum
cowchaser is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:49 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.