Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-15-05, 05:01 AM   #1
gdh
Registered User
 
Join Date: Oct 2003
Posts: 33
Question 7167 and composite and glx issues

OK, so Im playing around with the new 7167 driver (works fine sofar, installed without a hitch) and decided to give the composite extensions a try.

Which works extremely smooth in combination with KDE 3.4

Then I also enabled glx ( I need glx to do my work).
After that composite stioll worked perfectly, until the moment I started a GLX application (any glx application, wether glxgear of one of our own) . When I start a GLX app, the Xserver immediately crashes.

Now I know that glx + composite is not yet supported, so Im not complaining, but I am wondering

Has anyone managed to get this working succesfully (this being GLx + composite) ?

Suse 9.2, amd64, kde3.4
gdh is offline   Reply With Quote
Old 03-16-05, 04:35 AM   #2
sydrog
i documenti..svelti
 
sydrog's Avatar
 
Join Date: Mar 2005
Posts: 6
Default Re: 7167 and composite and glx issues

In the README of the driver I read

Option "AllowGLXWithComposite" "boolean"
Enables GLX even when the Composite X extension is loaded.
ENABLE AT YOUR OWN RISK. OpenGL applications will not
display correctly in many circumstances with this setting
enabled. Default: GLX is disabled when Composite is
loaded.

but on my workstation is broken ;-(
__________________
slackware_current
k_2.6.12-rc1 & nvidia 1.0-7167
GeForce4_MX_4000
sydrog is offline   Reply With Quote
Old 03-16-05, 04:41 AM   #3
gdh
Registered User
 
Join Date: Oct 2003
Posts: 33
Default Re: 7167 and composite and glx issues

What do you mean with broken ?
gdh is offline   Reply With Quote
Old 03-16-05, 08:03 AM   #4
sydrog
i documenti..svelti
 
sydrog's Avatar
 
Join Date: Mar 2005
Posts: 6
Default Re: 7167 and composite and glx issues

Quote:
Originally Posted by gdh
What do you mean with broken ?
Ok.. sorry for my bad english.
broken = extension of composite _or_ extension of glx
composite _and_ glx = Xserver crashes (and I must reboot)

but I've done a new test and the situation now is good (no perfect..
only good).
Follow me..:

- in xorg.conf I have
Load "glx"
Option "Composite" "Enable"
Option "AllowGLXWithComposite" "True"
Option "RenderAccel" "True"

- my Xclient is Xfce4 and I have build xfwm4 (window manager) with
--enable-composite

now I'm using composite _and_ glx and works fine; I've played with ut2003 and all seems ok.

I've only two inconvenients:
1) in _window preference manager_ I've unmarked "display content of windows when resizing/moving". If this two boxes are marked my Xserver crashes.
2) with mplayer I cannot use xv with switch -vo; I can use x11 and, if I want fullsreen mode, gl or gl2
__________________
slackware_current
k_2.6.12-rc1 & nvidia 1.0-7167
GeForce4_MX_4000
sydrog is offline   Reply With Quote
Old 04-28-05, 01:47 PM   #5
tsuraan
Registered User
 
Join Date: Nov 2003
Posts: 4
Default Re: 7167 and composite and glx issues

Could you post your full xorg.conf? I'm sure that I had glx and composite working at some point, but now whenever I try to run any OpenGL application, X crashes. I am using KDE's window transparency and shadows, so perhaps glx doesn't like doing OpenGL and transparency. Anyhow, can you post your full config file?
tsuraan is offline   Reply With Quote
Old 04-28-05, 05:22 PM   #6
poca
Registered User
 
Join Date: Apr 2005
Posts: 25
Default Re: 7167 and composite and glx issues

I use 7174 drivers with xorg 6.8.2 + composite + glx.

It works fine under kde with xcompmgr and kompmgr (KDE 3.4), I can start glxgears withouts problems (but the window is, of course, not transparent)
I can run Diablo2 with wine, but I have very BIG graphical bug.
When I launche doom3-demo, xserver crashes.

with composite managers disabled, all work fine

System : debian sid + kernel 2.6.7 + abit kt7a raid + athlon xp + GF FX 5700

Last edited by poca; 04-29-05 at 06:23 AM.
poca is offline   Reply With Quote
Old 04-28-05, 08:40 PM   #7
Ironi
Registered User
 
Join Date: Dec 2004
Posts: 86
Default Re: 7167 and composite and glx issues

Using composite with glx enabled is "at your own risk," therefore it may not work properly. If you really want both enabled, then try to make sure that a composite manager isn't running when you start a 3D app.
Ironi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:35 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.