Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-16-05, 12:00 PM   #1
fishy-mun
Registered User
 
Join Date: Mar 2005
Posts: 7
Default 6800 PAM issues

Hi all,
I just bought and installed the 6800 card. Using the nvidia linux driver everything seems to work fine. However as soon as a reboot I get the following when I try to run say glxgears:

Error: Could not open /dev/nvidiactl because the permissions
are too resticitive. Please see the FREQUENTLY ASKED QUESTIONS
section of /usr/share/doc/NVIDIA_GLX-1.0/README for steps
to correct.

Referencing this doc I carried out the steps changing the file and chmod/chown the /dev/nvidia*. It all works however the next time I reboot I have to change the permissions all over again.

The doc also suggests it is the PAM security system which changes the permissions back again and that I should disable the service.

I am running on FC3.

Has anybody any ideas how to do this? or have the same issue?

Thanks.
fishy-mun is offline   Reply With Quote
Old 03-16-05, 12:23 PM   #2
erek
 
erek's Avatar
 
Join Date: Jan 2004
Location: USA
Posts: 220
Send a message via ICQ to erek Send a message via AIM to erek
Default Re: 6800 PAM issues

try upgrading PAM
__________________
[b]Linux localhost 2.6.11 #3 Sat Mar 19 14:50:03 EST 2005 i686 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux[/b][center]
[color=blue]EPoX 9NDA3+ Socket 939 nForce 3 Ultra[/color][b] * [/b][color=blue]2x 512MB Mushkin Dual Basic PC3200 (@ CAS 2.0-3-3-6 1T)[/color][b] * [/b][color=blue]"BFG" GeForce 6800 GT "OC" (@OEM 370/1000)[/color][b] * [/b][color=blue]LSI Logic Ultra 160 SCSI-3 Single Channel 64-Bit Controller[/color][b] * [/b][color=blue]Creative Labs Soundblaster Audigy[/color][b] * [/b][color=blue]Intel Pro 100 S Desktop adapter[/color][b] * [/b][color=blue]Seagate Cheetah 15k.3 18GiB 15K RPM Ultra 320[/color][b] * [/b][color=blue]Seagate Cheetah X15 36LP 18GiB 15K RPM Ultra 160[/color][b] * [/b][color=blue]Samsung Spinpoint 40GiB 5400 RPM ATA100[/color][b] * [/b][color=blue]Samsung 48X ATA33 CD-ROM.[/color][/center][indent]
[b]Kernel[/b]: Vanilla [url="http://frozenarctic.com/erek/SERENA.txt"][u]2.6.11[/u][/url].
[b]Settings[/b]: 4kB stacks, regparm, pre-emptive, deadline i/o scheduler, fast writes on, sideband addressing on.
[b]Video/Sound drivers[/b]: NVIDIA x86-1.0-7174 / ALSA 1.0.9_rc3[/indent]
erek is offline   Reply With Quote
Old 03-16-05, 01:44 PM   #3
fishy-mun
Registered User
 
Join Date: Mar 2005
Posts: 7
Default Re: 6800 PAM issues

I had the newest PAM version.

Solution:

Create a file named 10-udev.permissions under /etc/udev/permissions.d/
This file should have a single line:
nvidia*:root:root:0666

Save it and from the command line as root:
chown root.root /dev/nvidia*
chmod 0666 /dev/nvidia*

Reboot.
fishy-mun is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blizzard Address Diablo III Issues With 'Emergency' Fix News Archived News Items 0 05-16-12 01:40 AM
Strange RedHat 7.3 issues with A7N266-C nforceuser NVIDIA Linux 8 09-27-02 03:16 PM
Overclocking issues... mcortz_2000 CPUs, Motherboards And Memory 5 09-16-02 03:41 PM
Is there a Microsoft patch for the refresh rate issues yet? Zarich NVIDIA GeForce 7, 8, And 9 Series 22 08-24-02 01:02 PM

All times are GMT -5. The time now is 11:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.