Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-16-05, 01:41 PM   #1
Dirtyharry1971
Registered User
 
Join Date: Mar 2005
Posts: 2
Default Sound Problem - Nforce - Doom 3

OK heres a strange one
I have a problem with getting sound to work in Doom3
I am using the latest Nforce drivers with asus 8x-x
NFORCE-Linux-x86-1.0-0301-pkg1.run
Sound works ok in all the native linux games and within linux itself
I am running Redhat 7.3 (I know its old) kernel-2.4.18-3

Doom 3 runs fine in fact it runs very fast too but no sound
if I open the console I can see the error....

Failed to open sound device /dev/dsp: Cannot allocate memory
Sound subsystem Disabled

Can anyone help?
Ps I used the proper linux installer for doom 3 not using any wrappers or any sh*t like that
Dirtyharry1971 is offline   Reply With Quote
Old 03-16-05, 03:54 PM   #2
lightsout
Registered User
 
Join Date: Mar 2005
Posts: 28
Default Re: Sound Problem - Nforce - Doom 3

Do something like this:

Quote:
d3: aliased to /usr/games/bin/doom3 +set s_driver oss
That +set command alters which sound output system doom 3 will use. As the nvidia drivers are oss only, you have to use it.
lightsout is offline   Reply With Quote
Old 03-17-05, 07:06 AM   #3
espinafre
Registered User
 
Join Date: Dec 2004
Posts: 2
Default Re: Sound Problem - Nforce - Doom 3

Slightly unrelated, is the Linux nForce sound driver compatible with 5.1, as the windows version is?
espinafre is offline   Reply With Quote
Old 03-19-05, 05:01 PM   #4
Dirtyharry1971
Registered User
 
Join Date: Mar 2005
Posts: 2
Wink Re: Sound Problem - Nforce - Doom 3

Ok lightsout I'll try that command although I think I sorted out the original issue.
It was the sound server in kde that was not allowing doom3 access to the device. Once I disabled it I got a different error.
The new problem is caused by the default frequency the sound runs at 48000KHz

In doom3 the sound engine will only output 44.1KHz
The sound is disabled as it detects it to be running at 48000 khz
"SNDCTL_DSP_SPEED failed to get the requested frequency 44100, got 48000"
I cannot lower this as I am unable to open the audio control panel (nvmixer) as it requires the Qt 3.1 libraries and redhat 7.3 uses qt 3.0

I have searched everywhere but cannot find a download location for qt3.1. I'm new enough to linux (using it about 2 weeks) so am probably missing something really simple. Can anyone give me some advise.
Dirtyharry1971 is offline   Reply With Quote
Old 03-20-05, 05:32 AM   #5
lightsout
Registered User
 
Join Date: Mar 2005
Posts: 28
Default Re: Sound Problem - Nforce - Doom 3

Yes, the Nvidia driver does seem to support 5.1 like Windows. nvmixer shows it nicely.

QT is produced by trolltech, there is a GPL version available for X11 platforms. Should be on their website. Although, using Redhat 7.3 is a total dead-end as it is beyond support. Try Fedora, Mandrake or SuSE. Grab the latest version, they'll have most stuff there by default.

I use Gentoo... it rocks!
lightsout is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remastered Doom 3 BFG Edition Game Coming with Stereo 3D Support News Archived News Items 0 06-01-12 05:30 AM
Doom 3 BFG Edition will feature entire Doom series, seven new Doom 3 levels News Archived News Items 0 05-31-12 05:40 AM
Official nForce 2 Thread Matthyahuw CPUs, Motherboards And Memory 148 04-16-03 04:39 AM
nForce sound locking up system shroom NVIDIA Linux 4 09-16-02 01:50 AM
nForce - BattleField 1942 demo - Sound cuts out rtz General Hardware 3 09-05-02 12:48 PM

All times are GMT -5. The time now is 02:46 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.