Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-21-05, 12:00 PM   #1
wilbur.harvey
Registered User
 
Join Date: Jun 2004
Posts: 6
Default FC3 NForce4 GA-K8N No USB No second GigE

Does anyone know how to get the USB ports or the second (Marvell) GigE port working?
Nforce4 chipset, Gigabyte GA-K8N Ultra-9 MB
I have an Nvidia based Gigabyte PLX5300 graphics card and I was able to install the drivers for it without any problems. I also tried to install the NFORCE-Linux-x86-1.0-0301 drivers but it didn't seem to help.
wilbur.harvey is offline   Reply With Quote
Old 03-21-05, 12:45 PM   #2
Lauwenmark78
Registered User
 
Join Date: Mar 2005
Posts: 33
Default Re: FC3 NForce4 GA-K8N No USB No second GigE

The GA-K8N uses a 8053 Marvell Gigabit Ethernet controller. You can use the 8053 driver supplied by Asus if you want to get it working (for example here).

The NForce4 USB subsystem is an USB2-EHCI compatible one. The EHCI HCD driver of the standard Linux kernel should be able to manage it. Notice that the 2.6.10 kernel introduced a workaround for another USB chipset that conflicted with some NForce4 revisions, so if you don't manage to properly detect any USB peripheral connected, try with a 2.6.11 instead.

Hope this helps !
Lauwenmark78 is offline   Reply With Quote
Old 03-21-05, 12:49 PM   #3
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: FC3 NForce4 GA-K8N No USB No second GigE

Quote:
Originally Posted by wilbur.harvey
Does anyone know how to get the USB ports
Probably temporary workaround: Go into your BIOS and look for something like USB Version (should be something like 2.0 + 1.1, or only 2.0) ... change it to 1.1

If this solves your problem, but you can't stay with 12MBits/s... then you should upgrade to the lastest 2.6.11 kernels...

...
chunkey is offline   Reply With Quote
Old 03-23-05, 12:45 PM   #4
wilbur.harvey
Registered User
 
Join Date: Jun 2004
Posts: 6
Default Re: FC3 NForce4 GA-K8N No USB No second GigE

I tried the trick with the USB 1.1 and it didn't work.
I compiled a new 2.6.11-5 kernel and the USB now works.
I still can't see the Marvell network. The driver module is there, but the chip doesn't seem to be detected.
Doing an LSPCI shows the chip however.
wilbur.harvey is offline   Reply With Quote
Old 03-23-05, 04:42 PM   #5
Lauwenmark78
Registered User
 
Join Date: Mar 2005
Posts: 33
Default Re: FC3 NForce4 GA-K8N No USB No second GigE

Quote:
Originally Posted by wilbur.harvey
I still can't see the Marvell network. The driver module is there, but the chip doesn't seem to be detected.
Doing an LSPCI shows the chip however.
With which driver ? Asus's one ? Any dmesg output when loading the module ?
Lauwenmark78 is offline   Reply With Quote
Old 03-24-05, 11:31 AM   #6
wilbur.harvey
Registered User
 
Join Date: Jun 2004
Posts: 6
Default Re: FC3 NForce4 GA-K8N No USB No second GigE

The driver which appears to be in the kernel
/lib/modules/2.6.11.5/kernel/drivers/net/sk98lin/sk98lin.ko

I don't find any reference to the marvell chip at all in dmesg

Here is my lspci listing

00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation: Unknown device 0050 (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev a2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:00.0 Ethernet controller: Marvell Technology Group Ltd. Marvell Yukon 88E8053 Gigabit Ethernet 10/100/1000Base-T Adapter (rev 19)
05:00.0 VGA compatible controller: nVidia Corporation NV37GL [Quadro FX 330/GeForce PCX 5300] (rev a2)

After doing a modprobe sk98lin, here is the output of lsmod

Module Size Used by
nfsd 216064 9
exportfs 8640 1 nfsd
lockd 65704 2 nfsd
parport_pc 27780 0
lp 11016 0
parport 41032 2 parport_pc,lp
autofs4 25732 0
i2c_dev 10688 0
i2c_core 21952 1 i2c_dev
sunrpc 167748 19 nfsd,lockd
dm_mod 58388 0
video 13828 0
button 5136 0
battery 7684 0
ac 3588 0
nvidia 3925436 12
md5 4032 1
ipv6 267776 16
ohci_hcd 24712 0
ehci_hcd 35272 0
snd_intel8x0 33024 2
snd_ac97_codec 74040 1 snd_intel8x0
snd_pcm_oss 53344 0
snd_mixer_oss 18880 2 snd_pcm_oss
snd_pcm 108616 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 33988 1 snd_pcm
snd 56612 8 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_ oss,snd_pcm,snd_timer
soundcore 10592 2 snd
snd_page_alloc 8516 2 snd_intel8x0,snd_pcm
sk98lin 174560 0
forcedeth 21824 0
ext3 127944 3
jbd 90072 1 ext3
raid0 6912 1
sata_nv 8004 6
libata 46404 1 sata_nv
sd_mod 17600 8
scsi_mod 138056 2 libata,sd_mod

But no, still no messages in dmesg
wilbur.harvey is offline   Reply With Quote
Old 03-25-05, 02:01 AM   #7
Lauwenmark78
Registered User
 
Join Date: Mar 2005
Posts: 33
Default Re: FC3 NForce4 GA-K8N No USB No second GigE

Again, I suggest you to try the drivers supplied by Asus (see above for the URL). Although they're also the sk98lin stuff, they seem to be more recent: the version included in the 2.6.11 kernel is 6.23, while those supplied by Asus are 7.06.
Lauwenmark78 is offline   Reply With Quote
Old 03-26-05, 02:37 AM   #8
wilbur.harvey
Registered User
 
Join Date: Jun 2004
Posts: 6
Default Re: FC3 NForce4 GA-K8N No USB No second GigE

I was finally able to install the ASUS drivers and the second ethernet now works. Thank you very much.
wilbur.harvey is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:50 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.