Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-23-05, 07:15 AM   #1
sinate
Registered User
 
Join Date: Mar 2005
Posts: 3
Unhappy Rebooting on startx (2.6.11.5 and 7167 nvidia)

I got the Nvidia drivers 7167 working fine with a freash install of SuSE 9.2 running a 2.6.8 kernel. I then wanted to install the latest kernel (2.6.11.5). The Nvidia driver module compiles and loads fine. However, when I come to issue the startx command the machine either reboots itself or I'm left with a black screen with a white "_" in the top left hand corner. I then can't back to any console to see any errors and have to reboot the machine with the reboot button. After the event, the X.org logs show no errors.

When I configured the 2.6.11.5 kernel I did a make oldconfig with the config file SuSE 9.2 came with for 2.6.8.

I've tried the latest patches for 7167 and get the same result.

Maybe someone can suggest something else to try.

Cheers,

Steve.
sinate is offline   Reply With Quote
Old 03-23-05, 09:11 AM   #2
Rob Zondag
RoZo
 
Join Date: Jan 2003
Posts: 12
Default Re: Rebooting on startx (2.6.11.5 and 7167 nvidia)

Just installed NVIDIA 7167 fine on my Dell M60 (Go1000) laptop using SuSE9.2 kernel 2.6.8-24.11-default. I didn't use YOU but followed steps 2a and 3 of the SuSE readme section 3. "SuSE Linux 9.2-IA32" (I prefer compiling ...).
But I did have my problems with the NVIDIA driver for which some tweaking was needed in order to get thing to work.
Please check my (an others) posting on SuSE 9.2 and NVIDIA driver 6629 ... especially about the X11 update and steps to perform with kernel-sources ... it looks like you need those ...

Hope this is helpful ...
Rob Zondag is offline   Reply With Quote
Old 03-23-05, 09:37 AM   #3
sinate
Registered User
 
Join Date: Mar 2005
Posts: 3
Default Re: Rebooting on startx (2.6.11.5 and 7167 nvidia)

Thanks, but those are the precise instructions I used on the 2.6.8 kernel. I tried the same with the 2.6.11.5 with no success. I will try and get the machine networked to see if on occations when it doesn't reboot anything is still alive to report the error.

Anybody else, I'm open to further suggests.

Cheers,

Steve.
sinate is offline   Reply With Quote
Old 03-24-05, 04:10 AM   #4
Mr-Ed
Registered User
 
Join Date: Mar 2005
Posts: 24
Default Re: Rebooting on startx (2.6.11.5 and 7167 nvidia)

Signate, i got the same prob as u got... the 6629 drivers work like a charm on my 6600GT pci-e, but when i try 2 upgrade to the 7167-drivers, X tries to load but hardlocks my comp!! I've tried everything: older kernels, other versions, different versions of Xorg, nvagp or agpgart even tried Xorg with a very standard config, but the problem stays the same...
The drivers install fine, the module loads correct and everything!!! But X still hardlocks and i get the same blinking cursor in the top left corner...

My comp specs:
2.6.11-gentoo-r4 SMP x86_64 Intel(R) Xeon(TM) CPU 3.20GHz EMT64 GenuineIntel GNU/Linux
with a XFX 6600GT pci-e videocard

Hope Zander gets a wiff of this, cause it's definetely something with the new drivers (the 6629 work great WITH Render and Composite enabled!!!)
Mr-Ed is offline   Reply With Quote
Old 03-25-05, 07:36 AM   #5
usv
Mr. Janne Paalijarvi
 
Join Date: Mar 2005
Posts: 3
Default Re: Rebooting on startx (2.6.11.5 and 7167 nvidia)

Funny. I had a couple of months old SuSE 9.2 installation working with default kernel and the Nvidia drivers from Yast Online Update. Earlier this week I took a fresh kernel (2.6.11.5) from kernel.org, configured, compiled and installed it. After rebooting to the new kernel I backed up and deleted my /etc/X11/XF86Config , downloaded Linux IA32 1.0-7167 driver package from Nvidia and installed it. Then I run sax2 -m 0=nvidia and just accepted the suggested configuration. Then I tried startx ... and it worked flawlessly! I only had to erase a couple of lines from sax2-generated XFree86 to get font sizes right. I'm using GeForce FX 5700 based board. My XFree86 and kernel config files are available on request.
usv is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:47 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.