Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-29-05, 05:18 PM   #1
exalik
Registered User
 
Join Date: Jan 2005
Location: St Etienne / France
Posts: 10
Exclamation Need to install NVIDIA driver each boot (Man)drake 10.1 + GEFORCE 6600 + Xorg 6.8.1

Hello

Because the NVIDIA driver 1.0-6629-pkg2 didn't work properly (without Swcursor = 1 and NoRenderExtension = 1 / and need to install each boot) i decided to patch the Xorg 6.8.1 and to build/install it.

I install NVIDIA driver (1.0-6629) and change my xorg.conf (Swcursor = 0 and NoRenderExtension = 0)
I do a startx and see it's running fine.

I reboot my computer and X can't start ; i need to install an other time the driver to do it


Look at the Xorg log file just after a reboot :


(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 16, (--) framebuffer bpp 16
(==) NVIDIA(0): RGB weight 565
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "SWcursor" "0"
(**) NVIDIA(0): Option "NoRenderExtension" "0"
(--) NVIDIA(0): Linear framebuffer at 0xB0000000
(--) NVIDIA(0): MMIO registers at 0xC0000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found


My xorg.conf :


Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "/usr/X11R6/lib64/modules/extensions/libglx.so"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1600x1200 @ 70 Hz"
HorizSync 31.5-88.0
VertRefresh 50-90

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# Dell D800 and few Inspiron (16/10) 1280x800
ModeLine "1280x800" 147.89 1280 1376 1512 1744 800 801 804 848

# Dell D800 and few Inspiron (16/10) 1680x1050
ModeLine "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054 1103

# Dell D800 and few Inspiron (16/10) 1920x1200
ModeLine "1920x1200" 230 1920 1936 2096 2528 1200 1201 1204 1250 +HSync +VSync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
BoardName "NVIDIA GeForce (fbdev)"
Driver "nvidia"
Option "NoRenderExtension" "0"
Option "SWCursor" "0"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection



Who can help me please ???


Thanks


Exalik
__________________
AMD Athlon 64 3000+ / ASUS A8N-SLI-Deluxe / GEFORCE 6600 / 1Go DDR400 / Mandriva Linux 2006 x86 64

What about less microsoft in our world ? Better !!!
exalik is offline   Reply With Quote
Old 01-29-05, 06:38 PM   #2
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Need to install NVIDIA driver each boot (Man)drake 10.1 + GEFORCE 6600 + Xorg 6.8.1

hmm, if "modprobe nvidia" (by hand... before you start X) solves your problem...
then you should add a "nvidia" line (bien sūr sans les "") in /etc/modules.preload
chunkey is offline   Reply With Quote
Old 01-29-05, 06:42 PM   #3
chrismortimore
Registered User
 
Join Date: Jul 2004
Posts: 131
Default Re: Need to install NVIDIA driver each boot (Man)drake 10.1 + GEFORCE 6600 + Xorg 6.8.1

or set up hotplug properly to autoload the driver on startup.
__________________
[ www.guff.tk ]
chrismortimore is offline   Reply With Quote
Old 01-30-05, 12:11 PM   #4
seandarcy
Registered User
 
Join Date: Jan 2005
Posts: 8
Default Re: Need to install NVIDIA driver each boot (Man)drake 10.1 + GEFORCE 6600 + Xorg 6.8

I'm having the same problem with FC3, Updates Released. 2.6.10-1.741. nv 6629.

How do i set up hotplug?

sean
seandarcy is offline   Reply With Quote
Old 01-31-05, 03:03 AM   #5
exalik
Registered User
 
Join Date: Jan 2005
Location: St Etienne / France
Posts: 10
Default Re: Need to install NVIDIA driver each boot (Man)drake 10.1 + GEFORCE 6600 + Xorg 6.8.1

Hello,

I tried to boot with nvidia driver writing in /etc/modprobe.preload ; i saw the nvidia logo screen and X was qtarting properly but my keyboard was bloking.



So i tried to add keyboard driver just before the nvidia driver in the modprobe.preload file but it was the same result.

Then i have deleted nvidia and keyboard in the modprobe.preload file ; start in level 3 and do a modprobe nvidia before the startx and it is working properly


Now, i'm looking where (in which file) i can add "modprobe nvidia" to start directly in level 5

I've just found that in an other thread :

Re: Failed to initialize the NVIDIA kernel module!

What version of x.org are you running?

I've been experiencing strange problems like this since upgrading from 6.8.0 to 6.8.1. Right now I have a manual modprobe in my /etc/rc.d/rc.local and then X succeeds to start on the third (!) try. Without the manual modprobe it doesn't start at all.


Exalik


PS: I don't launch games with my computer but use it just for internet and others so i don't know if it would fully work properly !
__________________
AMD Athlon 64 3000+ / ASUS A8N-SLI-Deluxe / GEFORCE 6600 / 1Go DDR400 / Mandriva Linux 2006 x86 64

What about less microsoft in our world ? Better !!!

Last edited by exalik; 01-31-05 at 03:19 AM.
exalik is offline   Reply With Quote
Old 02-07-05, 08:24 AM   #6
exalik
Registered User
 
Join Date: Jan 2005
Location: St Etienne / France
Posts: 10
Default Re: Need to install NVIDIA driver each boot (Man)drake 10.1 + GEFORCE 6600 + Xorg 6.8.1

Hello,

I tried put nvidia driver in the /etc/rc.d/rc.local but it doesn't change.

I want to boot in level 5 as it is writing in the /etc/inittab but Mandrake 10.1 boot in level 3.
I have to log and to do a modprobe nvidia before start x to use my computer in graphic mode.


can somebody help me please ?


Thanks


Exalik
__________________
AMD Athlon 64 3000+ / ASUS A8N-SLI-Deluxe / GEFORCE 6600 / 1Go DDR400 / Mandriva Linux 2006 x86 64

What about less microsoft in our world ? Better !!!
exalik is offline   Reply With Quote
Old 02-07-05, 09:00 AM   #7
va3rcc
The Ancient One
 
Join Date: Aug 2004
Location: London, Ontario, Canada
Posts: 89
Default Re: Need to install NVIDIA driver each boot (Man)drake 10.1 + GEFORCE 6600 + Xorg 6.8

Well for starters I hate to burst your bubble but Xorg 6.8.1 does not support the 6600 series cards. I hope Mandrake has an updated Xorg for you to use like Xorg 6.8.2RC3.
__________________
Ron Crouch
va3rcc is offline   Reply With Quote
Old 02-07-05, 10:06 AM   #8
exalik
Registered User
 
Join Date: Jan 2005
Location: St Etienne / France
Posts: 10
Default Re: Need to install NVIDIA driver each boot (Man)drake 10.1 + GEFORCE 6600 + Xorg 6.8

Quote:
Originally Posted by va3rcc
Well for starters I hate to burst your bubble but Xorg 6.8.1 does not support the 6600 series cards. I hope Mandrake has an updated Xorg for you to use like Xorg 6.8.2RC3.

Where could i download the source tar file(s) ???
__________________
AMD Athlon 64 3000+ / ASUS A8N-SLI-Deluxe / GEFORCE 6600 / 1Go DDR400 / Mandriva Linux 2006 x86 64

What about less microsoft in our world ? Better !!!
exalik is offline   Reply With Quote

Old 02-07-05, 10:50 AM   #9
va3rcc
The Ancient One
 
Join Date: Aug 2004
Location: London, Ontario, Canada
Posts: 89
Default Re: Need to install NVIDIA driver each boot (Man)drake 10.1 + GEFORCE 6600 + Xorg 6.8

Well that is a good question. SuSE are the only ones that I am aware of that have hacked 6.8.1 to produce a 6.8.2 version so I doubt that their source packages would work for your distro. Perhaps you should consider giving Mandrake the old heave-ho.
__________________
Ron Crouch
va3rcc is offline   Reply With Quote
Old 04-04-05, 09:08 AM   #10
linkin
Registered User
 
Join Date: Jan 2005
Posts: 15
Default Re: Need to install NVIDIA driver each boot (Man)drake 10.1 + GEFORCE 6600 + Xorg 6.8.1

You could download the src from suse... and compile it from your distro.

But i thing.. you want download now the newest release (6.8.2-0.1).

(go to this URL here... to see the files, you will need. Here you can search for the RPMs for your Distro: rpmseek.com)

After downloading and installing you need to reinstall the nvidia driver. After it it will works perfectly
linkin is offline   Reply With Quote
Old 04-05-05, 04:49 PM   #11
scanti
Registered User
 
Join Date: Mar 2005
Posts: 11
Default Re: Need to install NVIDIA driver each boot (Man)drake 10.1 + GEFORCE 6600 + Xorg 6.8.1

I think it's a udev problem.
try looking for nvidia in /etc/udev/permissions.d/50-udev.permissions (in my Fedora)
and change it's permission to 0666, maybe it may works.
scanti is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia driver stopped working after X restart and Kernel taint msgs during boot mikejuni NVIDIA Linux 10 05-21-12 08:30 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
NVIDIA GeForce GTX 670 brings Kepler on a $399 budget (SlashGear) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM

All times are GMT -5. The time now is 07:40 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.