Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-31-05, 04:35 PM   #1
pelias
Registered User
 
Join Date: Jan 2003
Location: Hellas
Posts: 11
Unhappy FC3 nforce4 unsolved sound problem

I have a MSI K8N SLI Platinum nforce4 m/b.

I have installed : the latest

NFORCE-Linux-x86_64-1.0-0301-pkg1.run

dmesg reports :
---------------------------------------------
nvsound: module license 'unspecified' taints kernel.
Nvsound: Nvidia Audio Init Module, 17:15:12 Mar 31 2005 version 1.0-2
----------------------------------------------
the system-config-soundcard can't detect it

the AUDIO section of /etc/sysconfig/hwconf is
----------------------------------------------
class: AUDIO
bus: PCI
detached: 0
driver: nvsound
desc: "Creative Labs SB Audigy LS"
vendorId: 1102
deviceId: 0007
subVendorId: 1462
subDeviceId: 1009
pciType: 1
pcidom: 0
pcibus: 1
pcidev: d
pcifn: 0
-
----------------------------------------------

The /dev/dsp doesn't exist.

The /etc/modprobe.conf is :
-------------------------------------------------
alias eth0 forcedeth
alias scsi_hostadapter sata_nv
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias ieee1394-controller ohci1394
alias sound-slot-0 nvsound
install nsound /sbin/modprobe --ignore-install nvsound && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove nvsound { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove nvsound
----------------------------------------------------
The "alias sound-slot-0 nvsound" line isn't enough?

alsa is installed :
alsa-utils-1.0.6-3
alsa-lib-1.0.6-7.FC3
alsa-lib-devel-1.0.6-7.FC3
alsa-lib-1.0.6-7.FC3

You can find attached the nvidia-bug-report.log

I have even try to load module snd-intel8x0 .

ANY IDEA Please!!


Thanks in advance

Panagiotis
Attached Files
File Type: txt nforce-bug-report.log.txt (59.2 KB, 126 views)

Last edited by pelias; 04-01-05 at 08:51 AM.
pelias is offline   Reply With Quote
Old 04-03-05, 06:58 AM   #2
pelias
Registered User
 
Join Date: Jan 2003
Location: Hellas
Posts: 11
Question Re: FC3 nforce4 unsolved sound problem

Anyone??
pelias is offline   Reply With Quote
Old 04-03-05, 12:44 PM   #3
lightsout
Registered User
 
Join Date: Mar 2005
Posts: 28
Default Re: FC3 nforce4 unsolved sound problem

What does "lsmod" show? Does it show the nvsound module being loaded?
lightsout is offline   Reply With Quote
Old 04-03-05, 03:20 PM   #4
pelias
Registered User
 
Join Date: Jan 2003
Location: Hellas
Posts: 11
Default Re: FC3 nforce4 unsolved sound problem

Yes.
I load it manually before I start X.

[root@lycos ~]# lsmod
Module Size Used by
nvsound 1724524 0
soundcore 12769 1 nvsound
pelias is offline   Reply With Quote
Old 04-03-05, 03:30 PM   #5
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: FC3 nforce4 unsolved sound problem

Quote:
Originally Posted by pelias
desc: "Creative Labs SB Audigy LS"
Well, It seems MSI has it own Sound "Solution"...
so you should check out the "snd-emu10k1" (or something like that) module...
just do "modprobe snd-emu10k1"... and try...

(If it doesn't work, run lspci -v and attach the output here)
chunkey is offline   Reply With Quote
Old 04-03-05, 04:04 PM   #6
PrakashP
gentoo ~x86_64 user
 
PrakashP's Avatar
 
Join Date: Jul 2004
Location: Germania
Posts: 213
Default Re: FC3 nforce4 unsolved sound problem

Furthermore, unless you have a nf2 with mcp-t, I wouldn't use nvsound and rather use alsa, as it serves you better.
PrakashP is offline   Reply With Quote
Old 04-03-05, 04:10 PM   #7
pelias
Registered User
 
Join Date: Jan 2003
Location: Hellas
Posts: 11
Default Re: FC3 nforce4 unsolved sound problem

It didn't work

You can find attached the output of lspci -v, of dmesg as well as the output of lsmod.

I have notice some warnings about "NVIDIA" module in dmesg
Attached Files
File Type: txt lspci-v.txt (7.2 KB, 132 views)
File Type: txt lsmod.txt (2.4 KB, 130 views)
File Type: txt dmesg_tail.txt (731 Bytes, 119 views)
pelias is offline   Reply With Quote
Old 04-03-05, 04:48 PM   #8
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: FC3 nforce4 unsolved sound problem

Ok, I see... Your Audigy LS is stripped down version and not compatible with snd_emu10k1 driver...

Luckily, there's already a driver/module "snd-ca0106"!
(If you don't "have" it... update your kernel!)
chunkey is offline   Reply With Quote

Old 04-03-05, 05:12 PM   #9
pelias
Registered User
 
Join Date: Jan 2003
Location: Hellas
Posts: 11
Default Re: FC3 nforce4 unsolved sound problem

Do you mean to update alsa?

I have the Kernel 2.6.10-1.770_FC3

Thanks
pelias is offline   Reply With Quote
Old 04-04-05, 07:30 AM   #10
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: FC3 nforce4 unsolved sound problem

Quote:
Originally Posted by pelias
Do you mean to update alsa?
Hmm, depends who old your alsa-librarys & tools are...
(But I don't think that it's necessary)
Quote:
Originally Posted by pelias
I have the Kernel 2.6.10-1.770_FC3
Sorry, but you need a >= 2.6.11 Linux-Kernel!
chunkey is offline   Reply With Quote
Old 04-04-05, 03:30 PM   #11
pelias
Registered User
 
Join Date: Jan 2003
Location: Hellas
Posts: 11
Red face Re: FC3 nforce4 unsolved sound problem

Ok.

I have upgrade to 2.6.11.7 and I was able to detect it (snd-ca0106) but when I try to play test sound, I can hear no sound at all. The following message appears (note that when I enter X the warning message "no /dev/dsp was found" is still being displayed):

amixer: Mixer attach default error: No such file or directory
amixer: Mixer attach default error: No such file or directory
aplay: main:508: audio open error: No such file or directory

My sound server is arts. Do you suggest me to switch to another one?

Pan
pelias is offline   Reply With Quote
Old 04-04-05, 04:45 PM   #12
lightsout
Registered User
 
Join Date: Mar 2005
Posts: 28
Default Re: FC3 nforce4 unsolved sound problem

If you can get nvsound working, arts/esd isn't required as it does hardware mixing.

Do you get anything like this in dmesg?

Quote:
dmesg | grep -i nvsound
nvsound: module license 'unspecified' taints kernel.
Nvsound: Nvidia Audio Init Module, 17:53:03 Mar 28 2005 version 1.0-2
Nvsound: NVIDIA nForce2 Controller Mem 0xd6000000 and IRQ 9
Nvsound: NVIDIA nForce2 Audio aci 0xd400 and ac97 0xd000, IRQ 4
Nvsound: DEV MIXER 0 DEV AUDIO 3
This is what I get for my NF2.
lightsout is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:50 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.