Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-02-05, 06:56 PM   #1
_tf_
scriptfoo warrior
 
_tf_'s Avatar
 
Join Date: Apr 2003
Location: here
Posts: 117
Question composite extension slows down after some time

hi all

i'm using the composite extension with xcompmgr and renderaccel.
all works fine and *really* looks cool, but about every 1-4+ hours
the xcompmgr eats 100% cpu cycles and the whole desktop slows to a crawl
until i restart xcompmgr.
this is with latest fedora rawhide, and i'm getting this behavior for a long time
now with different xorgs, xcompmgrs, kernels and nvidia drivers.
same with kde and gnome, etc...
for a start, one thing i noticed is that it is often randomly triggered by browsing the dropdown bookmarklist in firefox.

maybe we can gather some info here to bring up a nice bug report for nvidia.
would be great to slay this nasty bug!


cheers
lars
__________________
"My mortgage rate was cut in half after I replied to spam
using Fedora!" raves Bo Battipaglia.
_tf_ is offline   Reply With Quote
Old 04-03-05, 08:58 AM   #2
_tf_
scriptfoo warrior
 
_tf_'s Avatar
 
Join Date: Apr 2003
Location: here
Posts: 117
Default Re: composite extension slows down after some time

hey! i'm not the only one with this, i'm shure!
__________________
"My mortgage rate was cut in half after I replied to spam
using Fedora!" raves Bo Battipaglia.
_tf_ is offline   Reply With Quote
Old 04-03-05, 09:40 AM   #3
joffe
Registered User
 
joffe's Avatar
 
Join Date: Nov 2004
Posts: 171
Default Re: composite extension slows down after some time

Have you tried KDE 3.4 with its own composite manager 'kompmgr'? It's the same guy who wrote the xcompmgr who has written the new one as well, only kompmgr has a lot of bugs ironed out...
joffe is offline   Reply With Quote
Old 04-03-05, 03:05 PM   #4
_tf_
scriptfoo warrior
 
_tf_'s Avatar
 
Join Date: Apr 2003
Location: here
Posts: 117
Default Re: composite extension slows down after some time

thanks for answering!


i'm only using gnome for now, so it would be nice to backport some of these
changes to xcompmgr when they kill this issue.
will have a look at kcompmgr, maybe i get a clue whats going wrong.

right now i'm using gnome-settings-visualeffects
http://www.gnomefiles.org/app.php?soft_id=777
which works verry nice, except this slowdown xcompmgr issue.

maybe an integrated xcomp-manager will come when luminocity
http://www.gnome.org/~seth/blog/xshots
is added to metacity.
btw. coolest eyecandy i've ever seen on a desktop, bb. osx

maybe someone using kcompmgr without problems (minus the opengl issue)
can comment how well this solution works?


cheers
lars

edit: here is the bugzilla page for this bug
https://bugs.freedesktop.org/show_bug.cgi?id=1096
__________________
"My mortgage rate was cut in half after I replied to spam
using Fedora!" raves Bo Battipaglia.

Last edited by _tf_; 04-03-05 at 03:32 PM.
_tf_ is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora KDE 16 Geforce GTX260 and slow gtk applications Rendering NVIDIA Linux 10 07-11-13 08:02 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 01:14 PM

All times are GMT -5. The time now is 10:18 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.