Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-03-05, 07:18 PM   #1
Gallienus
Registered User
 
Join Date: Apr 2005
Posts: 11
Angry Unable to install Nvidia driver

I am trying to install a new version of the Nvidia driver. My GeForce FX 5200 is unaceeptably slow in graphics upadates. When I try to install the NVIDIA-Linus-7174-pkg1.run it gives an error messgae that X is already running an nvidia device & can't be unloaded.

I cannot find any documentation on what "X" is. A keyword serach shows every topic in every forum. My RH Linux manuals have no entries on this "X" or how to start/ stop it. How do I disable this X so I can install the driver.

Also I re-edited my XF86Conig file to change back to Driver "vesa". Now my Linus will not start at all. It just boots to a blank screen. How do I boot to a command primpoit so I can re-edit my XF86Config to get the Linux working again.
Gallienus is offline   Reply With Quote
Old 04-03-05, 07:32 PM   #2
Qzukk
Registered User
 
Join Date: Apr 2005
Posts: 1
Default Re: Unable to install Nvidia driver

X is the graphics system. If you see pretty pictures and windows, you're probably using X.

It sounds like you're using xdm, kdm, or another display manager to "boot" to X. You'll need to start your computer in single-user mode to disable this. See your distribution's instructions for how to do this, since it differs (typically, you use the kernel image name (usually "linux") followed by "1" or "single" at the boot prompt.)

Single user mode is a good time to compile the nvidia driver, too.
Qzukk is offline   Reply With Quote
Old 04-03-05, 11:06 PM   #3
APwrs
Registered User
 
Join Date: Apr 2005
Posts: 26
Default Re: Unable to install Nvidia driver

I would suggest changing "vesa" back to "nv" for the time being. Then, as suggested, try booting into single user mode, or if you're not sure how to do that, after booting your computer, when you're sitting at the login screen, press CTRL + ALT + 1. This should put you at a console.

Once there, type "telinit 3" without the quotes, and hit enter. This should put you into the 3rd run level, which nVidia actually likes compiling in more than the 1st run level (single user mode). Hopefully, that should cause X to close for you. Then, try installing your driver.

If it still complains about X already running, you can log in as root (which you should be already) and try typing "killall X" again without the quotes. That might do the trick for you.
APwrs is offline   Reply With Quote
Old 04-04-05, 02:26 PM   #4
Parity
Registered User
 
Join Date: Apr 2005
Posts: 4
Default Re: Unable to install Nvidia driver

Quote:
Originally Posted by APwrs
I would suggest changing "vesa" back to "nv" for the time being. Then, as suggested, try booting into single user mode, or if you're not sure how to do that, after booting your computer, when you're sitting at the login screen, press CTRL + ALT + 1. This should put you at a console.

Once there, type "telinit 3" without the quotes, and hit enter. This should put you into the 3rd run level, which nVidia actually likes compiling in more than the 1st run level (single user mode). Hopefully, that should cause X to close for you. Then, try installing your driver.

If it still complains about X already running, you can log in as root (which you should be already) and try typing "killall X" again without the quotes. That might do the trick for you.
If you've logged out of your KDE or Gnome session and still have X running, you will
generally want to do something like '/etc/init.d/kdm stop', or 'killall kdm'.
(replace kdm with xdm or gdm as appropriate : these are the programs that provide
the graphical login screen ('x display manager'), and they may respawn X every time
you kill it, depending on configuration.)

Using init.d scripts to shut down your display manager is slightly cleaner. You can
also use the init.d scripts to restore your graphical login prompt.

'/etc/init.d/xdm start' (or kdm, or gdm.)


On single-user mode.

To boot into single user mode in lilo, hit the shift key at the lilo prompt, and -
assuming you normally boot a kernel named 'linux', then type 'linux single' and
hit return.

The procedure is similar on grub. I seem to recall that grub's runtime help tells
you how to append options to a kernel boot line.

To get -out- of single user mode, just exit the shell.
This should continue the boot process, and continue to the default runlevel.
Parity is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
Unable to load 3d driver rebol NVIDIA Linux 3 09-29-02 04:58 PM
NVIDIA driver doesn't install successfully on RH 7.3 Sunni NVIDIA Linux 3 08-28-02 02:30 PM

All times are GMT -5. The time now is 06:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.