Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-18-04, 02:14 PM   #1
jeff_sadowski
Registered User
 
Join Date: Apr 2004
Posts: 4
Default 6629 Problem not an ELF file?

After installing 6629 ldconfig now says the following.

ldconfig: /usr/X11R6/lib/libXvMCNVIDIA.so.1.0.6629 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/X11R6/lib/libXvMCNVIDIA_dynamic.so.1 is not an ELF file - it hasthe wrong magic bytes at the start.

ldconfig: /usr/lib/libGL.so.1 is not an ELF file - it has the wrong magic bytesat the start.

ldconfig: /usr/lib/libGL.so.1.0.6629 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libGL.so is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libGLcore.so.1 is not an ELF file - it has the wrong magic bytes at the start.

ldconfig: /usr/lib/libGLcore.so.1.0.6629 is not an ELF file - it has the wrong magic bytes at the start.

I re-downloaded the driver and ran a diff against my original download no difference so I doubt the file is corrupt besides it unpacks with no errors
and installs even with noerrors. but when I try to run it the screen goes blank
like others have reported. I have Slackware current as of nov 18 2004.
I am running kernel 2.6.8.1 and nvidia 6111 works fine. I am hoping the errors
Im reporting might shed new light on the issue. Do I need something different with ldconfig to support non-ELF files? Is this a kernel issue? I swore I compiled in
all three binary support into the kernel.
Heres what make menuconfig says for my 2.6.8.1 build
[*] Kernel support for ELF binaries
<*> Kernel support for a.out and ECOFF binaries
<*> Kernel support for MISC binaries

thats all the binaries I can find in the kernel options.

What am I missing?
Do I need a newer ldconfig?

ldconfig --version
ldconfig (GNU libc) 2.3.3
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Andreas Jaeger.

I tried the suggestion
sh NVIDIA-Linux-x86-1.0-6629-pkg1.run --force-tls=new

with the same result. I still get the error messages by ldconfig

Any help would be greatly appreciated. Thanks
I was wanting to upgrade the kernel.
Is there a driver patch for 6111?
this might be easier for a temporary solution that or go with xorg drivers
then pinball would run choppy. yall gotta try the pinball game it rocks.
:-)
jeff_sadowski is offline   Reply With Quote
Old 11-18-04, 03:16 PM   #2
Spyke
Foxie
 
Spyke's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 618
Send a message via AIM to Spyke Send a message via MSN to Spyke Send a message via Yahoo to Spyke
Default Re: 6629 Problem not an ELF file?

What distro is this?
__________________
Gaming:
Intel i7 980X @ 4GHz | ASUS Rampage III Extreme | GTX 480 3Way SLI @ 900Mhz | Koolance VID-NX480 | Corsair Obsidian 700D
Corsair H70 CPU Cooler | EK-FB RE3 | Corsair AX1200 | Black Ice SR1 360 | 240GB OCZ Revodrive X2 SSD | Windows 7 Ultimate
12GB Corsair Dominator GT @ 8-8-8-24-1T DDR3-1600 | Onkyo TX SR-707 | 70" Sharp Aquos LCD | KEF Audio 5.1 C3/C6LCR/C7
Workstation:
Intel i7 920 D0 @ 4GHz | ASUS Rampage II Extreme | GTX 480 @ 800Mhz | Koolance VID-NX480 | Lian-Li V1200B | Corsair HX1000
EK NB ASUS HP | Watercool HeatKiller 3.0 | Feser Extreme X-360 | 2x160GB Intel X25-M SSD RAID0 | 4x2TB WD20EARS RAID10
12GB Corsair Dominator @ 8-8-8-24-1T DDR3-1600 | Creative X-Fi Titanium | Pioneer DVR-212D | Gentoo Linux
Dell 3008WFP | JohnBlue JB3 | CityPulse DA2.03e II DAC | KingRex T20U w/ Modded Auricaps & PSU | Glow Audio Sub One
Server:
Quad Socket Opteron 8356 (16 cores) @ 2.3GHz | Supermicro H8QMi-2 | Supermicro 2U Chassis | Redundant 1200W PSU
32GB 2GBx16 DDR2-667 ECC | 4x 300GB Cheetah SAS RAID10 | Adaptec 5805 512MB w/BBU | Colocated | Gentoo Linux
Spyke is offline   Reply With Quote
Old 11-18-04, 03:28 PM   #3
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: 6629 Problem not an ELF file?

md5sum libGLcore.so.1
45eabc9f5248a554e32cdd173f12bf59 libGLcore.so.1

md5sum libGL.so.1
cedd8594c438097bc06fb198e8370198 libGL.so.1
Lithorus is offline   Reply With Quote
Old 11-18-04, 07:43 PM   #4
jeff_sadowski
Registered User
 
Join Date: Apr 2004
Posts: 4
Default Re: 6629 Problem not an ELF file?

Yes those are the files I have they are not ELF format.
md5sum ./usr/lib/libGL.so.1.0.6629
cedd8594c438097bc06fb198e8370198 ./usr/lib/libGL.so.1.0.6629
md5sum ./usr/lib/libGLcore.so.1.0.6629
45eabc9f5248a554e32cdd173f12bf59 ./usr/lib/libGLcore.so.1.0.6629

thats the same md5sum thanks for those Im certain now that this is the
problem some of us are having what version of ldconfig are you using
jeff_sadowski is offline   Reply With Quote
Old 11-18-04, 10:29 PM   #5
Spyke
Foxie
 
Spyke's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 618
Send a message via AIM to Spyke Send a message via MSN to Spyke Send a message via Yahoo to Spyke
Default Re: 6629 Problem not an ELF file?

Let me guess, Gentoo.
__________________
Gaming:
Intel i7 980X @ 4GHz | ASUS Rampage III Extreme | GTX 480 3Way SLI @ 900Mhz | Koolance VID-NX480 | Corsair Obsidian 700D
Corsair H70 CPU Cooler | EK-FB RE3 | Corsair AX1200 | Black Ice SR1 360 | 240GB OCZ Revodrive X2 SSD | Windows 7 Ultimate
12GB Corsair Dominator GT @ 8-8-8-24-1T DDR3-1600 | Onkyo TX SR-707 | 70" Sharp Aquos LCD | KEF Audio 5.1 C3/C6LCR/C7
Workstation:
Intel i7 920 D0 @ 4GHz | ASUS Rampage II Extreme | GTX 480 @ 800Mhz | Koolance VID-NX480 | Lian-Li V1200B | Corsair HX1000
EK NB ASUS HP | Watercool HeatKiller 3.0 | Feser Extreme X-360 | 2x160GB Intel X25-M SSD RAID0 | 4x2TB WD20EARS RAID10
12GB Corsair Dominator @ 8-8-8-24-1T DDR3-1600 | Creative X-Fi Titanium | Pioneer DVR-212D | Gentoo Linux
Dell 3008WFP | JohnBlue JB3 | CityPulse DA2.03e II DAC | KingRex T20U w/ Modded Auricaps & PSU | Glow Audio Sub One
Server:
Quad Socket Opteron 8356 (16 cores) @ 2.3GHz | Supermicro H8QMi-2 | Supermicro 2U Chassis | Redundant 1200W PSU
32GB 2GBx16 DDR2-667 ECC | 4x 300GB Cheetah SAS RAID10 | Adaptec 5805 512MB w/BBU | Colocated | Gentoo Linux
Spyke is offline   Reply With Quote
Old 11-21-04, 06:07 PM   #6
jeff_sadowski
Registered User
 
Join Date: Apr 2004
Posts: 4
Default Re: 6629 Problem not an ELF file?

No I'm using Slackware Current last upgraded 11-18-2004
What version of glibc are you using with your Slackware Current?
jeff_sadowski is offline   Reply With Quote
Old 04-04-05, 10:42 AM   #7
dimitri
Registered User
 
Join Date: Sep 2003
Location: France
Posts: 23
Default Re: 6629 Problem not an ELF file?

I'm using Fedora Core 2 and I see the same problem. This is not an issue related to a buggy distribution:

# file /usr/X11R6/lib/libXvMCNVIDIA.so.1.0.6629
/usr/X11R6/lib/libXvMCNVIDIA.so.1.0.6629: data
# /sbin/ldconfig
/sbin/ldconfig: /usr/X11R6/lib/libXvMCNVIDIA.so.1.0.6629 is not an ELF file - it has the wrong magic bytes at the start.
#

The strange thing is that we have updated from 6629 to 7167 so this file shouldn't be there in the first place:
# ls /usr/X11R6/lib/libXvMCNVIDIA*
/usr/X11R6/lib/libXvMCNVIDIA.a
/usr/X11R6/lib/libXvMCNVIDIA_dynamic.so.1
/usr/X11R6/lib/libXvMCNVIDIA.so.1.0.6629
/usr/X11R6/lib/libXvMCNVIDIA.so.1.0.7167
#
dimitri is offline   Reply With Quote
Old 04-04-05, 04:49 PM   #8
lightsout
Registered User
 
Join Date: Mar 2005
Posts: 28
Default Re: 6629 Problem not an ELF file?

What happens when you run "file" on this files?

Quote:
file /usr/lib/opengl/nvidia/lib/libGLcore.so.1.0.7174
/usr/lib/opengl/nvidia/lib/libGLcore.so.1.0.7174: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), stripped
My only thought is that the x86-64 binaries have been installed on a i386 system, but that seems unlikely?
lightsout is offline   Reply With Quote

Old 04-05-05, 03:47 AM   #9
dimitri
Registered User
 
Join Date: Sep 2003
Location: France
Posts: 23
Default Re: 6629 Problem not an ELF file?

These are certainly not x86-64 binaries, I would expect 'file' to be able to identify them. For example it is able to identify a Solaris/SPARC library:

$ file libGL.so.1
libGL.so.1: ELF 32-bit MSB shared object, SPARC, version 1 (SYSV), not stripped
$

Also this happened on a few machines only. I guess something went wrong during the upgrade to 7167 or during the installation of 6629. The strange thing is that OpenGL programs had always worked properly on this machine as far as I can remember.
dimitri is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 06:00 PM
RPM Source problems LaoTzuTao NVIDIA Linux 10 01-19-03 05:15 AM
Can't install NVIDIA_kernel.XXXX.XXXX.src or regular rpm noeffort NVIDIA Linux 15 12-17-02 01:22 PM
RH7.2 (2.4.9-34) install + src.rpm problem FlyingDutchMan NVIDIA Linux 3 08-08-02 09:04 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 02:15 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.