Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-15-05, 09:00 PM   #1
H3g3m0n
eVga 6600GT PCI-E
 
H3g3m0n's Avatar
 
Join Date: Aug 2002
Posts: 14
Unhappy "Failed to load the NVIDIA kernel module!" PCIE+2.6.11-mm3+xorg-x11-6.8.2-r1+amd64

When ever i startx i get the the following error message. The module appears to be loaded fine. The xorg is a stock xorgconfig generated file with vga changed to nvidia, it works fine with nv instead of nvidia (although the nv driver has a anoying bug of crashing when lots of eterm console output is drawn and making all the windows white).

Are there any PCIE specific options i should enable in the kernel? I though I saw a PCI Express option under the BUS category but i carn't find it there now, is there some dependency i need to enable and would basic vga work without the pci express stuff on when its a pci express card?

The card is a eVga 6600GT

Code:
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xE0000000
(--) NVIDIA(0): MMIO registers at 0xE8000000
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.
Code:
hegemon@ender ~ $ lsmod
Module                  Size  Used by
nvidia               4562812  0
Code:
hegemon@ender ~ $ uname -a
Linux ender 2.6.11-mm3 #9 SMP Tue Mar 15 01:01:54 Local time zone must be set--see zic  x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux
some dmesg output:
Code:
ACPI: PCI Interrupt 0000:05:00.0[A] -> Link [APC3] -> GSI 18 (level, low) -> IRQ 209
PCI: Setting latency timer of device 0000:05:00.0 to 64
NVRM: loading NVIDIA Linux x86_64 NVIDIA Kernel Module  1.0-7167  Fri Feb 25 09:11:39 PST 2005
lspci vga line:
Code:
0000:05:00.0 VGA compatible controller: nVidia Corporation NV43 [MSI NX6600GT-TD128E] (rev a2)
Gentoo 2004.3, GCC 3.4.3
H3g3m0n is offline   Reply With Quote
Old 03-16-05, 04:00 PM   #2
lightsout
Registered User
 
Join Date: Mar 2005
Posts: 28
Default Re: "Failed to load the NVIDIA kernel module!" PCIE+2.6.11-mm3+xorg-x11-6.8.2-r1+amd6

Can you try a more "stock" kernel - like gentoo-dev-sources instead?
lightsout is offline   Reply With Quote
Old 03-27-05, 10:37 PM   #3
H3g3m0n
eVga 6600GT PCI-E
 
H3g3m0n's Avatar
 
Join Date: Aug 2002
Posts: 14
Default Re: "Failed to load the NVIDIA kernel module!" PCIE+2.6.11-mm3+xorg-x11-6.8.2-r1+amd6

I have tried love-sources 2.6.11-love2 also now, i cannot use a stock kernel because i require reiser4 + amd64 support however i havn't heard of anyone else having problems with this kernel and its not as unstable as mm afaik.
H3g3m0n is offline   Reply With Quote
Old 03-28-05, 02:15 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: "Failed to load the NVIDIA kernel module!" PCIE+2.6.11-mm3+xorg-x11-6.8.2-r1+amd6

@H3g3m0n: which version of the module-init-tools are you using? What does `modprobe nvidia; echo $?` return with nvidia.ko already loaded?
zander is offline   Reply With Quote
Old 04-03-05, 01:46 AM   #5
H3g3m0n
eVga 6600GT PCI-E
 
H3g3m0n's Avatar
 
Join Date: Aug 2002
Posts: 14
Default Re: "Failed to load the NVIDIA kernel module!" PCIE+2.6.11-mm3+xorg-x11-6.8.2-r1+amd6

I am using module-init-tools-3.0-r2

Tried the command and just got the following:
Code:
ender tmp # modprobe nvidia; echo $?
0
H3g3m0n is offline   Reply With Quote
Old 04-03-05, 03:35 AM   #6
H3g3m0n
eVga 6600GT PCI-E
 
H3g3m0n's Avatar
 
Join Date: Aug 2002
Posts: 14
Default Re: "Failed to load the NVIDIA kernel module!" PCIE+2.6.11-mm3+xorg-x11-6.8.2-r1+amd6

I have now tired it the 2.6.11 stock kernel with the reiser4 patch and linux-2.6.12-rc1-love1 with the same results.
H3g3m0n is offline   Reply With Quote
Old 04-06-05, 08:38 AM   #7
H3g3m0n
eVga 6600GT PCI-E
 
H3g3m0n's Avatar
 
Join Date: Aug 2002
Posts: 14
Default Re: "Failed to load the NVIDIA kernel module!" PCIE+2.6.11-mm3+xorg-x11-6.8.2-r1+amd6

Updating to 7174 fixed the problem
H3g3m0n is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 03:27 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
NVIDIA kernel not loading on boot-up, but insmod loads it Kyle NVIDIA Linux 3 09-10-02 12:01 AM

All times are GMT -5. The time now is 03:18 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.