Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-07-05, 03:32 AM   #1
angshuman
Pink GBA
 
angshuman's Avatar
 
Join Date: Apr 2005
Location: State College, PA
Posts: 207
Question 6600GT, 7174, MSI Neo4SLI, 2.6.11.4-i386 Hang/Reboot

Okay, I did the obligatory Search, but did not find anyone with exactly my problem. Here goes:

First, my specs:
- 6600GT PCIe
- MSI Neo4 Platinum SLI (almost identical to non-US Diamond)
- Dell 1905FP running through DVI
- Kernel 2.6.11.4 (32 bit), Driver 7174

The problem occurs with about 50% probability when the X server is being "activated", e.g.,
1) X startup
2) Ctrl + Alt + F7 after a console session
3) Gdm login screen display after a Logout

Here's what happens -- the screen goes totally blank (the yellow power saving LED comes on, which means the video card has totally cut off all signals from it), and the system either completely and hopelessly HANGs, or simply reboots. Again, the probability of the problem occurring in the above 3 scenarios is roughly 50%, but I have noticed that it is *much* more likely to occur during (3) than during (1).

The other 50% of the time (i.e., once X is up and running, and I don't console-switch or logout), though, everything seems rock solid. I played Half Life for several hours using OpenGL/Wine.

The Xorg log files show *nothing*. In case the problem occurs when X is starting up, the log is sometimes suddenly truncated at an arbitrary place.

I've seen the problem with the stock FC3 2.6.9 kernel, auto-updated 2.6.10 kernel, as well as my custom-compiled 2.6.11.4 kernel -- all i386. I did try x86_64 once, but those horrors are best left untold. I've tried all drivers from 6629 onwards.

The interesting thing is -- my system works perfectly and is 100% stable with the default VESA driver.

Any feedback (or at least sympathy ) would be greatly appreciated.

Angshuman
angshuman is offline   Reply With Quote
Old 04-07-05, 09:27 PM   #2
angshuman
Pink GBA
 
angshuman's Avatar
 
Join Date: Apr 2005
Location: State College, PA
Posts: 207
Unhappy Re: 6600GT, 7174, MSI Neo4SLI, 2.6.11.4-i386 Hang/Reboot

Bump.

Nobody had this problem???
angshuman is offline   Reply With Quote
Old 04-09-05, 05:57 AM   #3
hamsta
Registered User
 
Join Date: May 2004
Posts: 21
Default Re: 6600GT, 7174, MSI Neo4SLI, 2.6.11.4-i386 Hang/Reboot

Quote:
Originally Posted by angshuman
Bump.

Nobody had this problem???
Exactly the same here: PNY 6600. When X is already up, everything works perfectly. Newest Fedora stock kernel...


hamsta
hamsta is offline   Reply With Quote
Old 04-09-05, 10:39 AM   #4
StevenCVAL
Registered User
 
Join Date: Apr 2005
Posts: 4
Unhappy Here is almost same(I think...) case.

Um... First. I'm not good at english. sorry...

I'm useing 6600GT AGP/ASUS CUSL2-C/P3 1G/256MB ram.
and.. distribution is Haansoft LINUX. based on redhat family. I think.

My LINUX box is very same case.
if boot up to console. it's no problem.
and x server with VESA driver, OK. I can't find any problem during bootup. it's stable.
problem is when changing from console mode to graphic mode.(just before login)
or sometimes hangup when from graphic mode to console mode(when shutdown)
when hang up moniter is power save mode. or white screen.
it's never work any key inputs. Alt+Ctrl+Del, Numlock, etc...

but I don't have experience in reboot. only hang up.

I can't find any log messages about hangup. last log messages are just before hang up.
I have been changed and tested AGPmode(NVAGP, AGPGART, auto). but still my box stop.

is this problem cause of hardware or software ?
__________________
... Call me Steven.
StevenCVAL is offline   Reply With Quote
Old 04-09-05, 04:29 PM   #5
angshuman
Pink GBA
 
angshuman's Avatar
 
Join Date: Apr 2005
Location: State College, PA
Posts: 207
Post Re: 6600GT, 7174, MSI Neo4SLI, 2.6.11.4-i386 Hang/Reboot

Alright, lets try and find out what's common among us, in terms of hardware that could be relevant.

I'm using:
- DVI output to Dell 1905FP monitor
- A PCI-Express card (XFX 6600GT)
- SLI capable Motherboard (MSI Neo4 Platinum SLI)
- Corsair Value Select PC3200 DDR (2x512MB)
- Hitachi SATA-II 80GB HDD (not really relevant, but just in case)

Could you guys post what your corresponding components are?

Angshuman
angshuman is offline   Reply With Quote
Old 04-10-05, 12:34 AM   #6
StevenCVAL
Registered User
 
Join Date: Apr 2005
Posts: 4
Default Re: 6600GT, 7174, MSI Neo4SLI, 2.6.11.4-i386 Hang/Reboot

My System is...
- DVI output to LG Flatron L1720P LCD moniter.
- Geforce 6600GT AGP cards.(videocard maker is 'EVERTOP')
- ASUS CUSL2-C Motherboard(i815EP chipset.)
- Samsung PC....133? (or 100?... about 4years old...) SDRAM 128MB * 2 (256MB total)
- maxter EIDE 160GB HDD.(Model No. ST3160023A)

Need more? post message. and I reply answer.
I hope solve this problem soon
__________________
... Call me Steven.
StevenCVAL is offline   Reply With Quote
Old 04-10-05, 02:58 AM   #7
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: 6600GT, 7174, MSI Neo4SLI, 2.6.11.4-i386 Hang/Reboot

Why do I get the feeling that all FX6600 are unstable?
Mine crashes on a Xid 23.
If I replace the card with an older FX5900 or a GF4/4400, the machine remains rock-solid.
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.
gilboa is offline   Reply With Quote
Old 04-10-05, 04:47 AM   #8
hamsta
Registered User
 
Join Date: May 2004
Posts: 21
Default Re: 6600GT, 7174, MSI Neo4SLI, 2.6.11.4-i386 Hang/Reboot

6600GT (PNY) here, AGP connected.
Maybe in connection with udev.

I am using a stock Fedora Core Kernel. The system freezes completely if some of the following actions are done:

- startx
- init 5 (switching to x)
- Redhat Graphical Boot (which is using an X-Server and no framebuffer)
- CTRL-ALT-1 to switch from X to console

The crash does not happens every time. If I have made it into X, everything works until the next reboot. If a crash occours, nothing can be found in any log :-(

It looks like this fault is in all nvidia drivers at the moment, not only in the newest.


Hope, somebody will find a fix soon, I have played already with most of the settings of the driver but with no success :-(



Cheers,

Jens
hamsta is offline   Reply With Quote

Old 04-10-05, 06:14 AM   #9
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 6600GT, 7174, MSI Neo4SLI, 2.6.11.4-i386 Hang/Reboot

6600GT (MSI),AGP
FC3,kernel: 2.6.10-1.770_FC3
NVRM version: NVIDIA Linux x86 NVIDIA Kernel Module 1.0-7174 Tue Mar 22 06:44:39 PST 2005
GCC version: gcc-Version 3.4.3 20050227 (Red Hat 3.4.3-22.fc3)
no problems at all
Dragoran is offline   Reply With Quote
Old 04-10-05, 09:56 AM   #10
hamsta
Registered User
 
Join Date: May 2004
Posts: 21
Default Re: 6600GT, 7174, MSI Neo4SLI, 2.6.11.4-i386 Hang/Reboot

Quote:
Originally Posted by Dragoran
GCC version: gcc-Version 3.4.3 20050227 (Red Hat 3.4.3-22.fc3)
no problems at all
This is not the official stable gcc shipped by fedora. Do you have the testing version installed? Maybe there is a problem between fedora gcc and the nvidia driver?

My gcc looks like this:
gcc --version
gcc (GCC) 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)

rpm -q gcc
gcc-3.4.2-6.fc3



Cheers,

Jens
hamsta is offline   Reply With Quote
Old 04-10-05, 10:16 AM   #11
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: 6600GT, 7174, MSI Neo4SLI, 2.6.11.4-i386 Hang/Reboot

Stock FC3 here (with security updates)

$ gcc --version
gcc (GCC) 3.4.3 20050227 (Red Hat 3.4.3-22.fc3)
...

$ rpm -qa gcc
gcc-3.4.3-22.fc3

Sadly enough... it's no gcc problem.
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.
gilboa is offline   Reply With Quote
Old 04-10-05, 10:36 AM   #12
hamsta
Registered User
 
Join Date: May 2004
Posts: 21
Default Re: 6600GT, 7174, MSI Neo4SLI, 2.6.11.4-i386 Hang/Reboot

Quote:
Originally Posted by gilboa
Stock FC3 here (with security updates)

$ gcc --version
gcc (GCC) 3.4.3 20050227 (Red Hat 3.4.3-22.fc3)
...

$ rpm -qa gcc
gcc-3.4.3-22.fc3
Sadly enough... it's no gcc problem.
Aehm, maybe I am some kind of blind, but, I cannot find any security gcc update for FC3. So it would realy be nice to see, where this strange gcc comes from. Take a look here:

http://download.fedora.redhat.com/pu...pdates/3/i386/

As you see, no gcc update. The only place I can find that *.22.fc3 thing ist in testing?


Cheers,

hamsta
hamsta is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:26 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.