Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-07-05, 08:35 AM   #1
tanelius
Registered User
 
Join Date: Apr 2005
Posts: 2
Angry Very low fps in Enemy Territory

Hi!
I have very low fps in Enemy Territory..
Some facts:
-Im using Mandrake 10.1
-I have newest nVidia drivers installed and xorg.conf configured.
-I have P3 800mhz CPU, 512mb RAM, 32mb nVidia GF2 GTS Graphics Card.
-KDE 3.2

So, i get fps 5-25.. when i were running it on windows it worked fine..
glxgears gives me ~1300fps.
Its no matter what kind of configs i use in ET, same ****ty fps..
Any idea whats wrong? I haven't enabled fastwrites, but i think it doesn't matter?
tanelius is offline   Reply With Quote
Old 04-07-05, 08:46 AM   #2
slider129ca
Registered User
 
Join Date: Apr 2005
Posts: 4
Default Re: Very low fps in Enemy Territory

Well you wont get 1300FPS in ET, and GLXGEARS isnt the absolute best way of checking FPS... And with your system 5-20FPS is all you probally can get. and a 32MB Video card isnt very good for ET. And ET isnt one of the best graphics game.... Sorry to disapoint you, But thats how it is Hope some day ill see you on ET


Slider129ca
slider129ca is offline   Reply With Quote
Old 04-07-05, 09:43 AM   #3
tanelius
Registered User
 
Join Date: Apr 2005
Posts: 2
Default Re: Very low fps in Enemy Territory

Got it working! I Installed older drivers... now 60+ fps @ et!
tanelius is offline   Reply With Quote
Old 04-07-05, 11:03 AM   #4
slider129ca
Registered User
 
Join Date: Apr 2005
Posts: 4
Default Re: Very low fps in Enemy Territory

60FPS!??!?, how come i get only 53 with FX 5200 :-\ meh. Glad you got it working
slider129ca is offline   Reply With Quote
Old 04-08-05, 10:24 AM   #5
test1000
Registered User
 
Join Date: Jan 2005
Posts: 12
Default Re: Very low fps in Enemy Territory

I ALSO get low fps(5-10) in ET with 7174... this must be a serious bug.. Especially since ET is one of the few quality free 3d games on linux... When i installed 6629 i got my old fps back... I'm using 2.6.12-rc1-love1 kernel though, so it might be due to me not including something in that kernel. or something with the love patches/kernel(at first i could not even get the drivers and a lot of other things to work because i wasn't compiling in the needed things i believe)Comment Zander? Is ET in nvidias 'driver 3d performance test bucket' if the devs have such a thing.. or maybe it only contain latest games etc? :s
test1000 is offline   Reply With Quote
Old 04-28-05, 04:53 AM   #6
quadfour
Registered User
 
Join Date: Mar 2004
Posts: 83
Default Re: Very low fps in Enemy Territory

I am finding the exact same thing with only enemy territory. Something interesting though, I have 2 versions of Mandrake dual booting, this problem occurs on one and not the other. The one it does not occur on is my older 10.1 for x86_64 while the new version is 2005 for x86_64. Peformance in Q3 is normal (~260fps) and Ut2004 seems smoother, but getting about 10-20fps in ET only. Both distros are running the same version of X, just different kernels apart from the rest of the software. I will change kernels on the old distro to the same as 2005 (2.6.11-6mdk) and see if there is a change.

This is the output from ET showing that its working with opengl:

----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 7: 1152 864
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 1152x864
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: GeForce FX 5700/AGP/SSE2
Initializing OpenGL extensions
...GL_S3_s3tc not found
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...GL_EXT_compiled_vertex_array not found
...ignoring GL_NV_fog_distance
...ignoring GL_EXT_texture_filter_anisotropic
Initializing GLX extensions
...using GLX_SGI_swap_control
...using GLX_SGI_video_sync
XF86 Gamma extension initialized

GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce FX 5700/AGP/SSE2
GL_VERSION: 1.2 (1.5.3 NVIDIA 71.74)
GL_EXTENSIONS: GL_ARB_depth_texture GL_ARB_imaging GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_copy_depth_to_color GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_multi_draw_arrays GL_SUN_slice_accum
GLX_EXTENSIONS: GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIX_fbconfig GLX_SGIX_pbuffer
GL_MAX_TEXTURE_SIZE: 4096
GL_MAX_ACTIVE_TEXTURES_ARB: 4

PIXELFORMAT: color(24-bits) Z(24-bit) stencil(0-bits)
MODE: 7, 1152 x 864 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: multiple glArrayElement
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 2
texture bits: 0
multitexture: enabled
compiled vertex arrays: disabled
texenv add: disabled
compressed textures: disabled
anisotropy: 1.0
NV distance fog: disabled
Initializing Shaders
----- finished R_Init -----
quadfour is offline   Reply With Quote
Old 04-28-05, 05:23 AM   #7
quadfour
Registered User
 
Join Date: Mar 2004
Posts: 83
Default Re: Very low fps in Enemy Territory

Well now, this is interesting.

I have put the same kernel as 2005 on 10.1 and it is still working perfectly. So here is some info:

Old install:
xorg-x11-6.8.2-7mdk
kernel-2.6.11.6mdk-1-1mdk
NVIDIA-Linux-x86_64-1.0-7174-pkg2.run

New install:
xorg-x11-6.8.2-7mdk
kernel-2.6.11.6mdk-1-1mdk
NVIDIA-Linux-x86_64-1.0-7174-pkg2.run

Got to be something else going on... I will investigate.
quadfour is offline   Reply With Quote
Old 04-28-05, 10:41 PM   #8
quadfour
Registered User
 
Join Date: Mar 2004
Posts: 83
Default Re: Very low fps in Enemy Territory

Found the problem... the Mesa GL library, it was pretty much software rendering. I got rid of that and it was fine. You can check for things like this typing "glxinfo | grep render". It should say yes.
quadfour is offline   Reply With Quote

Old 04-28-05, 11:45 PM   #9
Kamel
Hardware Mass Murderer
 
Kamel's Avatar
 
Join Date: Oct 2003
Location: Jacksonville, FL
Posts: 1,035
Send a message via ICQ to Kamel Send a message via AIM to Kamel Send a message via MSN to Kamel Send a message via Yahoo to Kamel Send a message via Skype™ to Kamel
Default Re: Very low fps in Enemy Territory

enemy territory is notorious for its CPU usage, it's a real CPU hog. even on some of the highest end cpu's, ET wants more.

this isn't to say it can't run on slower systems, but that's a huge bottleneck you will run into.

i strongly suggest using ETPro when possible, etpro has a lot of optimised code just for linux that makes ET run much much better.
__________________
hardware murdered so far: geforce 5900u, deceised: sat on it. geforce 6600gt deceised: improperly mounted heatsink. 3 asus a7n8x-e deluxe motherboards, deceised: unsure. mobile amd xp2600 processor, deceised: chipped core due to compusa heatsink. dfi lanparty ultra b, deceised: unsure, third memory bank went out. samsung cd burner 48x40x48, deceised: unsure, will only read pressed cd's very slowly. samsung TH552C dvd burner (dual layer), deceised: same as other samsung . 10gb seagate 5200rpm drive, deceised: tried fixing a pin that was pushed into the drive by inserting an ide cable upside down. 40gb maxtor drive, deceised: maxtor manufacturer. 80gb western digital, deceised: unnatural causes. swan xt10, deceised: brutal pre-meditated murder, even video taped (it wasn't y2k compliant). logitech mx510, deceised: death by electricution. ati remote wonder, deceised: death by electricution.
Kamel is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
8800 GT and Ubuntu - Plymouth low resolution legluondunet NVIDIA Linux 3 06-24-12 04:22 PM
XCOM: Enemy Unknown trailer initiates mankind's last stand, is awesome News Archived News Items 0 06-04-12 08:30 PM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-31-02 12:59 AM
Low OpenGL Performance Instinct NVIDIA Linux 10 08-08-02 04:56 PM
low fps why??? nipster Benchmarking And Overclocking 4 08-07-02 03:35 PM

All times are GMT -5. The time now is 04:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.