Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-12-05, 09:38 PM   #1
mzand
Registered User
 
Join Date: Apr 2005
Posts: 1
Unhappy SuSe 9.2 install hangs with 6800

Very excited to get my new dual opteron 248 system, nVidia GeoForce 6800 SLI graphics card.

I am trying to install dual boot Win XP and SuSe Linux Pro 9.2

I am unable to complete the installation of SuSe Linux Pro 9.2. YAST works fine until setting graphics card and monitor settings in sax2. When I go to test the settings, I get the blank screen of death or a corrupted screen and the machine hardlocks. Re-booting I get GRUB, can boot WinXP, but am unable to SuSe boot at level 3, failsafe mode, etc.

Hardware:

MB: Tyan 2895 K8W
CPU: AMD Opteron 248 x2
Graphics: nVidia GeoForce 6800
Memory: 4 Gb EEC DDR
Monitor: Viewsonic VP191b

From other posts, it seems to be a driver issue with the nVidia board, although I applied the nVidia driver download during the install. sax2 detects the board and assigns it code 0x00c1. I have tried assigning the monitor VESA or LCD 1280 x 1024@75 Hz and 60Hz, but no joy.

Any help would be appreciated.

mszand@rochester.rr.com
mzand is offline   Reply With Quote
Old 04-13-05, 09:49 AM   #2
beebelo
Registered User
 
Join Date: Mar 2005
Posts: 8
Default Re: SuSe 9.2 install hangs with 6800

Quote:
Originally Posted by mzand
YAST works fine until setting graphics card and monitor settings in sax2. When I go to test the settings, I get the blank screen of death or a corrupted screen and the machine hardlocks. Re-booting I get GRUB, can boot WinXP, but am unable to SuSe boot at level 3, failsafe mode, etc.
I don't have much experience with Linux, but the same thing happened to me (with a different nVidia graphics card). Here are some suggestions:

1. Boot off the install CD again, and make sure you are installing the kernel-sources in the "Developer Packages". You will need that stuff, and SuSE didn't do it by default (for me). Going by memory here, but you will also eventually need "make", "gcc" and "binutils". I think I ended up installing most of the developer packages just to be sure...

2. When setting up your display stuff in sax2, unclick the higher res modes. There will be a message like 'starting in 1024x768 resolution', after you unclick the higher ones, underneath the selection box. In my case, sax setup in yast kept trying to make my system start in too high a res. Later, when you've gotten through the installation of the correct driver, you can begin to experiment with resolutions again. That SaX2 display "Test" was constant trouble for me. I've learned it's better to work with the text files directly (after you get through the initial installation.)

3. Your driver is not installed correctly, if you did it in yast. You have to do it manually. Go and download the latest driver from the nVidia site (it's now 7174). Print out the README.TXT -- it's HUGE, but you need to read it thoroughly and have it handy. (Print the HOWTO also, but it *does not* contain everything you need to know!

4. I am still having annoyance problems with mine (like spontaneous reboots when browsing screen savers in KDE). It's doubly difficult, being new to Linux.

5. Time and patience are also needed ....

Have lot's of fun!
;o)
beebelo is offline   Reply With Quote
Old 04-13-05, 02:08 PM   #3
SquireSCA
Gun-Monkey
 
SquireSCA's Avatar
 
Join Date: Aug 2004
Location: Atlanta, GA
Posts: 362
Default Re: SuSe 9.2 install hangs with 6800

Boot Linux into a console, not an X session.

Navigate to where you downloaded the NVidia driver to, in my case:

cd /home/dave

Log in as root(su) and type in the following 3 commands:

1) sh NVIDIA*
2) modprobe nvidia
3) sax2 -m 0=nvidia

That's it, throw the rest of that install guide away. When sax2 launches, go in and set the max rez of your monitor, and the lower resolutions that you want available, test it, exit, and log back into Suse and restart the x server...
__________________
Coolermaster Centurion5 w/Antec NeoHE 550W
Asus P5B Deluxe/Core2Quad 6600 at 2.4Ghz
4GB Corsair TwinX DDR2 800Mhz
BFG 8800GT OC Edition
Gateway 24" LCD
Dell 2005FPW 20.1" LCD
Creative Labs X-Fi/Logitech Z680 speakers
74GB WD Raptor/400GB Seagate SATA
Samsung 16x Dual-Layer DVDRW/Liteon 16X DVDROM
Vista 64bit
SquireSCA is offline   Reply With Quote
Old 04-14-05, 11:06 AM   #4
beebelo
Registered User
 
Join Date: Mar 2005
Posts: 8
Default Re: SuSe 9.2 install hangs with 6800

Quote:
Originally Posted by SquireSCA
1) sh NVIDIA*
2) modprobe nvidia
3) sax2 -m 0=nvidia

That's it, throw the rest of that install guide away.
What if you have more than one .run file fitting the wildcard "NVIDIA*" ?

Anyway, just an fyi: nVidia says the install README has been corrected/improved with version 7174, and in fact I had no problems installing off those directions. It is all done at the command prompt.
beebelo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
How to install Divx+player to SUSE linux guide... kaarelcool NVIDIA Linux 1 08-27-02 07:54 AM

All times are GMT -5. The time now is 06:16 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.