Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-13-05, 05:12 AM   #1
michael.bauer
Registered User
 
Join Date: Sep 2004
Posts: 62
Default Xid Errors with 71.74

Hi,

it seems that many users have still to deal with Xid errors even with the latest (71.74) drivers. Is there a way to get rid of them?

They occur after closing the glxgears window. The window closes but the program continues to run until I kill it explicitly. Other (own) GL apps work well and don't trigger that error. It could be a problem specially related to glxgears ...

Apr 13 11:37:41 mlbrechner kernel: NVRM: Xid: 23, L1 -> L0
Apr 13 11:37:41 mlbrechner kernel: NVRM: Xid: 13, 0002 beef3097 00004497 0000180c 00010000 00000800
Apr 13 11:37:45 mlbrechner kernel: NVRM: Xid: 23, L1 -> L0
Apr 13 11:37:45 mlbrechner kernel: NVRM: Xid: 13, 0002 beef3097 00004497 00001d94 000000f0 00000800
Apr 13 11:37:49 mlbrechner kernel: NVRM: Xid: 23, L1 -> L0
Apr 13 11:37:49 mlbrechner kernel: NVRM: Xid: 13, 0002 beef3097 00004497 00001d94 000000f0 00000800
Apr 13 11:37:53 mlbrechner kernel: NVRM: Xid: 23, L1 -> L0
Apr 13 11:37:53 mlbrechner kernel: NVRM: Xid: 13, 0002 beef3097 00004497 00001d94 000000f0 00000800
Apr 13 11:37:58 mlbrechner kernel: NVRM: Xid: 23, L1 -> L0
Apr 13 11:37:58 mlbrechner kernel: NVRM: Xid: 13, 0002 beef3097 00004497 00001d94 000000f0 00000800
Apr 13 11:38:02 mlbrechner kernel: NVRM: Xid: 23, L1 -> L0
Apr 13 11:38:02 mlbrechner kernel: NVRM: Xid: 13, 0002 beef3097 00004497 00001d94 000000f0 00000800
Apr 13 11:38:06 mlbrechner kernel: NVRM: Xid: 23, L1 -> L0
Apr 13 11:38:06 mlbrechner kernel: NVRM: Xid: 13, 0002 beef3097 00004497 00001d94 000000f0 00000800
Apr 13 11:38:10 mlbrechner kernel: NVRM: Xid: 23, L1 -> L0
Apr 13 11:38:10 mlbrechner kernel: NVRM: Xid: 13, 0002 beef3097 00004497 00001d94 000000f0 00000800

// vaio fs115m, Geforce 6200, mandrake 10.1 default kernel 2.6.8.1-12mdk
Attached Files
File Type: txt nvidia-bug-report.log.txt (75.2 KB, 154 views)
michael.bauer is offline   Reply With Quote
Old 04-13-05, 09:02 AM   #2
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Xid Errors with 71.74

You are not alone :/
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.
gilboa is offline   Reply With Quote
Old 04-13-05, 09:24 AM   #3
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Xid Errors with 71.74

Yeah, it seems like that XiDs are a common problem of every 6XXX card...

But you can try a few things...
1. disable the framebuffer ( set kernel boot parameter "vga=normal" or remove it )
2. Check if there're any updates for the vbios (mvktech.net) or on the vendor's webside
3. FIX for GeForce 6 Series Badness under linux (it's more or less the same as 2, but dangerous )
4. disable RenderAccel
5. use NvAGP instead of Linux's own implementation (or disable it)
6. run memtest86

and check if:
1. your card is overheating
2. Windows has the same problems
3. you still have problems, after you unplug/remove all not needed devices
4. you try lower resolutions / depth like 640x480 @ 16-bit
5. you can try CRT - output instead of DVI...

...

Last edited by chunkey; 04-13-05 at 11:23 AM. Reason: added lots of stuff and ideas
chunkey is offline   Reply With Quote
Old 04-13-05, 10:10 AM   #4
anrxc
Registered User
 
Join Date: Apr 2005
Posts: 2
Default Re: Xid Errors with 71.74

I have the same problem, GeForce2 MX 400 worked ok with all versions of the nvidia drivers on my machine: Matsonic mobo with SiS730s chipset. A few days back i got an FX5500 card and notorious Xid errors showed up.
I can start X only if AGP support is disabled (NvAGP "0") and the system is stable, anything else (NvAGP 1 2 3) ends up with a freeze.
I tried various versions of the drivers, some patched, on some i applyed patches, tried to disable and enable the acpi, disable fast writes, force agp 2x mode, disable RenderAccel..... nothing worked, X freezes cpu goes to 100%, I logged in from another machine and checked the logs:
NVRM: Xid: 6, ........


2.6.11.6 vanilla kernel
anrxc is offline   Reply With Quote
Old 04-13-05, 10:45 AM   #5
michael.bauer
Registered User
 
Join Date: Sep 2004
Posts: 62
Default Re: Xid Errors with 71.74

I forgot to tell...

My system nearly freezes during the Xid errors. The mouse does not react any more and I have to type the kill command without seeing what I type.

Shoud I do a kernel update or downgrade or is it unrelated with the kernel version?

Are there any known circumstances where we don't get the Xid errors or does every system with 71.74 driver have this problem?
michael.bauer is offline   Reply With Quote
Old 04-13-05, 10:51 AM   #6
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Xid Errors with 71.74

As far as I can tell it not related to the kernel. It's a driver/libGL bug.
(I may be wrong, though...)
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.
gilboa is offline   Reply With Quote
Old 04-16-05, 08:39 AM   #7
anrxc
Registered User
 
Join Date: Apr 2005
Posts: 2
Default Re: Xid Errors with 71.74

Is somenome willing to explain to me what does it mean when you don't use AGP support (NvAGP "0"), even though when starting X the nvidia module auto loads the agpgart... and how is that I get around 1000FPS in glxgears (around 50FPS in enemy-teritory) even though I don't use agp support as stated in xorg.conf, and
cat /proc/drivers/nvidia/agp/status shows it is disabled.
I am wondering this, 'cause my old GeForce 2 when using AGP support had only 300FPS in glxgears.
anrxc is offline   Reply With Quote
Old 04-16-05, 09:30 AM   #8
michael.bauer
Registered User
 
Join Date: Sep 2004
Posts: 62
Default Re: Xid Errors with 71.74

Hi,

Some people say that the problem is related to differing 2D 3D clocks. This could be solved by some overclocking tool, right? Zander, could you at least tell us if you would suggest this or if it's unrelated - no warranties of course. We don't need details, simply some suggestions or hints. I really don't like to flash the bios...
michael.bauer is offline   Reply With Quote

Old 04-16-05, 09:50 AM   #9
MadEgg
Registered User
 
Join Date: Apr 2003
Posts: 88
Default Re: Xid Errors with 71.74

michael.bauer, it is related apparently since many tried and it worked for them.
I flashed a bios with modified 2D/3D clocks(400/400 instead of 400/425) to my GF6800 Ultra and since I haven't had any more problems.
I can understand your hesitation but it is a fact that it does help to solve the problem. The question remains why nvidia-resellers are selling crippled video-cards.
__________________
Proud owner of GF 6800 Ultra AGP and GF 6600 AGP
MadEgg is offline   Reply With Quote
Old 04-16-05, 10:04 AM   #10
michael.bauer
Registered User
 
Join Date: Sep 2004
Posts: 62
Default Re: Xid Errors with 71.74

MaddEgg,

Can't the 2D 3D clocks be set without flashing? At least temporary. All overclocking tools work without bios flashing and can modify the 3d clock, right? So the right way would be to modify the 3d clock to match the 2d clock. Unfortunately my 6200Go isn't supported by the nvclock tool. Did anybody try to flash a 6200Go? This is quite risky since I cannot replace the card if its gone away to visit its ancestors.
michael.bauer is offline   Reply With Quote
Old 04-16-05, 11:11 AM   #11
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Xid Errors with 71.74

... Anyone can suggest a good FX6600GT bios?
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.
gilboa is offline   Reply With Quote
Old 04-16-05, 11:33 AM   #12
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Xid Errors with 71.74

Quote:
Originally Posted by michael.bauer
Unfortunately my 6200Go isn't supported by the nvclock tool. Did anybody try to flash a 6200Go? This is quite risky since I cannot replace the card if its gone away to visit its ancestors.
It is supported by the CVS version, unfortunetaly clocking has always crashed on my system: screen goes *totally* corrupted (when running X) or the system will freeze if you start X (when clocking the system from console).
LubosD is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVRM: Xid while using chromium browser blekot NVIDIA Linux 2 06-26-12 01:29 PM
Screen freeze NVRM: Xid error ciancaroll NVIDIA Linux 0 06-05-12 01:05 PM
Graphic errors and hangs after standby reini122 NVIDIA Linux 4 05-07-12 03:37 AM
Graphical errors: broken card? lapino NVIDIA GeForce 7, 8, And 9 Series 0 05-03-12 01:20 PM
Getting bizarre errors with driver install clutch NVIDIA Linux 1 09-14-02 09:53 PM

All times are GMT -5. The time now is 09:19 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.