Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Closed Thread
 
Thread Tools
Old 05-17-05, 06:31 PM   #157
nukem
Registered User
 
Join Date: Dec 2004
Posts: 226
Default Re: Trying to make headway into finding the Xid crashes source...

That would disable OpenGL, at least hardware support, if not totatly. My problem is that when using OpenGL apps I get the XiD error, otherwise my system is rock solid. People that get the XiD error randomly without being in OpenGL apps should try this, otherwise its a waste.
nukem is offline  
Old 05-18-05, 02:48 AM   #158
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Trying to make headway into finding the Xid crashes source...

xenofon,

glxgears usually needs much more time to lock the system.
While I can run glxgears for hours without a lock, any OpenGL games will lock the machine within 10 minutes.
Other then that, you seem to be my mirror of each other: Dual Athlon MP, AMD 762MP chipset, rock solid with Albatron FX5900, problems with FX6600GT...
Let me know if you find anything (I'll do that same)

Cheers,
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.
gilboa is offline  
Old 05-18-05, 12:10 PM   #159
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Trying to make headway into finding the Xid crashes source...

What about PMing zander, so we can know what the hell is going on...?
LubosD is offline  
Old 05-19-05, 08:38 AM   #160
Koradji
Registered User
 
Join Date: May 2005
Posts: 18
Default Re: Trying to make headway into finding the Xid crashes source...

Someone asked if this problem with PCI Express,
Yes, me.

Leadtek 6600 GT Extreme.
Gentoo.

Will post any observations, but i'm no guru. Any help/info i can give, please ask.

Last edited by Koradji; 05-19-05 at 07:00 PM.
Koradji is offline  
Old 05-21-05, 05:24 AM   #161
Koradji
Registered User
 
Join Date: May 2005
Posts: 18
Default Re: Trying to make headway into finding the Xid crashes source...

Someone mentioned taking out RAM helped. I know one of my RAM sticks is weaker in this machine. I can't adjust voltages or timings (properly), i have to run underclocked.
Didn't help me to take out the weaker stick, except dropping glxgears frame rate, and the crash taking a bit longer.

Someone mentioned that using the drivers from the nvidia site rather than the distro packeged ones helped them. Using them droped my framerate from ~8000 to ~6000 with glx gears, and the crash took maybe an extra 20 seconds, and left me with a moving mouse. Probably because frame rate wasn't as high.

I've noticed somewhat different behaviour if i run glxgears as root.
It often lets me still do stuff. Doesn't crash as hard. glxgears often starts moving again when shifted on the screen. eventually it dies just as bad, but i can get out before that, if i'm lucky.

I've noticed nvidia-settings shows temp climbing a lot quicker than i would expect, about 1C per second for the first 5-10 seconds. But the heat sink doesn't seem to get as hot as it's saying. (max 69 before crashing)
And that shouldn't be hot enough for it to crash.
I _REALLY_ don't want to void warranty by putting good cooling on it.

I did run for quite a long time with nv drivers instead, and couldn't get a crash. I'll run it some more with nv before trying the onboard ATI.
(which only just released any drivers at all. I bought the nvidia because the ATI didn't have drivers. *sigh*. I want open source graphics)

I did manage to get this crash with 2d (or at least not obviously 3d) with the nvidia drivers.

I would like to know very soon whether it's driver or hardware, for whether i return for refund or replacement. If i can get either.

Could it be a faulty chip batch?
Does someone have one card it fails on, and one identical not, in the same machine?
Does someone's card that fails, work fine in another same set-up machine?
Who is it that doesn't have this problem?

Can nvidia reproduce the bug?
__________________
The problem with open source drivers, is they work.

Last edited by Koradji; 05-21-05 at 05:50 AM. Reason: thought more
Koradji is offline  
Old 05-21-05, 08:07 AM   #162
Giz
Registered User
 
Join Date: May 2005
Posts: 1
Default Re: Trying to make headway into finding the Xid crashes source...

I have this problem too, but always with active mouse pointer and it's never come out of it. It only happens when I use the nvidia driver, never when I use nv. You might say its probably glx related then because nv doesnt support that, but when I turned on my computer this morning it crashed within 10 minutes while I wasnt running any 3D apps (only gaim, mozilla firefox, xmms and gnoemoe - which is the lightest program for the graphics card because its mostly text). And in windows it runs 3D apps fine, I've never had a problem there. So I'm quite sure its the driver that causes the crash.

I emailed linux-bugs@nvidia.com about this 2 weeks ago (I included a link to this topic, so they should know about it) and their great solution was: update your driver (I was running 6629 at the time). I did so not expecting it to get better...and I was right. They also tried to blame my game and machine but, as I explained above, that cant be it. Last thing I heard from them was at the beginning of this week that they were working on it...


I dont know if anyone here can use it, but here's the first part of my debug file (i dont know whats in the rest of the file, so I wont attach it. but if anyone can use drop me a pm and I'll send it.:

/proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86 NVIDIA Kernel Module 1.0-7174 Tue Mar 22 06:44:39 PST 2005
GCC version: gcc version 3.3.5 (Debian 1:3.3.5-8)
__________________________________________
/proc/driver/nvidia/cards/0
Model: GeForce3 Ti 200
IRQ: 169
Video BIOS: 03.20.00.16.25
Card Type: AGP
____________________________________________
/proc/driver/nvidia/agp/card
Fast Writes: Not Supported
SBA: Not Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000007:0x1f000104
____________________________________________
/proc/driver/nvidia/agp/host-bridge
Host Bridge: VIA Technologies, Inc. VT8374 P4X400 Host Controller/AGP BridgeFast Writes: Not Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000a07:0x00000104
____________________________________________
/proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled
____________________________________________
/proc/cmdline
root=/dev/hdc1 ro
____________________________________________
/proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 3
model name : Intel(R) Celeron(R) CPU 2.40GHz
stepping : 3
cpu MHz : 2341.365
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe pni monitor ds_cpl cidbogomips : 4620.28
Giz is offline  
Old 05-23-05, 03:44 AM   #163
cpbotha
Registered User
 
Join Date: May 2005
Posts: 7
Default Re: Trying to make headway into finding the Xid crashes source...

Okay everyone, maybe NVidia is listening...

My test case is now available in binary form as well. Download this tarball: http://visualisation.tudelft.nl/~cpb...ash-x86.tar.gz then unpack it and read the README.

You should be able to run this binary on ANY x86 Linux system newer or just as old as Debian 3.0. It should reproduce the reported X freeze: Xids in dmesg, WAIT()s in X.log, X is frozen, CPU at 100%, wait long enough and X unfreezes.

The source is available at: http://visualisation.tudelft.nl/~cpb...nvcrash.tar.gz

I can reproduce the X freeze on driver versions 7174, 7167 and 6629. On 6111 and 6106 only the application itself freezes during the destruction of the 3D windows. On 5336, there is no crash. So, there was a definite progression from 5336 (no freeze) through 6106 and 6111 (application freeze) through 6629 to 7174 (X freezes).
cpbotha is offline  
Old 05-23-05, 03:46 AM   #164
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Trying to make headway into finding the Xid crashes source...

I'll test your application later tonight.

Good work.
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.
gilboa is offline  

Old 05-23-05, 06:40 AM   #165
Koradji
Registered User
 
Join Date: May 2005
Posts: 18
Default Re: Trying to make headway into finding the Xid crashes source...

I don't need the app to crash my X (skt 939, 6600GT PCI express), 30 seconds with glxgears is all it takes. I'll try it anyway.

It doesn't seem to crash my gf's X (skt A, FX 5600XT). i get Xid errors in dmesg, but no crash.
(thats from two runs. it seems to like beef)
NVRM: Xid: 6, PE0004 02dc 00e2e2de 002874c4 00000000 01310107
NVRM: Xid: 12, COCOD 00000004 beef3901 00000039 00000af0 00000000
NVRM: Xid: 6, PE0004 0af0 00000000 0000fa50 01040af3 00000003
NVRM: Xid: 6, PE0004 04e8 00e2e2de 000008c4 00000000 00000000
NVRM: Xid: 6, PE0004 0af4 00000000 0000fdf8 01040af7 00000003
NVRM: Xid: 6, PE0004 04e8 00e2e2de 000008c4 00000000 00000000
NVRM: Xid: 6, PE0004 0af8 00000000 0000faa8 01040afb 00000003
NVRM: Xid: 6, PE0004 04e8 00e2e2de 000008c4 00000000 00000000
NVRM: Xid: 6, PE0004 0afc 00000000 0000f95c 01040aff 00000003
NVRM: Xid: 6, PE0004 0fec 00000000 00000054 07758fec 01310107
NVRM: Xid: 6, PE0004 17cc 0018eeea 00000068 00000000 01310107
NVRM: Xid: 6, PE0004 17cc 0018eeea 0000006c 00000000 01310107
NVRM: Xid: 6, PE0004 17cc 0018eeea 00000070 00000000 01310107
NVRM: Xid: 6, PE0004 17cc 0018eeea 00000074 00000000 01310107
NVRM: Xid: 6, PE0004 17cc 0018eeea 00000078 00000000 01310107
NVRM: Xid: 6, PE0004 17cc 0018eeea 0000007c 00000000 01310107

The program keeps putting out "NOT setting DisplayId" when something moves or covers a window (but not when playing with the cone).
I'll try to fiddle more, like not in the third X session, and with a much chunkier AGP card.
__________________
The problem with open source drivers, is they work.
Koradji is offline  
Old 05-23-05, 06:53 AM   #166
nukem
Registered User
 
Join Date: Dec 2004
Posts: 226
Default Re: Trying to make headway into finding the Xid crashes source...

I tried this on my AMD64 system and while the app does crash X does not. I also do not get the same Xid error that I usally do.

Here is what I got after running this app
Code:
NVRM: Xid: 6, PE0002 1ffc ffffffff 00000054 ffffffff 01310107
NVRM: Xid: 6, PE0002 02f8 00000000 00000054 000002fb 01310107
NVRM: Xid: 6, PE0002 02fc 00000000 00000054 000002ff 01310107
NVRM: Xid: 6, PE0002 0300 00000000 00000054 00000303 01310107
NVRM: Xid: 6, PE0002 0304 00000000 00000054 00000307 01310107
NVRM: Xid: 6, PE0002 0308 00000000 00000054 0104030b 01310107
NVRM: Xid: 6, PE0002 030c 00000000 00000054 0104030f 01310107
NVRM: Xid: 6, PE0002 0310 00000000 00000054 01040313 01310107
NVRM: Xid: 6, PE0002 0314 00000000 00000054 01040317 01310107
NVRM: Xid: 13, 0002 beef7b01 0000307b 00000404 00800080 00004000
NVRM: Xid: 6, PE0002 041c 00000000 00000054 0000041f 01310107
NVRM: Xid: 6, PE0002 0420 00000000 00000054 00000423 01310107
NVRM: Xid: 6, PE0002 0424 00000000 00000054 00000427 01310107
NVRM: Xid: 6, PE0002 0428 00000000 00000054 0104042b 01310107
NVRM: Xid: 6, PE0002 042c 00000000 00000054 0104042f 01310107
NVRM: Xid: 6, PE0002 0430 00000000 00000054 01040433 01310107
Normally I get

Code:
NVRM: Xid: 24, L2 -> L1
NVRM: Xid: 23, L1 -> L0
NVRM: Xid: 8, Channel 00000002
My crash only happens with newer games and I can fix it by running glxgears in the background, your crash probably has something to do with mine. I would suggest sending this to nvidia as well as zander, hopefully they can do something about it.
nukem is offline  
Old 05-23-05, 07:03 AM   #167
Koradji
Registered User
 
Join Date: May 2005
Posts: 18
Default Re: Trying to make headway into finding the Xid crashes source...

More on the testing on my gf's machine:

With the Cone app, i got Xid errors (as posted) ONLY the first two runs, not again in about 20 attempts.
Once or twice i temporarily had behaviour that looked a little crashlike, for a second or two, mostly after moving windows around then clicking crash, but it recovered.

Still haven't tried with the FX5800, cooling is going to be tricky.

I'm expecting my results on my own machine to look like Nukem's.
Edit:
My own machine, the nv drivers, all worked very nicely.
The nvidia drivers, It didn't crash my machine, i got these Xid errors:
NVRM: Xid: 23, L1 -> L0
NVRM: Xid: 6, PE0002 0184 beef0201 00000054 ff0018c0 01a1010b
NVRM: Xid: 23, L1 -> L0
NVRM: Xid: 13, 0002 beef4401 00000044 00000304 00000000 00000002
NVRM: Xid: 23, L1 -> L0
NVRM: Xid: 13, 0002 beef4401 00000044 00000304 00000000 00000002
NVRM: Xid: 23, L1 -> L0
NVRM: Xid: 3, C 00000002 SC 00000000 M 00000180 Data beef0348
NVRM: Xid: 23, L1 -> L0
NVRM: Xid: 2, CCMDs 00000002 0000357c 00000304 00000000 00001000
NVRM: Xid: 23, L1 -> L0
NVRM: Xid: 3, C 00000002 SC 00000002 M 00000198 Data beef4201
NVRM: Xid: 23, L1 -> L0
NVRM: Xid: 6, PE0002 0198 beef4201 00200180 00000000 00000000
NVRM: Xid: 23, L0 -> L0
NVRM: Xid: 6, PE0002 0198 beef4201 00000000 00000000 00000000

And it behaved very badly for about a minute, like a crash, but sorted itself out. Much like what it would do sometimes running glxgears as root.
Trying a few more...

(Sorry if it seems spammish to use the thread to document experiments as i go, but, it seemed as good a place to put notes as any)
__________________
The problem with open source drivers, is they work.

Last edited by Koradji; 05-23-05 at 07:23 AM. Reason: My own machine
Koradji is offline  
Old 05-23-05, 08:00 AM   #168
Koradji
Registered User
 
Join Date: May 2005
Posts: 18
Default Re: Trying to make headway into finding the Xid crashes source...

Trying a few more, i got the full crash eventually.
But still no more Xid errors.

I did repeat a previous observation a little more interestingly:
As i think i noted before, i crash in about 30 seconds running glxgears. When i start glxgears, temp starts rising fast, about 1C per second at the start, for a 10-20C rise before the crash. Hard to see after.
With Cones, temperature with them just sitting there, or making them spin, wasn't affected, CPU usage stayed low (about 24% with two lots open and spread around the screen) When i click "crash", if it does the crash-like thing, X CPU usage jumps, and GPU temperature jumps fast, just like in X Gears 10-20C, but not until the crash, and temp falls back to normal if it recovers from the crash.
What i noticed particularly was:
Ambient temp went up a good amount, (about half as much as core), so it was a significant amount of heat quickly. I never noticed that with glxgears, perhaps because it's much faster.

Maybe the crash X CPU usage, is also being GPU usage?

Should the Cones crash put so much load on the GPU as to raise temp 20C?
__________________
The problem with open source drivers, is they work.

Last edited by Koradji; 05-23-05 at 09:51 AM. Reason: Misleading error correction
Koradji is offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 03:27 AM

All times are GMT -5. The time now is 05:38 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.