Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Closed Thread
 
Thread Tools
Old 05-29-05, 05:36 AM   #205
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Trying to make headway into finding the Xid crashes source...

Quote:
Originally Posted by gilboa
I doubt it.
I moved the card to a second, newer (nForce2/400) single CPU machine (that runs Windows XP and FC3) and the card worked just fine.
No artifacts (Windows). no Xids (Linux.)

Cheers,
Do you use AGP GART or nVidia's AGP? I've played 3 hours ET on AGP GART w/o single crash .
LubosD is offline  
Old 05-29-05, 06:36 AM   #206
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Trying to make headway into finding the Xid crashes source...

AGPGART on both cases.
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.
gilboa is offline  
Old 05-29-05, 01:07 PM   #207
sir_tez
Registered User
 
Join Date: Apr 2005
Posts: 23
Default Re: Trying to make headway into finding the Xid crashes source...

Quote:
Originally Posted by LubosD
Do you use AGP GART or nVidia's AGP? I've played 3 hours ET on AGP GART w/o single crash .
Did you specify the nvidia agp in the kernel config or just agpgart alone?

Drivers you're running? x.org version? glibc?
sir_tez is offline  
Old 05-29-05, 04:38 PM   #208
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Trying to make headway into finding the Xid crashes source...

Quote:
Originally Posted by sir_tez
Did you specify the nvidia agp in the kernel config or just agpgart alone?
I don't know what you actually mean. I've compiled my kernel with AGPGART and specified NvAGP "2".

Drivers - the latest, of course
X.org - see my signature - 6.8.2
glibc-2.3.4
LubosD is offline  
Old 05-29-05, 09:38 PM   #209
sir_tez
Registered User
 
Join Date: Apr 2005
Posts: 23
Default Re: Trying to make headway into finding the Xid crashes source...

Is everyone who's running stably not using glibc 2.3.5? Perhaps if I downgraded to 2.3.4 this would work better. With 6629 I'm able to run longer (still hiccupping) but longer before I get hit with a crash.
sir_tez is offline  
Old 05-30-05, 10:39 PM   #210
nukem
Registered User
 
Join Date: Dec 2004
Posts: 226
Default Re: Trying to make headway into finding the Xid crashes source...

sir_tez: So do you think the problem is that nvidia may be compiling on glibc 2.3.4 while we are using 2.3.5? Is there any way to see what version the nvidia precompiled modules were compiled with(glibc 2.3.4 or glibc 2.3.5)? If we can not find this out I would ask Zander/nvidia what version and ask them to compile a beta version with glibc 2.3.5 and see if it fixes the problem for people.
nukem is offline  
Old 05-31-05, 02:22 AM   #211
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Trying to make headway into finding the Xid crashes source...

Me think you're barking on the wrong tree.
My bet is that it's X.org -> Driver -> AGP -> Card problem.
Had it been glibc problem every single FC3 user would have seen these problems. (Or at least most of them.)
My best guess is that Xids are generated by corrupted DMA transfers, timing problem, broken SMP support, etc and not from software version combinations.
Seems that every single problem with the driver (or hardware, such as over-heating) is immediately gets translated to Xid errors.

Cheers,
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.
gilboa is offline  
Old 05-31-05, 08:31 AM   #212
Saulzar
Registered User
 
Join Date: Apr 2005
Posts: 20
Default Re: Trying to make headway into finding the Xid crashes source...

So there's been no conclusion at all from this? Other than, "Xid is generic error message" (Which no doubt someone in the know could have pointed out immediately).

I've not been tracking it recently... I'm not very happy about the whole affair.
To boot the shop which sold me the card is giving nonsense. It's funny how in every other industry - if you are dissatisfied they bend over backwards to make sure you're set right, with computer hardware retailers they pass the buck and run.
Saulzar is offline  

Old 05-31-05, 12:59 PM   #213
sir_tez
Registered User
 
Join Date: Apr 2005
Posts: 23
Default Re: Trying to make headway into finding the Xid crashes source...

Quote:
Originally Posted by gilboa
Me think you're barking on the wrong tree.
My bet is that it's X.org -> Driver -> AGP -> Card problem.
Had it been glibc problem every single FC3 user would have seen these problems. (Or at least most of them.)
My best guess is that Xids are generated by corrupted DMA transfers, timing problem, broken SMP support, etc and not from software version combinations.
Seems that every single problem with the driver (or hardware, such as over-heating) is immediately gets translated to Xid errors.

Cheers,
You make an interesting point. As such, perhaps I shall install FC3 on a separate partition and see how it runs doom3 or some such game.....

Sir-Tez
sir_tez is offline  
Old 05-31-05, 05:40 PM   #214
cosurgi
Registered User
 
Join Date: May 2005
Posts: 6
Default Re: Trying to make headway into finding the Xid crashes source...

does everyone with this Xid problem have SMP systems? (dual processor, dualcore (for google))
cosurgi is offline  
Old 05-31-05, 05:46 PM   #215
cosurgi
Registered User
 
Join Date: May 2005
Posts: 6
Default Re: Trying to make headway into finding the Xid crashes source...

does everyone with this problem have SMP ?
cosurgi is offline  
Old 05-31-05, 09:58 PM   #216
sir_tez
Registered User
 
Join Date: Apr 2005
Posts: 23
Default Re: Trying to make headway into finding the Xid crashes source...

Quote:
Originally Posted by cosurgi
does everyone with this problem have SMP ?
No, not at all.
sir_tez is offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 03:27 AM

All times are GMT -5. The time now is 03:34 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.