Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Closed Thread
 
Thread Tools
Old 04-18-05, 02:54 AM   #37
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Trying to make headway into finding the Xid crashes source...

Quote:
Originally Posted by kmare
hi,
do you know where this "infinite loop" resides? in the kernel module, in the GL library or in the agp module? if it's not in the gl library maybe it is easier fixable.. of course I'm not a kernel developer so I might saying **** here...
If you look back at my first post, my assumption is that the a kernel polling function never completes (or fails) causing the GL library to polling function to infinite loop.
Without further nVidia ioctls (A type of IO system call) documentation, I can't really dig any dipper.

Cheers,
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.

Last edited by gilboa; 04-19-05 at 05:26 AM.
gilboa is offline  
Old 04-18-05, 08:10 AM   #38
kmare
Registered User
 
Join Date: Jul 2003
Location: greece
Posts: 180
Send a message via ICQ to kmare
Default Re: Trying to make headway into finding the Xid crashes source...

yeah.. sorry.. I missed that.. so we have to wait for an official fix from nvidia.. let's hope it'll be soon enough
kmare is offline  
Old 04-18-05, 09:05 AM   #39
mlaks
Registered User
 
Join Date: Mar 2005
Posts: 14
Default Re: Trying to make headway into finding the Xid crashes source...

Do you all still have this crash if you change the 2d and 3d speeds in thee nvidia bios to be equal? I have seen improvement (far fewer crashes) as soon as I got the NiBitor nvidia bios editor and fixed my bios.

I initially had a bios on my XFX 6600GT that had 3d speed set at 500 and 2d set at 300. I switched to 300 at both and now I have stability (relative).
I also notice that my device is running with
vChaim:~# cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: NVIDIA
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

Does this help ?
Mitche;;
mlaks is offline  
Old 04-18-05, 10:48 AM   #40
mlaks
Registered User
 
Join Date: Mar 2005
Posts: 14
Default Re: Trying to make headway into finding the Xid crashes source...

Well it goes to show:

I just ran my system for 9 hours. Now while surfing the net I get the freeze of the system. I cant move mouse.

I ssh from another machine and did top. 99% utilization of XFree86.
I did dmesg and last line is

NVRM: Xid: 6, PE0000 0484 0004a3fc 0000fd80 0000ffff ffff0000
same line is present in /var/log/syslog

Then I kill the top XFree process. Now I still cant access the keyboard or the mouse. I guess I must reboot system via ssh login.
Is there any other option I can use to get it working again other than reboot?

Any ideas?
Mitchell
mlaks is offline  
Old 04-18-05, 03:18 PM   #41
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Trying to make headway into finding the Xid crashes source...

Quote:
Originally Posted by mlaks
I initially had a bios on my XFX 6600GT that had 3d speed set at 500 and 2d set at 300.
Wow, really 500?

Std. speed for my card (GF6800U) is 425! Overclock even to 435 would kill my system....
LubosD is offline  
Old 04-19-05, 01:00 AM   #42
nagual.hsu
Registered User
 
Join Date: Feb 2005
Posts: 19
Default Re: Trying to make headway into finding the Xid crashes source...

Quote:
Originally Posted by mlaks
Well it goes to show:

Then I kill the top XFree process. Now I still cant access the keyboard or the mouse. I guess I must reboot system via ssh login.
Is there any other option I can use to get it working again other than reboot?

Any ideas?
Mitchell
Suppose you do not run X windows as default when you boot up your PC...
Have you tried start X from remote side after you kill X? (ie. ssh from another
machine and 'export DISPLAY=:0.0' and then 'rmmod nvidia' and then
'modprobe nvidia' and then 'startx')

Or maybe you can try 'SysRq' ..(Need some kernel settings when you compile
the linux kernel source)..This offers several sorts of hot keys to kill processes
or reboot or shutdown....

Or write a program to monitor the cpu utilization of X and once it detects some
thing happened, it can try to kill X and restart X automactically.
nagual.hsu is offline  
Old 04-19-05, 01:55 PM   #43
siersmak
Registered User
 
Join Date: Apr 2005
Posts: 23
Default Re: Trying to make headway into finding the Xid crashes source...

I've got similar issues on a Quadro FX 3400. http://www.nvnews.net/vbulletin/show...732#post591732

Please help, nvidia.... please.
siersmak is offline  
Old 04-22-05, 07:49 PM   #44
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Trying to make headway into finding the Xid crashes source...

Quote:
Originally Posted by siersmak
I've got similar issues on a Quadro FX 3400. http://www.nvnews.net/vbulletin/show...732#post591732

Please help, nvidia.... please.
nVidia people (Zander, Andy) seem to be very quiet lately... hopefully they are working to resolve these issues (AKA not on a vacation in the Caribbean…)

Cheers,
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.
gilboa is offline  

Old 04-23-05, 12:38 AM   #45
Ironi
Registered User
 
Join Date: Dec 2004
Posts: 86
Default Re: Trying to make headway into finding the Xid crashes source...

Quote:
Originally Posted by gilboa
nVidia people (Zander, Andy) seem to be very quiet lately... hopefully they are working to resolve these issues (AKA not on a vacation in the Caribbean…)
More likely, they've decided that it's Someone Else's Bug (i.e. it's not the fault of nVidia's hardware nor software). Although zander did ask people to provide an nvidia-bug-report.sh log and specific information ... and most people aren't doing that (myself included ).
Ironi is offline  
Old 04-23-05, 03:55 AM   #46
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Trying to make headway into finding the Xid crashes source...

.... I doubt it.
A. They can post a message saying: Xid problem: not ours. Take your case to x.org...
B. At least in my case, yanking out the FX6600 and return the old FX5900 solves the problem.
C. I've sent a couple of bug reports to nVidia; I've yet to get an answer... not even an automated one...

Cheers,
__________________
DEV-NG: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX680, F19/x86_64, Dell U2711.
DEV: Intel S5520SC, 2xX5680, 36GB, 5x320GB, GTX550, F19/x86_64, Dell U2711 (^).
SRV: Tyan Tempest i5400XT, 2xE5335, 8GB, 4x2TB, 9800GTX, F19/x86-64, Dell U2412.
LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F19/x86_64.
gilboa is offline  
Old 04-23-05, 09:19 AM   #47
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Trying to make headway into finding the Xid crashes source...

A. I suggest PM'ing Zander for his statement
B. Return to MX440 solves the problem too :-/
C. I've sent a few bug reports too, no reply

My system is stable now (knock, knock) - "Prefetch Caching" rulez - but RenderAccel=death.
LubosD is offline  
Old 04-27-05, 03:07 PM   #48
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Trying to make headway into finding the Xid crashes source...

These drivers are worse then hell.

I was playing Enemy Territory (RenderAccel turned off)...
Code:
Apr 27 20:58:31 localhost kernel: NVRM: Xid: 23,  L1 -> L0
Apr 27 20:58:31 localhost kernel: NVRM: Xid: 8, Channel 00000002
Apr 27 20:58:31 localhost kernel: NVRM: Xid: 23,  L0 -> L0
Apr 27 20:58:31 localhost kernel: NVRM: Xid: 13, 0002 beef3097 00004097 000008e4 0f4adf41 00040000
Apr 27 20:58:36 localhost kernel: NVRM: Xid: 13, 0002 beef3097 00004097 000008e4 0f4adf41 00040000
Apr 27 20:58:42 localhost kernel: NVRM: Xid: 23,  L1 -> L0
Apr 27 20:58:42 localhost kernel: NVRM: Xid: 8, Channel 00000002
MultiXid!
LubosD is offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 04:27 AM

All times are GMT -5. The time now is 03:39 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.