Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-15-05, 09:54 AM   #1
sherw1d
Registered User
 
Join Date: Mar 2005
Posts: 4
Default : Xv & Interlace Issues with FX5200PCI

Hi

I am trying to build a MythTV system based on an old
PIII (866Mhz) system with an I810 chipset. This is
based on a Redhat FC3 installation with latest
upgrades to all packages.

Due to the fact that the i810 chipset doesn't support
interlaced mode (and I want to drive and RGB SCART TV
directly from the VGA connector), I have purchased a
INNO-3D FX5200 128MB PCI card.

This works perfectly with a standard monitor at
various resolutions (including 1024x768, 800x600 &
720x576) and watching video with MPlayer and Myth-TV
is fine.

When connected to the TV via a cable that combines
H-Sync & V-Sync to form C-Sync, with the resolution
set to 720x576i, I have the following issues...

1) When viewing the terminal, the image is rock-solid,
however not all (50%) single pixel horizontal lines
are visible. This leads me to believe that the card
isn't actually doing interlacing, but sending the same
field twice. This is fine for the terminal and UI,
however when viewing video, surely true interlacing
should be applied. Could you clarify this behaviour
and tell me how to enable true interlacing for the
display. (NOTE: i have discovered that 6629 doesn't
have this behaviour. i.e. screen flickers as expected
with single pixel hirizontal lines).

2) When viewing video via Xv in Myth-TV, the display
is fine when the full video is displayed on the whole
screen, however if I attempt to use the letterbox
modes (implemented in Myth by making the destination
display for the transfer larger than the physical
display), then the image is not displayed correctly.

Basically, the whole image is displayed too high on
the screen and only the first frame is fully displayed
(subsequent ones don't update the bottom of the
picture). Moving to a standard monitor and simply
removing the 'interlace' option results is correct
behaviour again.

I have looked through the Mtyh-TV and Xorg code and
established that neither of these behave any
differently when interlacing is enabled on the display
therefore I can only conclude that this is an issue
with the NVIDIA driver.

I have tried the NV driver but this doesn't appear to
work correctly with Xv at all.

3) Is XvMC supported in this configuration? If so,
are there any configuration options I need to get it
working?


I have looked on the mailing archive for these
problems but I have been unable to find any concrete
information and no-one has answered my queries. I
have also now e-mailed nvdiia-bugs but have had no
response at all.

Daniel

Last edited by sherw1d; 04-15-05 at 10:19 AM.
sherw1d is offline   Reply With Quote
Old 04-29-05, 08:35 AM   #2
erich.boleyn
Registered User
 
Join Date: Apr 2005
Posts: 8
Default Re: : Xv & Interlace Issues with FX5200PCI

I posted a new thread "Interlaced video modes busted in 1.0-7174 driver". Hopefully answers will appear there from the NVidia guys.
erich.boleyn is offline   Reply With Quote
Old 09-18-05, 05:32 AM   #3
mijutu
Registered User
 
Join Date: Sep 2005
Posts: 10
Default Re: : Xv & Interlace Issues with FX5200PCI

Mee too.

I'm currently exploring possibilities how could I abandon the dxr3 dvd card and use a normal display adapter as a tv out device. The dxr3 with rgb modifications would otherwise be perfect solution for me, but unfortunately the osd capabilities of the card are just too limited.

I want to have a RGB output with correctly interlaced signal so that one line of pixels corresponds one stripe on the tv. The sync to vblank option would then probably help deliver interlaced tv programs to the tv without having to deinterlace the video in any way.

I tried to use this modeline to do it:
Modeline "720x576i" 13.5 720 720 784 864 576 580 584 625 interlace

I got the line that says interlace is supported:
(--) NVIDIA(1): Interlaced video modes are supported on this GPU

But just like sherw1d said: The card seems to send the same field twice.
I'm using the 1.0.7676 driver, xfree86 4.3.0 and GeForce FX 5200.
mijutu is offline   Reply With Quote
Old 04-15-06, 03:53 AM   #4
skandalfo
Registered User
 
Join Date: Apr 2006
Posts: 6
Default Re: : Xv & Interlace Issues with FX5200PCI

After installing driver 8756 in my Gentoo and testing some modelines, I got my VGA to PAL RGB SCART working... only to find the same problems with interlaced Xv output:

- half vertical resolution on Xv overlays.
- distorted 4:3 -> 16:9 zoom when mythtv enlarges the Xv overlay so that it's larger than the screen.

Any hope of this being fixed in some near future? I actually liked the quality of picture I was getting, as well as the square pixel hacked modeline I got working on my wide TV, but I had to go back to standard SVHS TV-out because of these issues...
skandalfo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange RedHat 7.3 issues with A7N266-C nforceuser NVIDIA Linux 8 09-27-02 03:16 PM
Overclocking issues... mcortz_2000 CPUs, Motherboards And Memory 5 09-16-02 03:41 PM
Major issues with 40 dets. malachi1313 NVIDIA Windows Graphics Drivers 9 09-02-02 11:46 PM
Is there a Microsoft patch for the refresh rate issues yet? Zarich NVIDIA GeForce 7, 8, And 9 Series 22 08-24-02 01:02 PM

All times are GMT -5. The time now is 06:24 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.