Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-17-05, 04:48 PM   #1
starfire01
Registered User
 
Join Date: Apr 2005
Posts: 2
Default Random black screen on xorg start

To All,

OK, I'm stumped. I have been living with an "oddity" in my system for several months now and I'm beginning to get fed up.

I run a number of Linux distros, primarily FC3 and RHEL4. I've been using the NVIDIA drivers ever since 6629 and update when new drivers are released. Each time I hope that the problem disappears but it does not.

The problem. Randomly, when starting X during boot, the system will freeze, the monitor will go into power savings mode and I have to hard reboot.

Observation: This is purely subjective, but if I move the mouse while xorg attempts to set up the display, the odds of success seems to go up - but it is not always successful. Similarly if I let the system boot unattended, it usually locks up but sometimes works.

The system:
AMD 2600+
Soyo VIA KT600 based mother board with 8X AGP
PNY GeForce 6600GT
Dell 2001FP Digital FP at 1600x1200

Where the lock up occurs:
Based upon successful Xorg.0.log files, the problem occurs after loading modules and testing modes and right when it tries to set the screen to 1600x1200

What I have tried:
1) Upgraded MB from KT333 based system, 4X AGP - lots of posts about KT333 problems - no joy
2) Noticed that clock rate (162.5) exceeded DDC max of 160 Mhz so reconfigured timings to reduce blanking interval (down to 130MHz) with NoDDC option - no joy
3) Removed all unnecessary graphic entries (Redhat Graphical Boot - rhgb) and NVIDIA "NoLogo" option - no joy
4) Always use the latest driver - no joy
5) Upgraded my power suppoy to 550W - no joy
6) Temporarily disabled glx - no joy

Again, I can get it to boot - more often than not when I'm futzing with the mouse. Always though it was a timing problem because of this.

Any help would be GREATLY appreciated!

Thanks
Starfire-1
starfire01 is offline   Reply With Quote
Old 04-20-05, 08:29 AM   #2
starfire01
Registered User
 
Join Date: Apr 2005
Posts: 2
Default Re: Random black screen on xorg start

Follow up to my own post.

It appears as if the heart of my problem has to do with the Dell 2001FP monitor when connected to the digital output. Examination of my Xorg.0.log file seems to indicate that the monitor believes that it is a 1280x1024 pixel panel and reports itself as such when the DDC module is loaded.

If one looks closely at the DDC response, you'll see the following:

(II) NV(0) : Supported additional Video Mode:
(II) NV(0) : clock: 162.0 MHz Image Size: 367 x 275 mm
(II) NV(0): h_active: 1600 h_sync: 1664 h_sync_end 1856 h_blank_end 2160 h_border 0
(II) NV(0): v_active: 1200 v_sync: 1201 v_sync_end 1204 v_blank_end 1250 v_border 0

So, it appears as if Dell uses the internal electronics of an older panel and specifically added this ONE mode to support the true, native resolution of 1600x1200. Hmmm.

To help resolve my startup problem, I specified this mode as well as the horizontal and vertical refresh precisely.
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell 2001FP (Digital)"
DisplaySize 410 310
# HorizSync 31.0 - 80.0
# VertRefresh 56.0 - 76.0
HorizSync 75.0 - 75.0
VertRefresh 60.0 - 60.0
Option "dpms"
Modeline "1600x1200" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
EndSection

I hope this helps others.
starfire01 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT240M - black screen with newer drivers > 275.33 and win 7 doktor5000 NVIDIA GeForce 200 Series 1 07-08-12 12:17 PM
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 05:40 PM
Black screen and lockup on startx. redmoose NVIDIA Linux 4 09-18-02 12:53 PM
kernel 2.4.19 and 2960 -> black screen osterhase NVIDIA Linux 7 08-22-02 07:24 PM

All times are GMT -5. The time now is 07:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.