Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-20-05, 05:55 PM   #13
linuxoid
Registered User
 
Join Date: Nov 2004
Posts: 35
Default Re: SUSE won't install on AMD64 with SATA HDD

Thank you, guys for all your help.

First, I've installed the Linux source and did make cloneconfig and prepare-all before installing a 6111 driver. It didn't work, most probably because it doesn't support the new 6600GT chip.

Second, I've uninstalled the 6111 and installed the latest 7174. It complained that it should be used with kernel at least 2.6.11 but I've only got 2.6.8. And I've installed it anyway. But how can I update the kernel if I don't even have the whole system working properly.

Then, I've changed the monitor vertical and horizontal frequencies - this didn't help. By the way, how do I know what values I should put in there, I've got LG 17" Studioworks CRT.

Could anyone please tell me how I can update my kernel to 2.8.11, sax2 to 4.8-142 and xorg to 6.8.2 knowing that I can only work in text mode. I've got the latest kernel source in tar.bz2, latest sax2 and xorg as rpm files. Do I have to delete the old ones first or I can install everything on top of them?

Thank you.
linuxoid is offline   Reply With Quote
Old 04-21-05, 07:37 AM   #14
va3rcc
The Ancient One
 
Join Date: Aug 2004
Location: London, Ontario, Canada
Posts: 89
Default Re: SUSE won't install on AMD64 with SATA HDD

I use the 7174 driver on my SuSE 9.2 system and it did not complain about the 2.6.8 kernel. Perhaps there has been a revision to it since I got mine at initial release. You can always revert to the 6629 driver as it supports your card. Aside from that if you install non-SuSE kernels a few things will cease to work. This is due to the fact that SuSE kernels are customized and contain features that vanilla kernels do not have. You can use Yast in text mode to install and remove software from the distribution. Just type yast at the command prompt. In order to get your GUI up for now edit your xorg.conf file (likely XF86Config on initial install and vice versa after Xorg upgrade) located in /etc/X11 and edit the section labelled "Device" and change the driver from nvidia to nv. As far as the vertical and horizontal refresh rates for your monitor they will be in the owners manual. If you do not have one you can get the info from the manufacturers web site. If you persist in using x86_64 you must use only the sax2 x86_64 packages. As far as the updates for Xorg you must install these manually. This is done from the command line with the command "tpm -Uvh --nodeps --force *.rpm".

In gereral memory management within the 2.6.8 kernel for x86_64 sucks when the system is under heavy load. Also there are issues with browser plugins. There are many other issues but I'll not get into them here. Unless you are a developer I suggest that you install the 32 bit version. If you still feel the need to run x86_64 then I suggest you obtain SuSE 9.3 (comes with kernel 2.6.11).
__________________
Ron Crouch

Last edited by va3rcc; 04-21-05 at 11:54 AM.
va3rcc is offline   Reply With Quote
Old 04-21-05, 10:29 AM   #15
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: SUSE won't install on AMD64 with SATA HDD

Quote:
Originally Posted by linuxoid
Then, I've changed the monitor vertical and horizontal frequencies - this didn't help. By the way, how do I know what values I should put in there, I've got LG 17" Studioworks CRT.
Your instructions manual will have it or it will be on the manufactures website. even google will fine the model and H/V sync rate. Here is a example of my mums which I inputted.

Code:
Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    HorizSync 30-70   VertRefresh 50-120
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 04-21-05, 06:31 PM   #16
linuxoid
Registered User
 
Join Date: Nov 2004
Posts: 35
Default Re: SUSE won't install on AMD64 with SATA HDD

LINUX ROCKS!

It's working! I can't believe I finally got it to work! It's not 100% stable, it needs intensive care but at least it's breathing. Huray!

Here's what I've done (I don't know what actually helped and what steps are really necessary, but I know for sure that when I did that it started working):

PART II

Referring to PART I earlier, when I started sax2 it froze. So I've done a new 64-bit Linux install in text mode again. I've only installed minimum packages necessary for it to work and install faster, X graphical system, KDE, Documentation, C++ and stuff, Development incl. kernel sources.

Everything installed without a problem. The system booted OK, I can see all the drives and everything. This menas that there was no problem with the SATA HDD ever at all. This is all only to do with the video card and nvidia drivers.

Have a copy of the nVidia drivers:
NFORCE-Linux-x86_64-1.0-0301-pkg1.run and NVIDIA-Linux-x86_64-1.0-7167-pkg2.run

Note the nVidia 7174 driver never worked for some reason even though it's newer than 7167!

login: root
password: root_password
#> init 3
#> cd /usr/src/linux
#> make cloneconfig
#> make prepare-all
#> cd /drivers_folder (folder where the nforce and nvidia drivers are)
#> sh NFORCE-Linux-x86_64-1.0-0301-pkg1.run (and follow the prompts)
#> sh NVIDIA-Linux-x86_64-1.0-7167-pkg2.run (and follow the prompts)

It complained about my kernell and system instability but I've installed it anyway because I didn't have any other choice. Well, this may be the reason why the system is not fully stable. It works fine with one user logged in. But if I log in as a second user (eg. root), the mouse cursor erases everything it points at for the second user. When I close the second session, the first user works fine. Occasionally it boots and the monitor outputs heaps of color garbage and freezes as it did before, but so far it only happened once. Well, anyway

#> cd /etc/X11

Now I edited the xorg.conf file. I like MC more than any other editor, it the same as the old-days Norton Commander. But you can use any editor you like. So

#> mc

Scroll down to xorg.conf and press F4 to edit it. I've changed the HF and VF for the monitor to 30-70 and 50-160 respectively, then changed the "nv" driver to "nvidia". That was it. Press F2 to save it and F10 to quit the editor and again F10 to quit MC. Then

#> modprobe nvidia
#> sax2 -m 0=nvidia

And there you are! I mean and there I was! Bingo! It showed the display configuration, I clisked to change the monitor. It never detected my monitor correctly and I couldn't find it in the list anyway, so I've selected VESA 1024x768@85 and that's it! I've rebooted and bingo again, KDE popped in and ... bla-bla-bla, you know the rest from the begining.

Hope this helps someone. I'll make a separate Tips,Tricks or Howto post on this.

Now I have to update everything to newer versions and hope it works even better.

Thank you all who gave me suggestions. I wouldn't have done it without your help!
linuxoid is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
How to install Divx+player to SUSE linux guide... kaarelcool NVIDIA Linux 1 08-27-02 07:54 AM

All times are GMT -5. The time now is 11:21 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.