Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-10-02, 09:41 AM   #1
Andre
GeForce4 Ti 4200
 
Join Date: Dec 2002
Location: 60 kms from Hannover, Germany
Posts: 8
Default GF4 Ti 4200 does not work with SuSE 8.0

Hello,

OS is SuSE 8.0:

I have a problem with my card,
a GF4 (4200 Ti) , 128 MB .

The computer is brand new and so is my
Linux installation.
I installed Nvidia's RPMs for SuSE 8.0
kernel and glx)from the command line,
X-server not running.

No complaints during installation with "rpm -ivh xxx" (all according to Nvidia's installation instruction).

I used the X-Config program "sax2" to configure the display. I set it to 1024-768, 16,7 million
colors, 85 Hz V-sync. I chose the correct Nvidia
graphic card and activated the glx-option in
the 3D-properties. I did not play with any
expert-options in sax2.
The monitor can handle the resolution and frequencies. I also have Window-XP running on the
same disk and there everything works fine.

When I then try to test the X-server the monitor
becomes black and stays like that.
The system freezes.
The same when I just save the X-configuration
and start the X-server by runlevel 5 i.e.
The only choice I then have is to power off.

When I press CTRL-ALT-BACKSPACE the system
powers off immediately.
When I use the card setting "VESA, 1024x768, 85 Hz" all is OK and at least I can use a GUI.

I don't know what is wrong.
I trusted in sax2 and did not try to find an
error in the X-configuration file.
Maybe I should, but what should I search for?
Andre is offline   Reply With Quote
Old 12-10-02, 11:16 AM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Is there anything relevant in /var/log/XFree86.0.log after one of these system freezes? That log file gets overwritten every time you start up X, though, so I'd say try to boot to runlevel 3 (text-mode login), and just startx from there. If it doesn't work, boot to runlevel 3 again, copy the log file to somewhere useful, make the changes you need to make to get a working system, and post the copy of the log file.

There may not even be anything useful in it, but it's possible.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 12-11-02, 01:36 AM   #3
Andre
GeForce4 Ti 4200
 
Join Date: Dec 2002
Location: 60 kms from Hannover, Germany
Posts: 8
Default

Hi, bwkaz,

Thanks for the tip, I will try and let you know.
So far, booting to runlevel 3 and doing a "startx"
crashes the systems.
Default window manager is kde.
I will check out what's happening with "startx twm".
Andre is offline   Reply With Quote
Old 12-11-02, 07:00 AM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

I think I remember someone saying recently that sax2 does in fact cause problems... might be worth looking into, anyway. Or post the XF86Config(-4 if it exists) file and someone can take a look at it.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 01-09-03, 08:49 AM   #5
Andre
GeForce4 Ti 4200
 
Join Date: Dec 2002
Location: 60 kms from Hannover, Germany
Posts: 8
Default

Hello bwkaz,

My problem still persists!

I promised to get back to you.
So, here is what I found out:

First of all I had the wrong driver at Mid-December 2002.
I learned that from this forum about two weeks after my initial post.
Then I removed the two old nvidia RPMs
(1.0-3123) and installed the two 1.0-4191 RPMs.
Those support 8x AGP cards which I do have.

After studying the driver's manual I set the
following options:

1.)
in /etc/X11/XF86Config:
...
Section "ServerFlags"
Option "AllowMouseOpenFail"
Option "NvAgp" "1" <---- this line
EndSection
...

2.)
in /etc/modules.conf:
...
################################################## ######################
# AGP
################################################## ######################

# Andre, 22122002
#pre-install mga /sbin/modprobe "-k" "agpgart"
#pre-install r128 /sbin/modprobe "-k" "agpgart"
#pre-install radeon /sbin/modprobe "-k" "agpgart"
#options agpgart agp_try_unsupported=1
options nvidia NVreg_ReqAGPRate=8 <--- this line

--- end of modifications

Anyway, when I start X from runlevel 3 I can see
that the X-server is trying to start up but one
second later the monitor becomes black again.
Nothing else is happening, it stays black until
I press <CTRL><ALT><DELETE> on the keyboard
and let the PC shut down.

The X-server log file /var/log/XFree86.0.log
does not complain, all seems to be well:
...
[31] 0 0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
[32] 0 0x000003c0 - 0x000003df (0x20) IS[b](OprU)

(II) NVIDIA(0): AGP 8X successfully initialized
(II) NVIDIA(0): Setting mode "1024x768"
-- end of /var/log/XFree86.0.log --

So, what is wrong?
Do you have any idea?

I will post four files:
1.) /etc/X11/XF86Config
2.) /etc/modules.conf
3.) $HOME/.X.err
4.) /var/log/XFree86.0.log
Attached Files
File Type: txt geforce4-ti-4200_does_not_work_with_suse_8.0.txt (40.4 KB, 221 views)
Andre is offline   Reply With Quote
Old 01-09-03, 09:46 AM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Hmm... I have no good ideas.

Does setting ReqAGPRate to 4 help maybe? Run depmod -a and reboot (or just make SURE the module is unloaded before you try starting X again) after you change modules.conf, of course.

Which AGP chipset is this?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 01-09-03, 10:04 AM   #7
Andre
GeForce4 Ti 4200
 
Join Date: Dec 2002
Location: 60 kms from Hannover, Germany
Posts: 8
Default

I check out whether "options nvidia NVreg_ReqAGPRate=4" makes any difference.

The chipset is "SiS 648 NorthBridge and 963 SouthBridge".

Thanks for replying.
Andre is offline   Reply With Quote
Old 01-10-03, 03:50 AM   #8
ribelles
Registered User
 
Join Date: Jan 2003
Posts: 6
Default

Quote:
Originally posted by Andre
I check out whether "options nvidia NVreg_ReqAGPRate=4" makes any difference.

The chipset is "SiS 648 NorthBridge and 963 SouthBridge".

Thanks for replying.
I installed Nvidia's RPMs (4191) for SuSE 8.1 and I get a black screen too. My computer has a Quadro 2 pro. The end of the log file /var/log/XFree86.log:

(II) NVIDIA(0): AGP 4X successfully initialized
(II) NVIDIA(0): Setting mode "1600x1200"

However, I previously had installed SuSE 7.3 with the same driver (nvidia-4191) and it works fine. I got the black screen after updating to SuSE 8.1. I don't know how to solve it.
ribelles is offline   Reply With Quote

Old 01-10-03, 04:10 AM   #9
michael
Registered User
 
Join Date: Nov 2002
Location: Munich
Posts: 30
Default

Hello,

your describing exactly the same problem that I have too.

My config :

ASUS Athlon Dual Board 2*MP
TI4200
SUSE 8.1 with 2.4.19.SUSE compiled for ATHLON SMP

I have tried the RPM's and the SRPM's. When switching from the

"nv" driver to "nvidia" the screen turns black and you'll have to reboot the machine with ctrl-alt-del.

Since mid december I am struggling with that. Today I will try it with a new monitor that has better frequency range.

Of yource if that is the reason I will post it.

Michael
michael is offline   Reply With Quote
Old 01-10-03, 05:44 AM   #10
Andre
GeForce4 Ti 4200
 
Join Date: Dec 2002
Location: 60 kms from Hannover, Germany
Posts: 8
Default

Especially to "ribelles" and "michael".

Someone assumes that my X server hangs when
trying to set the modes.
He wants me to deactivate AGP by
setting: Option "NvAgp" "0"
in /etc/X11/XF86Config .

I have not tried that, yet, so I can't tell
whether this helps or not.
Andre is offline   Reply With Quote
Old 01-10-03, 07:23 AM   #11
michael
Registered User
 
Join Date: Nov 2002
Location: Munich
Posts: 30
Default

Kevin L. Dupree sended me his config that looks like this (basically). I'll give it a try this afternoon

Section "Device"
Identifier "Custom Video Card"
Driver "nvidia"
Option "NvAGP" "3"
Option "NoLogo" "true"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

....

Maybe we could stick on this thread until the $&&%/ Problem is solved. I think a lot of people do have problems with suse 8.x and TI4200 and the new driver.

Greetings

Michael
michael is offline   Reply With Quote
Old 01-13-03, 06:54 AM   #12
ribelles
Registered User
 
Join Date: Jan 2003
Posts: 6
Default Warsage said

Warsage said:

"Alright guys, I solved the problem, thanks mostly to the forums here. It seems that "Assign IRQ to PCI VGA" must be enabled and "PnP OS" must be disabled in order for the drivers to work. These settings can be found in the system BIOS."

Could someone do it?
ribelles is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 12:54 AM
My SuSE 8.0 just totally BROKE. Help please!!! sephiroth762 NVIDIA Linux 6 10-09-02 02:30 PM
DMA error (SuSE 8.0) Darkgod NVIDIA Linux 3 10-08-02 10:55 PM
SuSe 8.0 Problems. GaMMa NVIDIA Linux 19 09-26-02 06:51 AM
Suse Linux 8.0 - Geforce 4 TwinView TA00 NVIDIA Linux 8 08-30-02 03:24 AM

All times are GMT -5. The time now is 08:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.