Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-07-02, 02:03 PM   #1
jinksed
Guest
 
Posts: n/a
Default X freezes when agp 4x is enabled

I've had this problem for a while. I have an nvidia geforce 2 mx 400 64mb with tv out that locks when i try using 4x agp. everything works fine if i use 2x. i have an asus tusl2-c mobo(i815 chipset). im using the latest drivers in slackware 8.1 2.4.18.

bash-2.05a# lspci
00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 04)
00:01.0 PCI bridge: Intel Corp. 82815 815 Chipset AGP Bridge (rev 04)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 02)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 02)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 02)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX] (rev b2)
02:0a.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 07)
02:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C (rev 10)
02:0c.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 02)
02:0c.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 02)
02:0d.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
bash-2.05a#


cat /proc/drvier/nvidia/apg:

Status: Enabled
Driver: AGPGART
AGP Rate: 2x
Fast Writes: Disabled
SBA: Disabled

bash-2.05a# cat card
Fast Writes: Supported
SBA: Not Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000017:0x1f000102
bash-2.05a#

bash-2.05a# cat host-bridge
Host Bridge: Intel i815
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000207:0x00000102
bash-2.05a#
  Reply With Quote
Old 08-07-02, 04:56 PM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

Don't play with things like FW, SBA and the agp rate. 4x is unstable in a lot of cases and compared to 2x it isn't that much faster (max about 1% or a little more) in some cases it is even a little slower. So just stick with 2x. It was a different case if AGP was totally off or only working in 1x.

There's one thing you can do if you really want 4x. Try to use another agp driver. The nvidia drivers support agpgart (linux kernel stuff) and "nvagp" the nt 4.0 agp support that is builtin into the drivers. Check /proc/driver/nvidia/agp what you are using. Then try to switch drivers using the NvAGP option in the XF86Config-4 file. Check the docs for more info on it.
Thunderbird is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Detonator 40.71 frenzy A-KO NVIDIA Windows Graphics Drivers 41 10-03-02 08:25 AM
crashes and freezes Lethal Weapon NVIDIA Linux 9 09-27-02 08:23 PM
AGP not being enabled on Geforce2 mx frankjr NVIDIA Linux 1 09-22-02 02:01 PM
agp 440bx/zx tntultar32 t00bad NVIDIA Linux 1 09-11-02 02:46 PM
How much heat can a GeForce4 Ti 4600 handle? Velkator NVIDIA GeForce 7, 8, And 9 Series 4 09-03-02 04:41 PM

All times are GMT -5. The time now is 10:02 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.